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Introduction

 

elcome to the Adobe® Photoshop® 

Limited Edition program—extraor-

dinary photo retouching, image 

editing, and color painting software. Whether you 

are a novice or an expert in image editing, the 

Adobe Photoshop program offers you the tools 

you need to get professional-quality results.

You’ll find that Adobe Photoshop LE excels as an 

art production tool, whether you are an art 

director or electronic publisher who needs to 

merge and edit color images, a photographer who 

wants to retouch proofs, or a graphic designer who 

is creating original or composite artwork, collages, 

or photo montages. The software is equally useful 

to animators who want to colorize images and 

produce audiovisual materials quickly, and to 

artists who want to create new artwork using the 

latest media and tools.

This program offers a limited set of features from 

the Adobe Photoshop 5.0 application, which  

includes these more powerful features:

 

•

 

Channels.

 

•

 

Layer effects and advanced layer features.

 

•

 

Actions palette for automating tasks.

 

•

 

Color separations, CMYK editing, spot color, 

and color management capabilities.

 

•

 

Paths.

 

•

 

Additional color modes.

 

•

 

Guides and grids.

 

•

 

Additional filters.

 

•

 

Advanced selection capabilities.

 

•

 

Advanced editing capabilities including multiple 

undoes, tracking and listing recent changes to an 

image, and 3-D transformations.

 

•

 

Type layers with re-editable text.

 

•

 

Wizards (Windows) and Assistants (Mac OS) 

that simplify multi-step operations such as 

exporting transparent images, resizing images, 

and creating contact sheets. 

 

•

 

Expanded scratch space support.

 

•

 

Support for importing PDF files.

 

•

 

Printing to PostScript 3 printers.

 

About this manual

 

The 

 

Adobe Photoshop LE User Guide

 

 provides 

detailed information about the Adobe Photoshop 

LE tools and commands. It is designed to be used 

as a reference tool in your everyday work with 

Adobe Photoshop. This cross-platform manual 

provides instructions for using Adobe Photoshop 

on both the Macintosh® and Windows® 

platforms. Any differences in procedures and 

commands between platforms are noted in 

the text.

Before using this manual, you need to install 

the application by following the instructions in 

the

 

 

 

installation

 

 

 

Read Me, located on the applica-

tionCD. 

W
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Introduction

 

This manual assumes you have a working 

knowledge of your operating system and its 

conventions, including how to use a mouse and 

standard menus and commands, and how to open, 

save, and close files. For help with any of these 

techniques, please see your Macintosh or 

Windows documentation. 

 

Learning Adobe Photoshop LE

 

Adobe Photoshop LE includes the following 

online documentation. For information on 

troubleshooting and technical support, see 

Appendix B, “Troubleshooting.”

 

The Adobe Photoshop LE Installation Read Me 

 

Contains system requirements, installation 

instructions, and registration information. 

 

The Adobe Photoshop LE User Guide

 

Contains 

complete information on using all Adobe 

Photoshop commands and features. 

 

The Adobe Photoshop LE Help system 

 

Is an inter-

active online guide that contains complete infor-

mation on Adobe Photoshop features. In addition, 

the Help system includes a description of 

Photoshop LE shortcuts. To access the Help system 

from the Photoshop program, from the 

Macintosh, choose Help > Help Contents; in 

Windows, choose Help > Contents or press F1. 

For more information about Adobe technical 

support resources, see the notice that came with 

this product.
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Chapter 1: Looking at the Work Area

 

he Adobe Photoshop Limited Edition work 

area includes the command menus at the 

top of your screen, the window containing 

the image you are editing, and a variety of tools 

and palettes that let you edit images and add 

 elements such as paint fills and layers. You can also 

add commands and filters to the menus by 

installing 

 

plug-in modules—

 

software programs 

designed to extend the functionality of Adobe 

Photoshop.

T

(M) Marquee

 (L) Lasso

(A) Airbrush

(E) Eraser

(S) Rubber stamp

(R) Blur

(P) Type Mask

(N) Line

(K) Paint Bucket

(H) Hand

Foreground color

Move (V)

Magic wand (W)

Paintbrush (B)

Pencil (Y)

Smudge (U)

Dodge (O)

Type (T)

Gradient (G)

Eyedropper (I)

Zoom (Z)

Background color

Switch colors (X)

(Q) Standard mode

(D) Default colors

Quick mask mode (Q)

Full screen mode (F)Standard screen
mode (F)

Full screen mode with menu bar (F)

Ellipse marquee
Single row marquee

Single column 
marquee

Crop (C)

Sharpen Burn

Sponge

Polygon lasso

Magnetic lasso

SELECTING TOOLS You select a tool from the toolbox by clicking the tool or pressing the shortcut 
key shown in parentheses in the illustration below. You can select hidden tools by dragging, or 
Option-clicking (Macintosh) or Alt-clicking (Windows) or by pressing Shift + the tool shortcut key.
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TOOLBOX OVERVIEW 

The elliptical marquee 
tool makes elliptical 
selections. 

The single row and single 
column marquee tools 
make 1-pixel-wide 
selections. 

The crop tool trims 
images.

The rectanglar marquee 
tool makes rectangular   
selections. 

The paintbrush tool 
paints brush strokes on 
an image.

The eraser tool erases 
pixels and restores parts 
of a saved image.

The airbrush tool paints 
soft-edged strokes on an 
image.

The lasso tool makes 
freehand selections.

The polygon lasso tool 
makes freehand and 
straight-edged selections. 

The magic wand tool 
selects similarly colored 
areas.

The move tool moves 
selections and layers.

The magnetic lasso tool 
draws selection borders 
that cling to the edges of 
objects. 
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The smudge tool 
spreads color across an 
area of an image.

The blur tool blurs hard 
edges in an image.

The sharpen tool 
sharpens soft edges in 
an image.

The rubber stamp tool 
creates a copy of an 
image.

The line tool draws 
straight lines.

The gradient tool fills 
an area with a gradual 
transition between two
colors.

The type mask tool 
creates selection borders 
in the shape of type.

The burn tool darkens 
areas in an image.

The sponge tool 
changes the color 
saturation of an area.

The type tool creates 
type on an image.

The dodge tool lightens 
areas in an image.

The pencil tool draws 
hard-edged strokes on 
an image.
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Using the toolbox

 

The tools in the toolbox let you select, paint, edit, 

and view images. The toolbox also contains 

controls for choosing the foreground and 

background colors, creating quick masks, and 

changing the screen display mode. The settings in 

the Brushes and Options palettes affect the 

painting or editing effects of most tools. 

For information on the foreground and 

background color controls, see “Choosing the 

foreground and background colors” on page 127. 

For information on the Quick Mask mode control, 

see “Using Quick Mask mode” on page 104.

 

To move the toolbox:

 

Drag the toolbox by its title bar.

 

Selecting tools

 

You select a tool by clicking its icon in the toolbox 

or dragging to select its icon from a pop-up menu. 

A small triangle to the right of a tool icon indicates 

that the tool has a pop-up menu of hidden tools. 

The hand tool moves an 
image within its window. 

The zoom tool magnifies 
and reduces the view of an 
image.

The eyedropper tool 
samples colors in an 
image.

The paint bucket tool 
fills similarly colored areas 
with the foreground color.



 

9

 

ADOBE PHOTOSHOP 5.0 LIMITED EDITION

 

User Guide

 

To select a tool:

 

Do one of the following:

 

•

 

To select a visible tool, click its icon in the 

toolbox.

 

•

 

To select a hidden tool, position the pointer on 

the overlying tool in the toolbox, and drag to 

highlight the tool you want.

 

Use the following shortcuts to select tools: 

 

• 

 

To select a tool quickly, press its keyboard 

shortcut on the keyboard. 

 

• 

 

To cycle through a set of hidden tools, press Option 

(Macintosh) or Alt (Windows) and click the visible 

tool, or press Shift + the hidden tool’s keyboard 

shortcut repeatedly. (The marquee tool shortcut 

cycles through only the rectangle and ellipse marquee 

tools.) 

 

Using the tool pointers

 

When you select most tools and position the 

mouse pointer on the image, the pointer matches 

the tool’s icon. This is the default standard tool 

pointer. The standard marquee, line, and gradient 

pointers appear as crosshairs. 

Each of the default pointers has a different 

 

hot spot

 

, 

the point where an effect or action begins. To use a 

tool with greater accuracy, you can switch to 

precise pointers, which appear as crosshairs 

centered around the hot spot. When you’re using 

the painting tools, you can also display the pointer 

as a brush shape reflecting the current brush size.

 

To set the tool pointer appearance:

 

1

 

Choose File > Preferences > Display & Cursors.

 

2

 

Do one of the following:

 

•

 

Click Standard under Painting Cursors, Other 

Cursors, or both to display pointers as tool icons.

 

•

 

Click Precise under Painting Cursors, Other 

Cursors, or both to display pointers as crosshairs. 

 

•

 

Click Brush Size under Painting Cursors to 

display the painting tool pointers as brush shapes 

representing the size of the current brush.

 

3

 

Click OK.

When you’re using the brush size pointer with very 

small brushes, the brush shape is surrounded by 

four dots for finer accuracy.

 

Standard Precise

Brush size
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The Painting Cursors options control the pointers 

for the eraser, pencil, airbrush, paintbrush, rubber 

stamp, smudge, blur, sharpen, dodge, burn, and 

sponge tools. 

The Other Cursors options control the pointers 

for the marquee, lasso, polygon lasso, magic wand, 

crop, eyedropper, gradient, line, and paint bucket 

tools.

 

 To change the appearance of some tool 

pointers, press Caps Lock. Press Caps Lock 

again to return to your original setting. The 

following list outlines the pointer changes: 

 

• 

 

Standard changes to precise. 

 

• 

 

Precise changes to brush size (painting 

tools only). 

 

• 

 

Brush size changes to precise (painting 

tools only).

 

Using palettes

 

Adobe Photoshop includes a number of palettes to 

help you monitor and modify images. By default, 

these palettes appear stacked together in several 

groups. You can display and hide these palettes as 

you work with an image.

 

To show or hide a palette:

 

Choose the appropriate Window > Show or 

Window > Hide command. 

Choosing a Show command displays the selected 

palette at the front of its group. Choosing a Hide 

command for a palette in a group hides the 

entire group.

 

Changing the palette display

 

You can change the arrangement and display of 

palettes and palette groups to optimize the work 

area on your desktop. Use the following 

techniques to organize palettes:

 

•

 

Press Tab to hide or display all open palettes and 

the toolbox. Press Shift+Tab to hide or display all 

open palettes, excluding the toolbox.

 

•

 

To make a palette appear at the front of its group, 

click the palette’s tab.
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•

 

To move an entire palette group, drag its title bar.

 

•

 

To rearrange or separate a palette group, drag a 

palette’s tab. Dragging a palette outside of an 

existing group creates a new group. 

 

Click the palette tab... and drag the palette to a 
new location.

Palettes are separated.

 

•

 

To move a palette to another group, drag the 

palette’s tab to that group.

 

Click the palette tab... and drag the palette to 
another group.

Palettes are merged.

 

•

 

To display a palette menu, position the pointer 

on the triangle in the upper right corner of the 

palette, and hold down the mouse button. 

 

•

 

To change the height of a palette (except the 

Color, Options, or Info palette), drag the size box 

at the lower right corner of the palette (Macintosh) 

or drag the lower right corner of the palette 

(Windows). To return the palette to the default 

size, click the zoom box (Macintosh) or the 

minimize/maximize box (Windows) in the right 

of the title bar. (If you have resized the palette, the 

first click restores the default size and the second 

click collapses the palette group.)

 

Click to collapse or expand palette.

Windows

Macintosh
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•

 

To collapse a group to the palette titles only, 

Option-click the zoom box (Macintosh) or Alt-

click the minimize/maximize box (Windows). You 

can also double-click a palette’s tab. You can still 

access the palette menu from a collapsed palette.

 

Setting the positions of palettes and 
dialog boxes

 

Adobe Photoshop saves the positions and 

groupings of all open palettes and the positions of 

moveable dialog boxes when you exit the program. 

If you prefer, you can make Photoshop always start 

with its default palette positions. You can also 

restore the palettes to these default positions at any 

time when working with the program.

 

To reset palettes to the default positions:

 

1

 

Choose File > Preferences > General.

 

2

 

Click Reset Palette Locations to Defaults.

 

To always start with the preset palette and dialog 
box positions: 

 

1

 

Choose File > Preferences > General.

 

2

 

Deselect Save Palette Locations. The change 

takes effect the next time you start Adobe 

Photoshop.

 

Using the Options palette

 

Each tool in the toolbox (with the exception of the 

type and type mask tools) has its own set of 

options, which appear in the Options palette. The 

name and appearance of this palette change, 

depending on the currently selected tool.

The Options palette contains some settings that 

are common to several tools (such as painting 

modes and opacity), as well as specialized options 

like the cloning settings for the rubber stamp tool. 

 

To display the Options palette:

 

Do one of the following:

 

•

 

Choose Window > Show Options. 

 

•

 

Double-click a tool in the toolbox (except the 

zoom or hand tool) to display the Options palette 

for that tool. 

 

•

 

Click a tool in the toolbox or press its keyboard 

shortcut, and press Return (Macintosh) or Enter 

(Windows) to display the Options palette for 

that tool.

Paintbrush options palette
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To return to a tool’s default settings:

Choose from the following:

• To return a tool to its default settings, click the 

tool in the toolbox and choose Reset Tool from the 

Options palette menu. 

• To return all the tools to their default settings, 

choose Reset All Tools from the Options palette 

menu. 

Using the Info palette

The Info palette provides information on the 

selected tool and on the color values of the image 

area beneath the pointer. Depending on the tool 

you’re using, you can also use the Info palette to 

measure size, distance, and angle of rotation. In 

most cases when a tool is in use, the Info palette 

displays the x and y coordinates of the pointer’s 

position in the image using the units of 

measurement you specify.

The Info palette also displays the following 

information: 

• When the marquee tool is in use, the Info palette 

displays the x and y coordinates of your starting 

position and the width (W) and height (H) of the 

marquee as you drag. This marquee size infor-

mation is displayed as long as the image contains 

a selection. 

• When the crop tool or zoom tool is in use, the 

Info palette displays the width (W) and height (H) 

of the marquee as you drag. The palette also shows 

the angle of rotation of the crop marquee.

• When the line tool or gradient tool is in use, or 

when you move a selection, the Info palette 

displays the x and y coordinates of your starting 

position, the change in X (∆X), the change in Y 

(∆Y), the angle (A), and the distance (D) as you 

drag. 

To use the line tool to measure distances in an 

image, define a line width of 0 in the Line Tool 

Options palette. 

• When you use the Scale or Rotate command, the 

Info palette displays the percentage change in 

width (W) and height (H), and the angle of 

rotation (A).

• When you move the pointer over the pixels in 

your image while using any of the color 

adjustment dialog boxes, the Info palette displays 

the before and after color values of the pixels. See 

“Previewing color values” on page 69 for complete 

information on how to use this feature. 

Customizing the Info palette

The Info palette displays two color readouts. You 

can change the color mode used for each of these 

readouts. You can also change the units of 

measurement used to display distance and size in 

the Info palette. 

To change the Info palette options:

1 Choose Palette Options from the Info palette 

menu.

2 For First Color Readout, choose one of the 

following display options: 

• Actual Color to display values in the current 

color mode of the image.
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• Any other option to display the color values in 

that color mode. See “Color modes and models” 

on page 53 for more information.

3 For Second Color Readout, choose one of the 

display options listed in step 2.

4 For Ruler Units, choose a unit of measurement.

5 Click OK.

To change the measurement units and the color 

readout modes, click the crosshair or 

eyedropper icon, respectively, in the Info palette to 

display a menu with these options.

Using context menus
In addition to the menus that appear at the top of 

your screen, Adobe Photoshop contains a number 

of context-sensitive menus. These menus display 

commands that relate to the active tool, selection, 

or palette. You can use context menus as a quick 

way to choose commonly used commands. 

To display context menus:

1 Position the pointer over an image or palette 

item.

2 Do one of the following:

• On the Macintosh, press Control and hold down 

the mouse button.

• In Windows, click with the right mouse button.

Viewing images
The hand tool, the zoom tools, and the Zoom 

commands let you view different areas of an image 

at different magnifications. You can also use the 

Navigator palette to control your view of an image, 

and you can open additional windows to display 

several views at once. 

Controlling the window display

The window controls at the bottom of the toolbox 

control how image windows in Adobe Photoshop 

are displayed.

A. Window controls

To change the display of image windows:

Click one of the following window controls:

• The left window control to display the image in 

a standard window, with a menu bar at the top and 

scroll bars on the sides. This is the default mode.

• The center window control to display the image 

in a full-screen window with a gray background 

and a menu bar but with no title bar or scroll bars. 

To scroll through the image, use the hand tool or 

the Navigator palette.

A
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• The right window control to display the image in 

a full-screen window with a black background, but 

with no title bar, menu bar, or scroll bars. To scroll 

through the image, use the hand tool or the 

Navigator palette.

Opening multiple views of the same 
image

Each image in Adobe Photoshop can have several 

open windows showing different views. For 

example, you might want to have multiple 

windows open for a single image to view the image 

at different zoom levels. The number of images 

and windows you can have open depends on the 

amount of memory you have available. A list of all 

open windows appears at the bottom of the 

Window menu.

To open additional windows:

Choose View > New View. 

Arranging multiple windows 
(Windows only)

In Windows, you can control how Adobe 

Photoshop displays multiple windows on-screen.

To arrange multiple windows:

Do one of the following:

• Choose Window > Cascade to display windows 

stacked and cascading from the top left to the 

bottom right of the screen.

• Choose Window > Tile to display windows edge 

to edge.

Moving the view of an image

You can view different areas of an image using the 

image window scroll bars or the hand tool.

To scroll with the hand tool:

1 Select the hand tool.

2 Drag in the image to move the image in its 

window.

Drag the hand tool. . . to move the view.

To use the hand tool while another tool is 

selected, hold down the spacebar as you drag in 

the image.
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Magnifying and reducing the view

The zoom tool and the Zoom commands let you 

magnify and reduce the view of an image. You can 

also zoom to an exact percentage of the original 

view by entering values in the zoom percentage 

box at the lower left of the window. The image 

window’s title bar displays the magnification or 

reduction percentage at all times. You can magnify 

up to 1600% of the original image view.

Note: The 100% view of an image displays an image 

based on the monitor resolution and the image 

resolution, not on the actual image dimensions. See 

“About resolution and image size” on page 25 for 

more information.

To zoom in:

Do one of the following:

• Select the zoom tool, and click the area of the 

image you want to magnify. Each click magnifies 

the image to the next preset percentage, and the 

magnified display is centered around the point you 

click. When you reach the maximum magnifi-

cation, the center of the zoom tool appears empty.

• Choose View > Zoom In to magnify to the next 

preset percentage.

Click. . . to zoom in.

To zoom out:

Do one of the following:

• Select the zoom tool. Hold down Option 

(Macintosh) or Alt (Windows) to activate the 

zoom-out tool, and click the area of the image you 

want to reduce. Each click reduces the view to the 

previous preset percentage.

• Choose View > Zoom Out to reduce to the 

previous preset percentage.

 Use the following shortcuts to zoom in or out 

with any tool selected:

• To activate the zoom-in tool, press 

Command+spacebar (Macintosh) or Ctrl+spacebar 

(Windows). 

• To activate the zoom-out tool, press 

Command+Option+spacebar/Ctrl+Alt+spacebar.

To magnify by dragging:

1 Select the zoom tool.

2 Drag over the part of the image you want 

to magnify.

Drag the zoom tool. . . to magnify the view.
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The part of the image enclosed by the zoom 

marquee is displayed at the maximum magnifi-

cation possible. 

Press Command+[+] (Macintosh) or Ctrl+[+] 

(Windows) to zoom in to the next preset 

percentage. Press Command+[-]/Ctrl+[-] to zoom 

out to the previous preset percentage.

To magnify or reduce to a specified percentage:

Enter a percentage value in the zoom percentage 

box at the lower left of the window.

To display an image at 100%:

Do one of the following:

• Double-click the zoom tool.

• Choose View > Actual Pixels.

• Click Actual Pixels in the Zoom Tool Options 

palette. 

Press Command+Option+0 (Macintosh) or 

Ctrl+Alt+0 (Windows) to display the image 

at 100%.

To change the view to fit the screen:

Do one of the following:

• Double-click the hand tool. 

• Click Fit on Screen in the Zoom Tool Options 

palette.

These options scale the zoom percentage and 

window size to the largest that can fit on your 

monitor and still contain the entire image.

To constrain the window size:

Deselect Resize Windows To Fit in the Zoom Tool 

Options palette. Deselecting this option maintains 

the same window size regardless of the image’s 

magnification, and can be helpful when using 

smaller monitors or when working with tiled 

views of an image.

 Use the following shortcuts to change the image 

magnification without resizing the window:

• Press Command+0 [zero] (Macintosh) or Ctrl+0 

[zero] (Windows) to fit the image in the window.

• Press Command+Option +[+] (Macintosh) or 

Ctrl+Alt+[+] (Windows) to magnify the image 

without resizing the window.

• Press Command+Option+[-] (Macintosh) or 

Ctrl+Alt+[-] (Windows) to reduce the image view 

without resizing the window.

Using the Navigator palette

The Navigator palette lets you quickly view 

different areas of an image and change the magni-

fication of your view. This palette displays a 

thumbnail of the image and a rectangle, the view 

box, representing the boundaries of the image 

window. You can change the color of the view box 

from its default red.

A. Zoom percentage B. Zoom out
C. Zoom slider D. Zoom in

B CA D
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To move the view of the image:

Do one of the following:

• Drag the view box in the Navigator palette.

• Click in the thumbnail. The new view includes 

the area you click.

To magnify or reduce the view:

Do one of the following:

• Click the zoom in or zoom out button.

• Drag the zoom slider at the bottom of the 

palette.

• Enter the percentage of magnification or 

reduction you want, and press Return 

(Macintosh) or Enter (Windows).

 To zoom to the specified percentage and keep 

the zoom percentage box highlighted, hold 

down Shift while pressing Return/Enter.

• Hold down Command (Macintosh) or Ctrl 

(Windows) and drag over the area of the 

thumbnail that you want to magnify.

210% view of image View in Navigator palette

To change the color of the view box:

1 Choose Palette Options from the Navigator 

palette menu.

2 Do one of the following:

• To use a preset color, choose an option for Color.

• To define your own color, click the color box or 

choose Custom from the Color pop-up menu; 

then choose a color (see “Using the Swatches 

palette” on page 144), and click OK.

Using plug-in modules
Adobe Photoshop plug-in modules are software 

programs developed by Adobe Systems, and by 

other software developers in conjunction with 

Adobe Systems, to extend the functionality of the 

Adobe Photoshop program. Adobe Photoshop 

includes plug-in modules for importing and 

exporting images and for producing special 

effects. 

Installing plug-in modules

To use a plug-in module that has been developed 

by Adobe Systems, you must first install it into the 

plug-ins folder for Adobe Photoshop. To install a 

third-party plug-in module, follow the installation 

instructions included with the module. Once 

installed, the modules appear in the Import or 

Export menu, as file formats in the Open, Save As, 

and Save a Copy dialog boxes, or as filters in the 

Filter submenus.
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To install an Adobe Systems plug-in module:

Do one of the following:

• On the Macintosh, drag a copy of the module

to the Plug-Ins folder inside the Adobe Photoshop 

5.0 LE folder. 

• In Windows, copy the module into the Plug-Ins 

subdirectory in the Photoshop 5.0 LE directory.

Setting plug-ins preferences

When you install Adobe Photoshop LE and 

include the plug-in modules in the installation, 

these files are automatically placed in the Adobe 

Photoshop Plug-Ins folder (Macintosh) or the 

Plug-Ins directory (Windows). You can add new 

plug-ins or move the modules to a new location. 

If you move the plug-ins to a different location, 

you must change the Plug-Ins preference setting 

to enable the application to locate the plug-ins. 

(But if you change the preference setting to point 

Photoshop to a different folder than the Plug-Ins 

folder, you won’t be able to see the default plug-ins 

installed with Photoshop.) Alternatively, you can 

create a shortcut to the plug-ins: inside your Plug-

Ins folder, you can create a shortcut to another 

folder with plug-ins.

To set plug-ins preferences:

1 Choose File > Preferences > Plug-Ins & Scratch 

Disk. 

2 Click Choose, and select a folder or directory 

from the list. (Do not select a location inside the 

Plug-Ins folder. If you do, you won’t be able to see 

all of your plug-ins.) To display the contents of a 

folder, click Open (Macintosh); double-click the 

directory (Windows) to display its contents.

3 When you have highlighted the new plug-ins 

folder, click Select (Macintosh) or OK (Windows).

4 Restart Adobe Photoshop.

 On the Macintosh, to select the plug-ins 

location immediately upon starting Adobe 

Photoshop, press Command+Option as you launch 

the program.
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Setting preferences 

 

Adobe Photoshop includes numerous program 

settings, which are stored in a 

 

preferences file. 

 

This 

file is located in the Preferences folder in your 

System Folder (Macintosh) or in the Prefs subdi-

rectory inside the Photosle folder (Windows). The 

settings stored in this file include general options, 

display options, tool options, ruler units, and 

options for exporting information from the 

Clipboard. Most of these options are set in dialog 

boxes that can be opened through the Preferences 

submenus in the File menu. Preference settings are 

saved each time you exit Adobe Photoshop.

For information on a specific preferences option, 

see the Index.

 

To restore all of Adobe Photoshop’s preferences to 
their default settings:

 

Do one of the following:

 

•

 

On the Macintosh, open the Preferences folder 

in the System Folder and drag the Adobe 

Photoshop 5.0 LE Prefs file to the Trash. 

 

•

 

In Windows, delete the Adobe Photoshop 5 LE 

Prefs.psp file, located in Program 

files/Adobe/Photoshop 5.0 LE/Prefs. 

A new Preferences file will be created when you 

next start Adobe Photoshop.

 

Using Adobe Online Services

 

For more information about Adobe products, 

you can access extensive customer support 

information on the Adobe Web site on the World 

Wide Web. 

To open the Adobe Web site, enter the URL 

http://www.adobe.com in your Web browser. To 

launch the Adobe Home Page directly from 

Photoshop LE, choose File > Adobe Online or 

click the icon at the top of the tool bar. 
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Chapter 2: Getting Images into 
Photoshop

mages can be brought into the Adobe 

Photoshop Limited Edition program by 

importing in a variety of file formats; by 

scanning a photograph, a slide, or an image; 

or by capturing images from video.

This chapter contains an overview of the basic 

resolution and file size concepts essential for 

producing a high-quality image. It also provides 

instructions on how to create, open, and import 

images in Adobe Photoshop, how to produce a 

high-quality scan, and how to adjust the 

resolution and size of an image.

About bitmap images and vector 
graphics
Computer graphics fall into two main 

categories—bitmap images and vector graphics. 

Understanding the difference between these two 

types of images is useful when you’re creating and 

editing digital images.

Bitmap images

Bitmap images, also called raster images, use a grid, 

or raster, of small squares known as pixels to 

represent graphics. Each pixel in a bitmap image 

has a specific location and color value assigned 

to it. For example, a 1-inch circle in the lower left 

corner of the page is made up of the collection 

of pixels in that location, colored to give the 

appearance of a circle. When working with bitmap 

images, you edit groups of pixels rather than 

objects or shapes. Images created in Adobe 

Photoshop are bitmap images.

Because they can represent subtle gradations of 

shades and color, bitmap images are the most 

common electronic medium for continuous-tone 

images, such as photographs or images created in 

painting programs. Bitmap images are resolution-

dependent—that is, they represent a fixed number 

of pixels. As a result, they can appear jagged and 

lose detail if they are scaled on-screen, or if they 

are printed at a higher resolution than they were 

created for.

Vector graphics

Vector graphics consist of lines and curves defined 

by mathematical objects called vectors. Vectors 

describe graphics according to their geometric 

characteristics. For example, when you draw a 

1-inch circle in a vector-based program, the 

program creates the circle based on its shape and 

size. You can then move, resize, or change the color 

of the circle without losing the quality of the 

graphic. Graphics created in Adobe Illustrator® are 

vector graphics.

I
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Vector graphics are resolution-independent—that 

is, they are not defined by a fixed number of pixels 

and so are automatically scaled to appear crisp and 

sharp on any output device at any resolution. As a 

result, vector graphics are the best choice for type 

(especially small type) and bold graphics, such as 

logos, which require crisp, clear lines that can be 

scaled to many sizes.

Note that because computer displays are made up 

of a grid of pixels, both vector and pixel images are 

displayed as pixels on-screen. Vector-based pro-

grams render their shapes into pixels for display.

Bitmap images are good at reproducing the subtle 

shading found in continuous-tone images, such as 

photographs. However, bitmap images are resolution- 

dependent and thus can show jagged edges when 

magnified or printed at a higher resolution than they 

were created for.

Vector graphics display or print at the resolution 

available on the displaying or printing device. As a 

result, such graphics enlarge well and are good at 

reproducing crisp outlines and details.

24:1 zoom3:1 zoom

24:1 zoom3:1 zoom

BITMAP VS VECTOR A bitmap image consists of pixels, whose color and location on a grid determine the 
appearance of the image. A vector graphic is defined by mathematical objects called vectors, which determine 
the geometric characteristics of the graphic. When working with vector graphics, you edit shapes and objects 
rather than groups of pixels.
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Determining image size and 
resolution
In Adobe Photoshop, you determine the size of an 

image either by specifying pixel dimensions—to 

determine the size of the image on a monitor or 

video display, or by specifying print dimensions 

and image resolution—to determine the 

maximum size and resolution at which you can 

print the image.

An understanding of the relationship between 

pixel dimensions, resolution, and file size is key to 

understanding how Adobe Photoshop displays 

and produces output.

About resolution and image size

Several concepts are important when discussing 

the characteristics of bitmap images: pixel dimen-

sions, image resolution, output resolution, and 

screen frequency. The following sections discuss 

these characteristics. Another type of resolution, 

called bit resolution or pixel depth, is important 

when considering how color is displayed on-

screen. For information on bit resolution, see 

“About pixel depth” on page 56.

Pixel dimensions Every bitmap image contains a 

fixed number of pixels, measured in pixel height 

and pixel width (the number of pixels displayed 

along the height and width of the image, respec-

tively). The total number of pixels determines the 

file size, or the amount of data in the image. Pixel 

dimensions, along with the size and setting of the 

monitor, determine how large an image appears 

on-screen. A typical 13-inch monitor displays 640 

pixels horizontally and 480 vertically. Larger 

monitors can usually be set to display a varying 

number of pixels, for example, from 640 by 480 

pixels, at which setting the pixels may be quite 

large, to 1152 by 870 pixels, at which setting the 

pixels are small.

If you’re planning to display an image online (on a 

Web page, for example), your maximum image 

size is determined by the lowest pixel dimensions 

of the monitors used to display your image. For 

example, if your audience will view your image on 

a 13-inch monitor, you will probably want to limit 

the size of your image to 640 by 480 pixels.

Image resolution The number of pixels displayed 

per unit of length in an image is called the image 

resolution, usually measured in pixels per inch 

(ppi). An image with a high resolution contains 

more, and therefore smaller, pixels than an image 

of the same dimensions with a low resolution. For 

example, a 1-inch-by-1-inch image with a 

resolution of 72 ppi contains a total of 5184 pixels 
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PIXEL DIMENSIONS AND MONITOR RESOLUTION  Regardless of the print size specified for an image, the size 
of an image on-screen is determined by the pixel dimensions of the image and the monitor size and setting. 
A large monitor set to 640 by 480 pixels uses larger pixels than a small monitor with the same setting. In most 
cases, default Macintosh monitor settings are designed to display approximately 72 pixels per inch; default PC 
monitor settings typically display 96 pixels per inch.

13" Monitor, 640 x 480 setting

21" Monitor, 1024 x 768 setting

15" Monitor, 640 x 480 setting

21" Monitor, 640 x 480 setting

15" Monitor, 832 x 624 setting

Image size: 640 x 480 pixels, 

Print size: 288 ppi (2.22" x 1.67")



27ADOBE PHOTOSHOP 5.0 LIMITED EDITION
User Guide

(72 pixels wide x 72 pixels high = 5184). The same 

image with a resolution of 300 ppi would contain 

a total of 90,000 much smaller pixels. 

72-ppi and 300-ppi images; inset zoom 350% 

Because they use more pixels to represent each 

unit of area, higher-resolution images can usually 

reproduce more detail and subtle color transitions 

when printed than lower-resolution images. 

However, once an image has been scanned or 

created at a given resolution, increasing the 

resolution in Photoshop will not usually improve 

the image quality because in this case, Photoshop 

must in effect spread the same pixel information 

across a greater number of pixels. 

The proper image resolution to use for an image 

depends on how you intend to display or 

distribute the image. Using too low a resolution 

for a printed image results in pixelation—large 

pixels that produce very coarse-looking output. 

Using too high a resolution (pixels smaller than 

what an output device can reproduce) increases 

the file size unnecessarily and may increase the 

time required to print or distribute the image. 

Monitor resolution The pixel setting of the monitor 

along with the size of the monitor determines the 

size (and therefore density) of the monitor pixels. 

When converting printed images to on-screen 

images and translating image resolution into pixel 

dimensions, it’s useful to know that the default 

resolution of a Macintosh monitor is typically 72 

dpi; the default resolution of a PC monitor is 

typically 96 dpi.

In Photoshop, image pixels are translated directly 

into monitor pixels. This means that when the 

resolution of an image is higher than the monitor 

resolution, the image appears larger on-screen 

than its specified dimensions. For example, when 

you display a 1-inch-by-1-inch image with a 

resolution of 144 ppi on a 72-dpi monitor, it 

appears in a 2-inch-by-2-inch area on-screen. 

Because the monitor can display only 72 pixels per 

inch, it needs 2 inches to display the 144 pixels that 

make up one edge of the image.

Printer resolution If you are preparing images for 

print, it’s important to understand that printer 

resolution—that is, the number of dots per inch 

(dpi) that an imagesetter or laser printer produces 

—is usually proportional to, but not the same as, 

image resolution—that is, the number of pixels 

that make up an image and that determine the size 

of the image on-screen. Most laser printers have 

output resolutions of 300 dpi to 600 dpi and produce 

good results with images from 72 ppi to 150 ppi.

72 ppi 300 ppi
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IMAGE RESOLUTION AND SCREEN FREQUENCY To ensure good-quality output when printing with a halftone 
screen, you need to choose an image resolution based on the screen frequency of the printing device. In 
general, an image resolution from 1.5 to 2 times the screen frequency gives the best results. For very coarse 
screens, an even lower resolution may produce good results.

133 lpi: High-quality screen 

typically used to print four-

color magazines.

85 lpi: With coarse screens, resolutions 

at the low end of the range can produce 

good results.

177 lpi: With fine screens, only resolutions at 

the high end of the range produce good results.

177 lpi: Very fine screen typical-

ly used for annual reports and 

images in art books.

85 lpi: Average screen often used 

to print newspapers.

65 lpi: Coarse screen common-

ly used to print newsletters 

and grocery coupons.

170 ppi (2 x 85 lpi) 128 ppi (1.5 x 85 lpi) 354 ppi (2 x 177 lpi) 266 ppi (1.5 x 177 lpi)
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High-end imagesetters can print at 1200 dpi, 2400 

dpi, or higher and produce good results with 

images from 200 ppi to 300 ppi.

Screen frequency and image resolution Many 

commercial and desktop printers use halftone 

screens, which consist of printer dots called 

halftone cells, to print grayscale images and color 

separations. Screen frequency, also known as 

screen ruling, refers to the number of halftone cells 

per inch in a halftone screen, and is measured in 

lines per inch (lpi). 

The relationship between image resolution and 

screen frequency determines the quality of detail 

in the printed image. As a general rule, to produce 

a halftone image of the highest quality, use an 

image resolution that is 1.5 to 2 times the screen 

frequency. In some cases, however, depending on 

the image and the output device, using a lower 

resolution produces good results. 

Note: Some imagesetters and 600-dpi laser printers 

use screening technologies other than halftoning. 

If you are printing the image on a non-halftone 

printer, consult your service provider or your 

printer documentation for the recommended 

image resolutions.

About file size and resolution

The file size of a digital image is measured in 

kilobytes (K) or megabytes (MB) and is propor-

tional to the total number of pixels in the image. 

Although images with more pixels may produce 

more detail at a given size, they also result in larger 

file sizes. A 1-inch-by-1-inch 200-ppi image 

contains four times as many pixels as a 1-inch-by-

1-inch 100-ppi image and so is four times as large. 

File size is an important factor in determining the 

disk space you need to store a file and the speed 

with which you can edit and print a file. Choosing 

an image resolution needs to be a compromise 

between capturing all the data you need to 

produce a good-quality image and keeping file size 

to a minimum.

Adobe Photoshop supports maximum pixel 

dimensions of 30,000 by 30,000 pixels per image. 

For example, if an image is 14 by 14 inches, it can 

have a resolution of at most 2142 ppi (30,000 

pixels / 14 inches = 2142 ppi). 
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RESOLUTION, FILE SIZE, AND OUTPUT The file size of an image refers to the total amount of pixel information 
in the image. A 6-inch-by-6-inch high-resolution image has more pixels, and therefore a larger file size, than 
a 6-inch-by-6-inch low-resolution image with the same dimensions. In print, a high-resolution image produces 
more detail than the same image at low resolution. In Photoshop a high-resolution image appears larger on-
screen (see “About resolution and image size” on page 25). The enlarged on-screen display does not affect 
the dimensions of the printed image.

6 in x 6 in @ 72 ppi; file size 547K 100% view on-screen

6 in x 6 in @ 300 ppi; file size 7.6 MB 100% view on-screen
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Displaying the file size and resolution of 
an image

Adobe Photoshop displays the file size for each 

image in the lower left of the window. You can also 

display the dimensions, number of channels, and 

resolution information about a file. 

To display the file size:

Position the pointer over the triangle in the 

bottom border of the image window (Macintosh) 

or program window (Windows), hold down the 

mouse button, and choose Document Sizes from 

the menu.

The file size values appear in the box at the lower 

left of the window.

The first value indicates the file size of the final file 

as it would be sent to the printer, a flattened file 

that contains no layer data. The second value 

shows the size of the file including all layers and 

channels, that is, the file size if the file were saved 

with all its layers. For more information on how 

layers affect file size, see “Keeping track of file 

sizes” on page 174.

To display dimensions, channel information, and 
resolution information: 

Press Option (Macintosh) or Alt (Windows), 

position the pointer over the box in the lower left 

of the window where the file size is displayed, and 

hold down the mouse button.

The box displays the height and width of the image 

(both in pixels and in the units of measurement 

currently selected for the rulers), the number of 

channels, and the image resolution.

Previewing the page layout and print size

Before you change the size of an image, you may 

want to preview how the image will appear on the 

printed page. You may also want to preview the 

print size of the image—that is, the physical size 

that the image will have when printed.

To preview a page: 

Position the pointer over the box in the lower left 

of the window where the file size is displayed and 

hold down the mouse button.
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The dimensions of the page shown in the page 

preview box correspond to the page size that you 

select when you choose File > Page Setup. Options 

selected in the Page Setup dialog box, such as 

calibration bars, appear as gray boxes. 

A. Corner crop marks B. Calibration bars

To preview the print size:

Choose View > Print Size.

Photoshop adjusts the magnification of the image 

to display it at its actual printed size, as specified in 

the Print Size section of the Image Size dialog box. 

For more information, see “Changing the print 

dimensions and resolution of an image” on 

page 34.

About resampling

Resampling refers to changing the pixel dimen-

sions (and therefore file size) of an image. 

In Adobe Photoshop, you can change the pixel 

dimensions directly, or you can change the pixel 

dimensions by changing either the print dimen-

sions or the resolution while the Resample Image 

option is selected (see “Changing print size” on 

page 33). When you downsample (or decrease 

the number of pixels), Photoshop deletes infor-

mation from the image. When you resample up 

(or increase the number of pixels), Photoshop 

creates new pixel information based on the color 

values of the existing pixels. In both cases, 

Photoshop uses an interpolation method to 

determine how pixels are added or deleted (see 

“Choosing an interpolation method” on page 36).

Downsampling and then resampling up to the 

original resolution causes a deterioration in the 

quality of the image. This is because once an image 

has been downsampled, some of the original color 

information is lost. When Photoshop resamples 

the image back up, it attempts to reconstruct the 

file based on the new color information. Because 

the added pixels are interpolated from the new 

image data, they can make the image appear blurry 

or out of focus, resulting in a poorer quality image 

than the original.

A

B
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CHANGING PRINT SIZE By default, changing the dimensions or resolution of an image changes the number of 
pixels in the image, a process called resampling. Changing the total pixel count will probably result in a loss 
of quality in the printed image, because Photoshop must determine the color values of the pixels to be added 
or deleted using an approximation or interpolation method. On the other hand, if you deselect the Resample 
Image option in the Image Size dialog box, you can actually improve an image’s print quality by increasing its 
resolution. With Resample Image off, Photoshop maintains the total pixel count in an image by adjusting the 
print dimensions to compensate for the change in resolution and vice versa. 

Original file at 11 x 14 @ 72 ppi; file size 2.28 MB

No resampling; total pixel count maintained; 

resolution increased

Image resampled; total pixel count decreased 

with loss of quality

5.5 x 7 @ 72 ppi; file size 585K 5.5 x 7 @ 144 ppi; file size 2.28 MB
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It’s best to scan in or create your image using a 

high enough resolution so that you don’t need to 

increase the pixel dimensions from within Adobe 

Photoshop. If you want to preview the effects of 

changing the pixel dimensions on-screen, or print 

proofs at different resolutions, resample a 

duplicate of your original file. See “Duplicating 

images” on page 110 for instructions.

Original image: Image resampled up to 
150 ppi; 214K 300 ppi; 757K

Changing the pixel dimensions of an 
image

If you are preparing images for online use, such as 

for a Web site or a presentation, it’s most useful to 

specify image size in terms of the image’s pixel 

dimensions, that is, the number of pixels along 

each edge of the image. See “About resolution and 

image size” on page 25.

When you change the pixel dimensions of an 

image, you also change its printed character-

istics—either its printed dimensions or its image 

resolution. See “About resampling” on page 32 

for information on how Adobe Photoshop 

resamples images. 

To change the pixel dimensions of an image:

1 Choose Image > Image Size.

2 Make sure that Resample Image is selected, and 

choose an interpolation method, as described in 

“Choosing an interpolation method” on page 36.

3 To maintain the current proportions of pixel 

width to pixel height, select Constrain Propor-

tions. This option automatically updates the width 

as you change the height, and vice versa.

4 Under Pixel Dimensions, enter values for Width 

and Height. To enter values as percentages of the 

current dimensions, choose Percent as the unit of 

measurement.

The new file size for the image appears at the top 

of the Image Size dialog box; the old file size 

appears in parentheses.

5 Click OK to change the pixel dimensions and 

resample the image.

Changing the print dimensions and 
resolution of an image

If you are preparing images for print, it’s most 

useful to specify image size in terms of the printed 

dimensions and the image resolution. These two 

measurements determine the total pixel count and 

therefore the file size of the image. See “About 

resolution and image size” on page 25 for infor-

mation on pixel dimensions and resolution.
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When you select Resample Image in the Image Size 

dialog box, Photoshop lets you change the print 

dimensions and resolution of an image indepen-

dently of each other. In this case, Photoshop 

changes the total pixel count of the image to 

account for the new print dimensions or 

resolution. If you deselect Resample Image in the 

Image Size dialog box, Photoshop holds the pixel 

count of the image constant and adjusts the 

resolution as you change the dimensions and vice 

versa. For the best printed quality, it’s generally 

best to change the dimensions and resolution first 

with Resample Image deselected. Then resample 

only as necessary.

Note: If your image resolution is more than 2.5 times 

the screen ruling, an alert message appears when you 

try to print the image. This means that the image 

resolution is higher than necessary for the printer 

(see “About resolution and image size” on page 25). 

Save a copy of the file, and then lower the resolution. 

To change the print dimensions and resolution of 
an image:

1 Choose Image > Image Size.

2 Do one of the following:

• To change only the print dimensions or only the 

resolution and adjust the total number of pixels in 

the image proportionately, make sure Resample 

Image is selected. Then choose an interpolation 

method (see “Choosing an interpolation method” 

on page 36).

• To change the print dimensions and resolution 

without changing the total number of pixels in the 

image, deselect Resample Image.

3 To maintain the current proportions of image 

width to image height, select Constrain Propor-

tions. This option automatically updates the width 

as you change the height, and vice versa.

4 Under Print Size, enter new values for the height 

and width. If desired, choose a new unit of 

measurement. Note that for Width, the Columns 

option uses the width and gutter sizes specified in 

the Units & Rulers preferences (see “Using rulers” 

on page 111).

5 For Resolution, enter a value for the new 

resolution. If desired, choose a new unit of 

measurement.

6 Click OK.

 To return to the original values displayed in the 

Image Size dialog box, hold down Option 

(Macintosh) or Alt (Windows) and click Reset. 

Determining a recommended resolution 
for an image

If you plan to print your image using a halftone 

screen, the range of suitable image resolutions 

depends on the screen frequency of your output 

device (see “About resolution and image size” on 

page 25). You can have Photoshop determine a 

recommended resolution for your image based on 

your device’s screen frequency.

To determine a suggested resolution for 
an image:

1 Choose Image > Image Size.

2 Click Auto. 
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3 For Screen, enter the screen frequency for the 

output device. If desired, choose a new unit of 

measurement. Note that the screen value is used 

only to calculate the image resolution; it does not 

set the screen for printing.

Important: To specify the halftone screen ruling for 

printing, you must use the Halftone Screens dialog 

box, accessible through the Page Setup dialog box. 

For more information on defining screen rulings, see 

“Selecting halftone screen attributes” on page 220.

4 For Quality, select one of the following options:

• Draft to produce a resolution that is the same as 

the screen frequency (no lower than 72 pixels per 

inch).

• Good to produce a resolution that is 1.5 times 

the screen frequency.

• Best to produce a resolution that is 2 times the 

screen frequency.

5 Click OK to enter the recommended resolution 

in the Image Size dialog box.

Choosing an interpolation method 

When you resample an image using the Image Size 

command, Adobe Photoshop determines how 

pixels are added or deleted by using one of three 

interpolation methods. These methods look at the 

color values of the existing pixels in the image and 

adjust the color values of the new pixels to accom-

modate the added or deleted pixels. The more 

sophisticated interpolation methods attempt to 

choose color values that better preserve the quality 

and detail in the original image. 

A. Resampled up B. Original C. Resampled 
down Interpolation applied to black and white 
pixels and to image.

A

B

C

100% 50%50%75%

0%100%

50%
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You use the Interpolation setting in the General 

preferences to specify the default interpolation 

method used to resample images with the Image > 

Image Size command and with the Edit > 

Transform command. The Image Size command 

also lets you specify an interpolation method other 

than the default. For more information, see 

“Changing the pixel dimensions of an image” on 

page 34 and “Changing the print dimensions and 

resolution of an image” on page 34.

To specify the default interpolation method: 

1 Choose File > Preferences > General.

2 For Interpolation, choose one of the following 

options:

• Nearest Neighbor to use the fastest, but least 

precise, method of interpolation. The lack of 

precision is evident in the jagged appearance of 

modified selections, especially when you’re 

distorting or scaling an image or performing 

multiple manipulations on a selection. 

• Bilinear to use a medium-quality interpolation 

method.

• Bicubic to use the most precise form of interpo-

lation. This method results in the smoothest 

tonal gradations but is also the slowest form 

of interpolation. 

Applying the Unsharp Mask filter to the image 

after interpolation can help to refocus the image. 

For detailed instructions for using the Unsharp 

Mask filter, see “Step 5: Sharpen the image” on 

page 83.

A. Original B. Downsampled C. Unsharp Mask applied

Scanning images
Adobe Photoshop software works with any 

scanner that has an Adobe Photoshop-compatible 

plug-in module or supports the TWAIN interface. 

The scanner plug-in modules that you have 

installed appear in the File > Import submenu. 

See Chapter 1, “Looking at the Work Area” for 

more information about using and installing 

plug-in modules. 

Scanner drivers are provided and supported by the 

manufacturers of the scanners, not Adobe 

Systems. If you have problems with a scanner or 

during scanning, make sure that you have the 

latest version of the driver from the scanner 

manufacturer.

A B C
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If the scanner you are using does not have an 

Adobe Photoshop-compatible scanner driver, 

you can use the manufacturer’s software to scan 

your images and then save the images as TIFF, 

PICT, or BMP files. Then open the files in Adobe 

Photoshop. 

Adobe Photoshop software supports the Microsoft 

push model for scanners under Windows 98. 

Check with your scanner manufacturer to find out 

if your scanner supports this scanning model. You 

can use the Windows 98 Scanners and Cameras 

Control Panel to notify an application that a 

scanner wants to initiate a data transfer. 

To have a scanner choose Adobe Photoshop as the 
application to initiate a data transfer:

1 In Windows 98, choose Start Menu > Settings > 

Control Panel > Scanners and Cameras.

2 Select the scanner you want to configure and 

select Properties.

3 Click the Event tab.

4 From the pop-up menu list, choose Scanner 

Event. Select Photoshop.

5 On scanner, push the Scan button to activate the 

scanner’s date transfer. Windows 95 launches 

Adobe Photoshop and displays the scanner’s 

Import dialog box. 

About scan quality

When you scan an image, you make several choices 

that affect the quality and usefulness of the 

resulting file. Before you scan an image, be sure to 

follow the instructions in this chapter for deter-

mining the scanning resolution and optimal 

dynamic range, and for developing a procedure for 

eliminating unwanted color casts.

Importing an image using the TWAIN 
interface 

TWAIN is a cross-platform interface for acquiring 

images captured by certain scanners and frame 

grabbers. The manufacturer of the TWAIN device 

must provide a Source Manager and TWAIN Data 

source for your device; otherwise, the module will 

not work. 

Adobe Photoshop supports the current 

TWAIN_32 standard for scanning. Photoshop 

does not support TWAIN software used with 

Windows 3.1. Contact the scanner manufacturer 

for information on the availability of TWAIN 

source modules that are compatible with Windows 

NT or Windows 95.
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To import an image using the TWAIN interface:

1 If you’re using the TWAIN device for the first 

time with Adobe Photoshop, choose File > Import 

and choose the appropriate Select Source 

command from the submenu. Then select the 

device you’re using. You do not need to repeat this 

step for subsequent use of the TWAIN module.

If more than one TWAIN device is installed in 

your system and you want to switch devices, 

use the Select Source command to choose the 

new device. 

2 Choose File > Import and choose TWAIN 

Acquire (Macintosh) or the appropriate TWAIN 

command (Windows) to use the TWAIN 

interface.

Determining the scan resolution

Scan resolution, as it is used here and in following 

sections, is the same as image resolution—that is, 

the number of pixels per inch in the image when 

you open the file in Adobe Photoshop. For infor-

mation on resolution and pixel dimensions, see 

“About resolution and image size” on page 25.

The scan resolution you use for printed output 

depends on the quality of output that you need as 

well as on the resolution of your printer and the 

size of the original image compared with the 

final image. For more information, see “About 

resolution and image size” on page 25.

Scanning using the file size setting 

The best way to ensure that you have all the data 

you need for your Adobe Photoshop image is to 

create a dummy file that tells you exactly how 

much data—that is, what file size—you need for 

your final output. 

To calculate the file size before scanning an image:

1 Open Adobe Photoshop, and choose 

File > New. 

2 Enter the width, height, and resolution for your 

final printed image. The resolution should be 1.5 

to 2 times the screen frequency you will use to 

print. Make sure that the mode you plan to work 

with is selected. For more information, see “Color 

modes and models” on page 53.

The New dialog box displays the file size above the 

dimensions. For example, the following dialog box 

shows the values for a final image that is 4 inches 

wide and 5 inches high, printed with a 150-line 

screen using a 2:1 ratio (resolution is set at 300). 

The file size needs to be 5.15 megabytes.
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To produce the scan, select the area of the image 

you want to scan. Then adjust the resolution up or 

down until the file size is equal to or larger than the 

file size in the Photoshop File > New dialog box. 

You can fine-tune the image size and resolution 

later.

Once you have scanned the image and imported it 

into Photoshop, use the Image Size command to 

enter the correct width and height for the image.

Scanning using the resolution setting

If you cannot use file size as the determining factor 

in choosing your scanner settings, you can 

calculate a scan resolution using the original and 

final image dimensions and the screen frequency 

of your output device.

To estimate scan resolution:

1 Multiply the screen frequency by 2. (2 is 

the typical ratio of image resolution to screen 

frequency needed to produce a good-quality 

image.)

2 Multiply the result in step 1 by the size change 

factor to get the estimated scan resolution you 

need.

For example, suppose you are scanning an image 

that is 2 inches wide by 3 inches high. You want 

to produce a final image that is 6 inches wide by 

9 inches high. You are using a screen frequency 

of 85 lpi.

To calculate the scan resolution, you first multiply 

85 (the screen frequency) by 2 to get 170. You then 

multiply 170 by 3 (the ratio of final to original 

image dimensions) to get a scan resolution of 

510 ppi. 

Different printing procedures might require 

different ratios of image resolution to screen 

frequency. It’s a good idea to check with your 

service provider or printer to finalize your 

requirement before you scan the image.

Optimizing the dynamic range of the scan

When scanning an image, keep in mind that the 

human eye can detect a wider tonal range than can 

be printed. If your scanner lets you define the black 

and white points, set the points before scanning 

the file to produce the best tonal range and capture 

the widest dynamic range. After opening the file in 

Adobe Photoshop, use the color correction tools to 

set the white and black points for the digitized 

image. See Chapter 4, “Making Color and Tonal 

Adjustments” for more information about setting 

the black and white points for an image. 

Eliminating unwanted color casts

If your scanned image contains an unwanted color 

cast, you can perform a simple test to determine 

whether the cast has been introduced by your 

scanner. If you find that it has, you can use the 

same test file to create a color cast correction for all 

images scanned using that scanner.
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To identify and correct a color cast introduced by 
a scanner:

1 Open a new Photoshop file and use the gradient 

tool ( ) to create a blend from pure black to pure 

white.

2 Choose Image > Adjust > Posterize and 

posterize the blend using 11 levels.

3 Print the 11-step gray wedge and then scan it 

into Photoshop.

Note: You can also perform this test using an 18-

percent neutral gray card or an 11-step gray wedge 

from a photography store.

4 Open the Info palette and read the RGB values 

on-screen for each of the gray levels. Uneven R, G, 

and B values indicate a color cast. See Chapter 

3, “Choosing a Color Display Mode” for more 

information on color and color values. 

5 Use Levels to correct the color cast (see Chapter 

4, “Making Color and Tonal Adjustments” for 

instructions), and then save the dialog box 

settings.

6 Open the scanned image you want to correct, 

reopen the Levels dialog box, and load the saved 

settings.

Opening and importing images
Adobe Photoshop lets you open images in a variety 

of file formats. You can have multiple image 

windows open at one time. 

Import choices appear in the file format list in the 

Open dialog box or in the File > Import submenu. 

If a file format does not appear, install the format’s 

plug-in module, as described in “Installing plug-in 

modules” on page 18.

Opening files

You can open files in the following ways:

• The Open command lets you open files saved in 

formats that are supported by Photoshop (except 

for those that use Import modules). On the 

Macintosh, you can use the Open command to 

open files in the format that you specify.

• In Windows, the Open As command lets you 

open a file that has a missing or incorrect file 

extension, or a file that does not appear in the 

Open dialog box. 

• The Import command lets you open files saved 

in formats that use plug-in import modules. You 

can open anti-aliased PICT files and PICT 

Resource files (Macintosh), and files scanned 

using the TWAIN interface. You also use the 

Import command to use any third-party import 

modules you’ve installed. 
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To open a file on the Macintosh:

1 Choose File > Open.

2 To display all files in the selected folder, select 

Show All Files. To locate files in other folders, click 

Find and type the filename.

3 To preview files before opening them (if a 

preview has been saved with the image), select 

Show Thumbnail. This option requires the Apple® 

QuickTime® extension. Files created with a version 

of Adobe Photoshop prior to 2.5.1 must be resaved 

for the preview to appear. 

4 Select the file.

5 Click Open. In some cases, a dialog box appears, 

letting you set the open options.

For more information on a specific file format, see 

“About file formats” on page 210.

To open a file in Windows:

1 Choose File > Open.

2 For Files of Type, choose one of the following 

options:

• All Formats to display all the files in the selected 

directory.

• Any individual format to display only files saved 

in that format.

3 Select the file.

4 Click Open. In some cases, a dialog box appears, 

letting you set the open options.

For more information on a specific file format, see 

“About file formats” on page 210.

To specify the file format in which to open a file:

Do one of the following:

• On the Macintosh, choose File > Open and 

select Show All Files. For Format, choose the 

desired file format and click Open.

• In Windows, choose File > Open As. For Open 

As, choose the desired format and click Open.

Note: If the file does not open, then the chosen 

format may not match the file’s true format, or the 

file may be damaged.

To use an import module:

Choose File > Import; then choose the import 

module from the submenu.
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Opening PhotoCD files 

To open PhotoCD files in Adobe Photoshop, 

choose the Kodak® PhotoCD™ format in the Open 

dialog box. The PhotoCD plug-in module can 

open 4096-by-6144-pixel resolution (64Base, 

72 MB) images from Kodak Pro PhotoCD disks.

Note: The Kodak Precision Color Management 

System (KPCMS), required to use the Kodak CMS 

PhotoCD format, is automatically installed in your 

System Folder (Macintosh) or on your installation 

drive (Windows) when you install Adobe Photoshop. 

You cannot save files in the PhotoCD format from 

Adobe Photoshop.

The Kodak PCMS PhotoCD plug-in module lets 

you read Photo YCC data from the disk and 

convert it to an Adobe Photoshop RGB color 

space. You can transform both the source image 

and the destination image using the profiles (or 

PT) you have installed. Using the Kodak PCMS 

application lets you deliver the highest-quality 

image to Adobe Photoshop.

To open a Photo CD file:

1 Choose File > Open.

2 Select the file you want to open, and click Open. 

If the file does not appear, for Format, choose 

Show All Files (Macintosh) or All Formats from 

the Files of Type list (Windows).

3 Choose a resolution.

4 Click Source. Choose a device profile and an 

attribute from the list, and then click OK.

The first time you open a PhotoCD file, it opens 

using the default Source and Destination profiles. 

After you choose the profiles, they remain selected 

until you change them.

If you are unsure of the source profile, click Image 

Info and note the number next to Product Type of 

Original. On Windows, click Source and choose 

the profile that displays the same number for 

Device Settings.

5 Click Destination, and for Device, choose an 

RGB profile; then click Open. 

6 To display scanner information about the 

image, click Image Info; then click OK.

7 Click OK to open the image.

Opening Raw files

The Raw format is designed to accommodate 

images saved in undocumented formats, such as 

those created by scientific applications. 

Compressed files, such as PICT, LZW, and GIF, 

cannot be opened using this format. For more 

information on Raw options, see “About file 

formats” on page 210.

To open a file using the Raw format:

1 Choose File > Open (Macintosh) or File > Open 

As (Windows).

2 Choose Raw from the file format list and click 

Open.

3 For Width and Height, enter values for the 

dimensions of the file.

4 To reverse the order of the width and height, 

click Swap.
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5 Enter the number of channels.

6 Select Interleaved if the file was saved with a 

progressive display option. 

7 Select a color depth and, if necessary, a byte 

order.

8 For Header, enter a value.

9 If you are missing the dimensions or header 

value, you can have Adobe Photoshop estimate the 

parameters. Either enter the correct height and 

width values to estimate the header size, or enter 

the correct header size to estimate the height and 

width, and then click Guess.

10 To have Photoshop retain the header when you 

save the file, select Retain When Saving.

11 Click OK.

Importing an anti-aliased PICT file 
(Macintosh only)

Choose File > Import > Anti-aliased PICT to 

import object-oriented PICT files, such as those 

created with MacDraw® and Canvas, as soft-edged, 

or anti-aliased, files. Because the entire PICT file 

must be in memory for this module to operate, 

you may not be able to use the module with large 

PICT files. 

The Anti-aliased PICT dialog box indicates the 

current file size and dimensions. To change the 

image dimensions, enter new values for Width and 

Height; the file size is updated to reflect the new 

dimensions. To maintain the same image propor-

tions, select Constrain Proportions. You can 

choose to open the Anti-aliased PICT file in either 

Grayscale or RGB mode.

Acquiring PICT Resources 
(Macintosh only)

The PICT Resource module lets you read PICT 

resources from a file—for example, to read 

resources from another application. For more 

information, see “About file formats” on page 210. 

You specify the resources you want to read using 

the PICT dialog box. 

To preview a resource, click Preview; click the 

arrow buttons to step forward and backward 

through the resources. Note that the number 

displayed for Resource refers to the resource’s 

position in ascending order in the resource fork 

and not to the resource’s identification number.

Note: You can also open a file in the PICT Resource 

file format by choosing File > Open and, for Format, 

choosing PICT Resource. Using the Open command, 

however, automatically opens the first resource in the 

file in an Adobe Photoshop document and does not 

display any other PICT resources in the file.
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Viewing copyright and 
authorship information
Adobe Photoshop LE lets you view copyright and 

authorship information for an image that has been 

copyright-protected, or watermarked, using 

Digimarc PictureMarc™ technology. The 

watermark—a digital code embedded in the 

image—can be virtually invisible, and does not 

affect image integrity. Most filter and image opera-

tions—including color corrections, printing, and 

cropping—don’t affect the watermark. Copying 

an image with an embedded watermark also 

copies the watermark and any information 

associated with it.

Installing Adobe Photoshop LE using the Easy 

Install option (Macintosh) or Typical option 

(Windows) installs the Read Watermark filter 

automatically in the Plug-Ins folder. 

To read a watermark:

1 Choose Filter > Digimarc > Read Watermark. If 

the filter finds a watermark, a dialog box displays 

the creator ID, type of use, and whether the image 

has adult content.

Note: A message may appear that “a watermark was 

found but not readable” if you’re reading a scanned 

image from an inkjet printer or if you’re reading a 

small selection of an image. This message means that 

the PictureMarc technology was unable to decode the 

creator ID and usage information. For more infor-

mation, contact Digimarc or visit its home page at 

www.digimarc.com. 

2 Click OK, or for more information choose from 

the following options:

• If you have a Web browser installed, click 

Web Lookup to launch the browser, link to the 

Digimarc Web site, and display the artist’s contact 

information corresponding to the creator ID.

• Call the phone number listed in the Watermark 

Information dialog box to get information faxed 

back to you.

Creating new images 
The New command lets you create a blank, 

untitled Photoshop image. 

To create a new image:

1 Do one of the following:

• To base the image dimensions and resolution on 

the Clipboard contents, choose File > New.

• To base the image size on the default dimensions 

and resolution or the last entered parameters, hold 

down Option (Macintosh) or Alt (Windows) as 

you choose File > New.

• To base the image size on an open window, 

choose File > New. With the New dialog box open, 

choose the image whose size you want to match 

from the Window menu. 

2 Type a name for the image and if desired, set the 

width, height, resolution, and mode. See “Color 

modes and models” on page 53 for information 

on modes.

3 For Contents, select one of the following:
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• White to fill the background with white, the 

default background color.

• Background Color to fill the image with the 

current background color. See “Choosing the 

foreground and background colors” on page 127 

for information on choosing the foreground and 

background colors.

• Transparent to create an image containing a 

single layer with no color values. 

Note: Because images created with the transparent 

option contain a single layer instead of a background, 

they must be saved in Photoshop format. Photoshop 

is the only format that supports layers. See “Saving 

files” on page 203 for more information.

Cropping an image
Adobe Photoshop provides two ways for you to 

select part of an image and discard the rest:

• The Image > Crop command discards the area 

outside of a rectangular selection and keeps the 

resolution of the resulting image constant. 

• The crop tool ( ) lets you crop an image by 

dragging over the area you want to keep. You can 

also define the size and resolution of the cropped 

area. The advantage of using the crop tool is that 

you can rotate and resample the area as you crop.

To crop an image using the Crop command: 

1 Use the rectangle marquee tool to select the part 

of the image you want to keep. Make sure that the 

Feather option is set to 0 pixels. For more infor-

mation, see “Feathering a selection” on page 102.

2 Choose Image > Crop.

To use the crop tool:

1 Position the pointer on the marquee ( ) tool in 

the toolbox, and drag to select the crop tool ( ). 

2 Drag over the part of the image you want 

to keep.

When you release the mouse button, the crop 

marquee appears as a bounding box with handles 

at the corners and sides. 

3 Use the following methods to adjust the crop 

marquee:

• To move the marquee to another position, 

position the pointer inside the bounding box 

and drag. 
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• To scale the marquee, drag a handle. To 

constrain the proportions, hold down Shift as 

you drag a corner handle.

• To rotate the marquee, position the pointer 

outside the bounding box (the pointer turns into a 

curved arrow) and drag.

4 To crop the image, press Return (Macintosh) or 

Enter (Windows). To cancel the cropping 

operation, press Esc. 

Note: You can’t rotate the crop tool marquee for an 

image in Bitmap mode.

To specify the size and resolution of the cropped area:

1 Double-click the crop tool ( ) in the toolbox to 

display its Options palette.

2 Select Fixed Target Size.

3 To begin with the size and resolution values of 

the current image, click Front Image.

4 Choose the units of measurement you want 

from the menus. Note that for Width, the 

Columns option uses the width and gutter sizes 

specified in the Units & Rulers preferences (see 

“Using rulers” on page 111).

5 Enter values for the size and resolution you 

want for the cropped area. 

The Fixed Target Size option constrains the pixel 

count of the image. As a result, if you specify a size 

but not a resolution, Adobe Photoshop changes 

the image resolution to compensate for the size 

change. If you specify a resolution but not a size, 

Photoshop changes the size to compensate for the 

change in resolution. 
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6 Drag over the area you want to keep with the 

crop tool and then press Return (Macintosh) or 

Enter (Windows). 

The final image has the specified size and 

resolution.

Increasing the size of the work 
canvas
The Canvas Size command lets you add or remove 

work space, or extra canvas area, around an 

existing image. You increase the canvas area by 

specifying the height and width you want the 

canvas to be. 

You can also use the Canvas Size command to crop 

an image by decreasing the canvas area; however, if 

you want to adjust the size and resolution of an 

image, you should use the Image Size command or 

the crop tool. If you use the Canvas Size command 

to crop an image, you might inadvertently lose 

image information that you cannot recover.

To use the Canvas Size command: 

1 Choose Image > Canvas Size.

2 Choose the units of measurement you want 

from the menus. Note that for Width, the 

Columns option uses the width and gutter sizes 

specified in Units & Rulers preferences (see “Using 

rulers” on page 111).
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3 Enter the dimensions in the Width and Height 

boxes. The value above the text boxes reflects the 

new file size.

4 For Anchor, click a square to indicate where you 

want the existing image to be positioned on the 

new canvas. 

5 Click OK.

Before After

Added canvas appears in the background color. If 

the background is transparent, the added canvas is 

also transparent.
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Chapter 3: Choosing a Color 
Display Mode

amiliarity with color theory and termi-

nology can help you understand how color 

is measured and how Adobe Photoshop 

Limited Edition uses this information to define, 

display, and print color values.

This chapter discusses several accepted standards 

for describing color and Photoshop’s corre-

sponding color modes. The last part of the chapter 

explains how to optimize the monitor display for 

systems with limited colors and how to convert 

images between different color modes.

Color modes and models
Adobe Photoshop LE can use a number of color 

modes for displaying, printing, and storing 

images. The red, green, and blue (RGB) mode and 

the hue, saturation, and brightness (HSB) mode 

are based on established color models for 

describing and reproducing color. In addition to 

modes based on color models, Photoshop includes 

modes with restricted color ranges, such as 

Bitmap, Grayscale, and Indexed color modes. 

HSB model

The HSB model is based on the human perception 

of color. In the HSB model, all colors are described 

in terms of three fundamental characteristics:

• Hue is the wavelength of light reflected from or 

transmitted through an object. More commonly, 

hue is identified by the name of the color such as 

red, orange, or green. Hue is measured as a 

location on the standard color wheel and is 

expressed as a degree between 0° and 360°.

• Saturation, sometimes called chroma, is the 

strength or purity of the color. Saturation repre-

sents the amount of gray in proportion to the hue 

and is measured as a percentage from 0% (gray) to 

100% (fully saturated). On the standard color 

wheel, saturation increases as one approaches the 

edge of the wheel; saturation decreases as one 

approaches the center.

• Brightness is the relative lightness or darkness of 

the color and is usually measured as a percentage 

from 0% (black) to 100% (white).

In Photoshop, you can use the HSB model to 

define a color in the Color palette or Color Picker 

dialog box. 

F



CHAPTER 354
Choosing a Color Display Mode

RGB model

A large percentage of the visible spectrum can be 

represented by mixing three basic components of 

colored light in various proportions and inten-

sities. These components are known as the 

primary colors: red, green, and blue (RGB). When 

the three primary colors overlap, they create the 

secondary colors: cyan, magenta, and yellow. 

Since the primary colors combine to create white, 

they are also called additive colors. Adding all 

the colors together creates white—that is, all 

the light is reflected back to the eye. Additive 

colors are used for lighting, video, film recorders, 

and monitors. Your monitor, for example, creates 

color by emitting light through red, green, and 

blue phosphors.

RGB mode

Photoshop’s RGB mode uses the RGB model, 

assigning an intensity value to each pixel ranging 

from 0 (black) to 255 (white) for each of the RGB 

components in a color image. For example, a 

bright red color might have an R value of 246, a G 

value of 20, and a B value of 50. When the values of 

all three components are equal, the result is a 

shade of gray. When the value of all components is 

255, the result is pure white; when all components 

have values of 0, the result is pure black. 

RGB is the default mode for new Photoshop 

images. 

Bitmap mode

Bitmap mode uses one of two color values (black 

or white) to represent the pixels in an image. 

Images in Bitmap mode are called bitmapped, 

or 1-bit, images because they have a pixel depth 

of 1. 

Grayscale mode

Grayscale mode uses up to 256 shades of gray to 

represent an image. In Adobe Photoshop, every 

pixel of a grayscale image has a brightness value 

ranging from 0 (black) to 255 (white). The values 

between 0 and 255 correspond to points on the 

grayscale spectrum. Grayscale values can also be 

measured as percentages of black ink coverage (0% 

is equal to white and 100% is equal to black). 

Images produced using black-and-white or 

grayscale scanners are typically displayed in 

Grayscale mode.

You can convert both Bitmap-mode and color 

images to grayscale. Grayscale mode lets you 

convert a color image to a high-quality black-

and-white image. In this case, Adobe Photoshop 

discards all color information in the original 

image; the gray levels (shades) of the converted 

pixels represent the luminosity of the original 

pixels. 

When you convert a grayscale image to an RGB 

image, the color values for each pixel are assigned 

that pixel’s previous gray value. 
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Indexed color mode

An indexed-color image is a single-channel image 

and is based on a palette of at most 256 colors. 

When you convert an image to indexed color, 

Photoshop builds a color lookup table, which 

stores and indexes the colors in the image. If a 

color in the original image does not appear in the 

table, the program matches the color to the closest 

color in the color table or simulates the color using 

the available colors. 

Indexed color mode is useful when you want to 

limit the palette of colors used in an image—for 

example, when you want to use the image in a 

multimedia animation application or on a Web 

page. Using an indexed color table lets you reduce 

the file size of an image while maintaining the 

visual quality that you need. For more information 

on color tables and converting images to indexed 

color, see “Converting to indexed color” on 

page 60.

About color channels
Every Adobe Photoshop image contains one or 

more channels, which represent information about 

the color elements in the image. For example, 

an RGB image has three channels: one for red 

information, one for green information, and one 

for blue information. In this sense, a channel is 

analogous to a plate in the printing process in 

which a separate plate is used to apply each layer 

of color. 

By default, Bitmap-mode, grayscale, and indexed-

color images have one channel; RGB mode images 

contain three channels. 

Measuring color values in the 
Info palette
You can determine the color values of any part of 

your image using the Info palette. Depending on 

your Info palette setup, you can select any tool, 

position the pointer over any part of an image, and 

determine the color value under the pointer. You 

can customize the Info palette to express color 

values using the HSB or RGB models or Grayscale 

mode without changing the mode of the image 

itself. For more information on measuring color 

with the Info palette, see “Previewing color values” 

on page 69 and “Customizing the Info palette” on 

page 13.

Adjusting the monitor display
Although the RGB color model is capable of 

displaying a large portion of the visible spectrum, 

the video system that sends data to a monitor often 

limits the number of colors that can be displayed at 

one time. By understanding the way color data is 

measured in digital files and on-screen, you can 

adjust Photoshop’s preferences to offset the limita-

tions of your monitor.
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About pixel depth

Pixel depth, also called bit resolution or color 

depth, measures how much color information is 

available for each pixel in an image. Greater pixel 

depth (more bits of information per pixel) means 

more available colors and more accurate color 

representation in the digital image. For example, a 

pixel with a pixel depth of 1 has two possible 

values: black and white. A pixel with a pixel depth 

of 8 has 28, or 256, possible values; and a pixel with 

a bit depth of 24 has 224, or roughly 16 million, 

possible values. Common values for pixel depth 

range from 1 to 48 bits per pixel. 

1-bit (Bitmap) 8-bit (Grayscale)

Color display options for 8-bit color 
displays

Each image mode in Adobe Photoshop uses a 

different color lookup table, or color palette, to store 

the colors used in the image. When you’re working 

with a display system that supports 8-bit color (or 

fewer colors), the video card displays only 256 

different colors at one time. For example, an RGB 

image can display 16.7 million colors in any image 

at one time. However, if the monitor can display 

only 256 of the 16.7 million colors, Adobe 

Photoshop uses a technique called dithering to 

simulate the 257th color and each additional color 

thereafter. Dithering adjusts adjacent pixels of 

different colors to give the illusion of a third color, 

which simulates the display of colors that are not 

in the current color palette.

By default, Adobe Photoshop uses pattern 

dithering to display colors not in the current color 

palette, which can result in a distinctive pattern of 

darker or lighter areas in the image. In contrast, 

diffusion dithering spreads out the inaccuracy in 

representing a pixel’s color to the surrounding 

pixels and eliminates distinctive patterning. 

Diffusion dithering, however, can cause visual 

inconsistencies when only part of a screen is 

redrawn (for example, when you scroll, edit, or 

paint). However, when you print the image, the 

on-screen dithering effects will not be printed. You 

can set this and other display options in the Prefer-

ences dialog box. 
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To select a color display option:

1 Choose File > Preferences > Display & Cursors.

2 Choose either or both of the following options:

• Use System Palette to make the display of 

inactive images more accurate.

• Use Diffusion Dither to minimize dither 

patterns produced by dithering.

Converting between bit depths
In most cases, RGB and grayscale images contain 8 

bits of data per color channel. With three channels 

in an RGB image, this translates to a 24-bit RGB 

bit depth (8 bits x 3 channels) and an 8-bit 

grayscale bit depth (8 bits x 1 channel). Photoshop 

can also read and import 48-bit RGB and 16-bit 

grayscale images (each with 16 bits of data per 

color channel). 

Note:  A 16-bit-per-channel image provides finer 

distinctions in color, but its file size is much larger 

than an 8-bit-per-channel image.

Photoshop supports these tools and commands in 

16-bit-per-channel images: the marquee, lasso, 

zoom, hand, and eyedropper tools; and the 

Duplicate, Levels, Auto Levels, Curves, and Rotate 

Canvas commands. To take full advantage of 

Photoshop’s features, you can convert a 16-bit-

per-channel image to an 8-bit-channel image. 

To convert from 8 bits per channel to 16 bits per 
channel:

1 Flatten the image you want to convert, as 

explained in “Flattening all layers” on page 175.

2 Choose Image > Mode >16 Bits/Channel.

To convert from 16 bits per channel to 8 bits per 
channel:

Choose Image > Mode > 8 Bits/Channel.

Converting from one mode to 
another
When you convert an image from one mode to 

another, the transition between modes creates a 

permanent change to the color values in the image. 

For example, when you convert an RGB image to 

Indexed color mode, the RGB colors that do not 

appear in the color table are converted to the 

nearest matching colors in the table. Conse-

quently, it’s best to convert to another mode only 

after doing as much editing as possible in the 

image’s original mode. If you think you may need 

an image for more than one purpose, save a 

backup copy of that image before converting it. 

For information on converting to Bitmap, 

Grayscale, or Indexed color mode, see the 

following sections. 

Important: Converting an image between certain 

modes flattens the image. Be sure to save a copy of 

your image that includes all layers if you want to be 

able to edit the original version of the image after the 

conversion. 
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To convert an image to another mode:

Choose Image > Mode and choose the mode you 

want from the submenu. Images in certain modes 

cannot be converted directly to other modes. 

Modes not available for the active image appear 

dimmed in the menu. 

The following mode conversions cause a file to be 

flattened: RGB to Indexed color mode, and 

Grayscale to Bitmap or Indexed color mode.

Converting to Bitmap mode
To convert a color image to Bitmap mode, you 

must first convert it to grayscale. This removes the 

hue and saturation information from the pixels 

and leaves the brightness values. Because few 

editing options are available for Bitmap-mode 

images, it’s usually best to edit the image in 

Grayscale mode and then convert it to Bitmap 

mode if necessary to export the image to another 

application.

To convert a grayscale image to Bitmap mode:

1 Open the grayscale image; then choose Image > 

Mode > Bitmap.

2 For Output, enter a value for the output 

resolution of the Bitmap-mode image and choose 

a unit of measurement. By default, the current 

image resolution appears as both the input and the 

output resolutions.

3 Select a bitmap conversion method, and click 

OK. If you choose Halftone Screen, see the 

following section. The other conversion methods 

are described in “Additional bitmap conversion 

options” on page 59.

Specifying a halftone screen for a Bitmap-
mode image

The Halftone Screen option in the Bitmap dialog 

box lets you convert the pixels in a grayscale image 

to simulated halftone dots.

To specify the halftone screen for a Bitmap-mode 
image: 

1 Choose Image > Mode > Bitmap.

2 Click Halftone Screen; then click OK.

3 For Frequency, enter a value for the screen 

frequency and choose a unit of measurement. 

Values can range from 1.0 to 999.999 for lines per 

inch and from 0.400 to 400.000 for lines per centi-

meter. You can enter decimal values. 

The screen frequency is the ruling of the halftone 

screen. The frequency depends on the paper stock 

and type of press used for printing. Newspapers 

commonly use an 85-line screen. Magazines use 

higher resolution screens, such as 133 and 150. 

Check with your print shop for the correct screen 

frequency to use.

4 Enter a value for the screen angle in degrees. 

Values can range from –180 to +180. 

The screen angle refers to the orientation of the 

screen. Continuous-tone and black-and-white 

halftone screens commonly use a 45° angle. 

5 For Shape, choose the dot shape you want.
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6 Click OK.

 
Original grayscale image Halftone screen conversion: 

53 lpi, 45° angle, round dot

You can save the halftone screen settings and reuse 

them with other images by using the Save and 

Load buttons in the Halftone Screen dialog box.

Additional bitmap conversion options

Like the Halftone Screen option, the other four 

bitmap conversion options determine the quality 

of the Bitmap-mode image, ranging from a high-

contrast image to a textured or halftone-screen 

effect for output on non-PostScript® printers. 

These methods are described in the following 

sections.

50% Threshold Converts pixels with gray values 

above the middle gray level (128) to white, and 

converts pixels below the middle gray level to 

black. The result is a very high-contrast, black-

and-white representation of the image.

Pattern Dither Converts an image by organizing 

the gray levels into geometric configurations of 

black and white dots.

Diffusion Dither Uses an error-diffusion process to 

convert the image. The program starts at the pixel 

in the upper left corner of the image and evaluates 

its gray-level value. If the value is above middle 

gray (128), the pixel is changed to white. If the 

value is below 128, the pixel is changed to black. 

There is some error in the conversion because the 

original pixel is usually not pure between black 

and white, and the conversion changes it to either 

a black or a white value. The amount of error is 

transferred to surrounding pixels before they are 

converted. In this way, the error is diffused 

throughout the image. The result is a grainy, 

filmlike texture. This option is useful for viewing 

images on a black-and-white screen.

 
Original grayscale image 50% Threshold conversion 

method

 
Pattern Dither conversion Diffusion Dither 
method conversion method
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Converting a Bitmap-mode 
image to grayscale 
A Bitmap-mode image converted to grayscale 

consists of one gray level (black). Since few editing 

options are available in Bitmap mode, you might 

convert a Bitmap-mode image to a grayscale image 

for editing and then convert it back to a Bitmap-

mode image to export it to other applications. 

However, keep in mind that the appearance of a 

Bitmap-mode image edited in grayscale mode may 

change when you convert it back to Bitmap mode. 

To convert a Bitmap-mode image to grayscale:

1 Choose Image > Mode > Grayscale.

2 Enter a value for the size ratio.

The size ratio is the factor by which you want to 

scale down the size of the image. For example, 

to reduce the size of the grayscale image by 50%, 

enter 2 for the size ratio. If you enter a number 

greater than 1, the program averages multiple 

pixels in the Bitmap-mode image to produce a 

single pixel in the grayscale image. This lets you 

generate multiple shades of gray from an image 

scanned on a 1-bit scanner. 

Converting to indexed color
At times, you might want to convert an RGB image 

to an indexed-color image to edit an image’s color 

table or to export an image to an application that 

supports only 8-bit color. This is useful, for 

example, for multimedia animation applications 

and World Wide Web pages. When you convert an 

RGB image to indexed color, all but 256 colors are 

deleted from the image. 

To convert an RGB image to an indexed-color image:

1 Choose Image > Mode > Indexed Color.

2 Select the desired palette, color depth, and 

dither methods. These options are described in 

the following sections.

3 Click OK.

Specifying a palette 

Eight palette types are available for converting an 

image to indexed color. Choose Image > Mode > 

Color Table to view the results of each palette 

option.

Exact Uses exactly the same colors for the palette 

as those that appear in the RGB image. Since all the 

colors in the image are present in the image’s 

palette, there is no dithering. This option is 

available only if 256 or fewer colors are used in the 

RGB image.

System (Macintosh) Uses the Macintosh system’s 

default 8-bit palette, which is based on a uniform 

sampling of RGB colors. 

System (Windows) Uses the Windows system’s 

default 8-bit palette, which is based on a uniform 

sampling of RGB colors. 

Web Uses the palette most often used by Web 

browsers to display 8-bit images. 

Uniform Creates a palette based on a uniform 

sampling of colors from the color spectrum. 

For example, if you choose an 8-bit color depth, 

Adobe Photoshop takes six evenly spaced color 

levels each of red, green, and blue, and calculates 

the combinations of these colors to produce a 

uniform palette of 216 colors (6 x 6 x 6 = 216). 
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To create a uniform palette composed of fewer 

colors, choose a lower color depth. The total 

number of colors displayed in the image corre-

sponds to the perfect cube (8, 27, 64, 125, or 216) 

nearest to the chosen color depth.

Adaptive Creates a palette by sampling colors 

from the more commonly used areas of the color 

spectrum that appears in the image. For example, 

if you have an RGB image that has only the colors 

green and blue, the resulting palette is made up 

primarily of green and blue colors. Because the 

colors in most images are concentrated in 

particular areas of the spectrum, this table can 

be useful. 

To control more precisely how the Adaptive palette 

is built, select a part of the image that contains the 

colors you want to use in the palette before you 

make the conversion. When you have an active 

selection in the image, Adobe Photoshop weights 

the conversion toward the colors in the selection.

Custom Lets you create your own palette. When 

you select this option, the program displays the 

Color Table dialog box. You can then edit the color 

table and save it for later use or click Load to load 

a previously created color table. Editing a color 

table is described in “Manipulating the color table 

of an indexed-color image” on page 62.

Previous Converts the image by using the custom 

palette from the previous conversion. This option 

makes it easy to convert a number of images using 

the same custom palette. This option is available 

only after you have converted an image using the 

Custom or Adaptive option.

Specifying the color depth

When you choose the Uniform or Adaptive 

palette, you can specify the color depth (also 

known as pixel depth), or the number of bits 

of color information per pixel, for the indexed-

color image. The color depth you choose deter-

mines the number of colors used to display (or 

print) an image. For example, if you choose 4 bits 

per pixel, the image is composed of 16 colors; 

if you choose 6 bits per pixel, the image is 

composed of 64 colors; if you choose 8 bits per 

pixel, the image is composed of 256 colors. (The 

number of colors used is displayed in the Colors 

text box.) In addition, you can specify the exact 

number of colors to be displayed (up to 256) 

by choosing Other for Color Depth and entering 

a value for Colors. 

The options in the Indexed Color dialog box 

control only how the indexed color table is created. 

Adobe Photoshop still treats the image as an 8-bit, 

256-color image.

Specifying dithering options

Unless you’re using the Exact color table option, 

the color table may not contain all the colors used 

in the image. To simulate colors not in the color 

table, you can choose to dither the colors. 

Dithering mixes the pixels of the available colors to 

simulate the missing colors. You can choose from 

three dithering options:

• None: Does not dither colors but instead uses 

the color closest to the missing color. This tends to 

result in sharp transitions between shades of color 

in the image, creating a posterized effect.
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• Diffusion: Uses a less structured method than 

does the Pattern option to dither colors.

• Pattern: Adds random pixels in patterns to 

simulate the colors that are not in the color table. 

This option is available only when you’re using the 

Macintosh System palette.

Manipulating the color table of 
an indexed-color image
When you convert an RGB image to an indexed-

color image, or when you work in an original 

indexed-color image, you might want to change 

one or more colors in the table. You can also model 

the colors after a predefined color table. Each 

indexed-color image has its own color table, and 

you can save a color table for reuse with other 

indexed-color images. 

There are two types of indexed-color images: those 

with a limited number of colors (fewer than 256), 

and pseudocolor images (grayscale images that 

display variations in gray levels with color rather 

than shades of gray). Pseudocolor images are often 

used in scientific and medical applications. The 

color table editing features discussed in the 

following sections are most useful with pseudo-

color indexed images. These features can also be 

used to produce special effects with indexed-color 

images that have a limited number of colors.

Note: If you just want to change the colors in an 

image, choose Image > Adjust, and use the color 

correction commands in the submenus. Chapter 

4, “Making Color and Tonal Adjustments.” for a 

description of these commands.

Editing colors in the indexed color table 

To edit a color table, you select the colors you want 

to change. Although our example shows the 

editing of a color table for a pseudocolor image, 

the following procedure applies to all indexed-

color images. 

To edit colors in the color table:

1 Open the indexed-color image.

2 Choose Image > Mode > Color Table.

3 Click or drag in the table to choose the color or 

range of colors you want to change. 

Midtone and highlight range selected in dialog box

4 Choose the color you want, see “Using the 

Adobe Photoshop Color Picker” on page 146, and 

click OK. 

If you are changing a range of colors, Adobe

Photoshop creates a gradient in the color table 

between the starting and ending colors. The first 

color you choose in the Color Picker is the 

beginning color for the range. When you click OK, 

the Color Picker reappears so you can choose the 

last color in the range.



63ADOBE PHOTOSHOP 5.0 LIMITED EDITION
User Guide

The colors you selected in the Color Picker are 

placed in the range you selected in the Color Table 

dialog box.

5 Click OK in the Color Table dialog box to apply 

the new colors to the indexed-color image.

Choosing a color-table option

Your indexed color table can be modeled after one 

of six predefined color tables. You select a 

predefined color table from the Table menu in the 

Color Table dialog box. 

• Custom: Used whenever the table is not one of 

Adobe Photoshop software’s built-in color tables.

• Black Body: Displays a transition of colors based 

on the different colors a black-body radiator emits 

as it is heated—from black to red, orange, yellow, 

and white. 

• Grayscale: Displays a smooth transition from 

black to white in 256 levels of gray. 

• Spectrum: Displays a smooth transition between 

the colors that result when white light passes 

through a prism: violet, blue, green, yellow, 

orange, and red. 

• Macintosh System: Displays the standard 

Macintosh 256-color system palette. 

• Windows System: Displays the standard 

Windows 256-color system palette. 

Saving and loading a color table 

You use the Save and Load buttons in the Color 

Table dialog box to save your indexed color tables 

for use with other Adobe Photoshop images. Once 

you load a color table into an image, the colors in 

the image are changed to reflect the color positions 

they reference in the new color table. 

Note: You can also load saved color tables into the 

Swatches palette. See “Saving, loading, and replacing 

swatches” on page 146 for more information.
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Chapter 4 : Making Color and Tonal 
Adjustments

dobe Photoshop Limited Edition offers a 

number of color correction tools that let 

you adjust the color and tonal values of 

your image. You can use these tools to correct 

unwanted color casts, to sharpen a narrow tonal 

contrast, or to create special effects.

Using the Adobe Photoshop 
color correction tools
All of the Adobe Photoshop color correction tools 

work essentially the same way: by mapping 

existing ranges of pixel values to new ranges of 

values. The difference between the tools is the 

amount of control you have over the ranges of 

values. For example, the Brightness/Contrast 

command makes the same adjustment to every 

pixel in the selection or image—if you increase the 

brightness value by 30, 30 is added to the 

brightness value of every pixel. Curves, on the 

other hand, replicates high-end color correction 

systems and lets you isolate 16 ranges of pixel 

values (colors) between pure highlight and pure 

shadow.

Using color adjustment commands

To use most color adjustment tools, choose a 

command from the Image > Adjust submenu. The 

commands under the Adjust submenu apply only 

to the selected layer. When you adjust the color 

values in the selected layer, you permanently alter 

the pixels in this layer.

Most color adjustment tools have a dialog box 

associated with them.

To open a color adjustment dialog box:

Choose Image > Adjust and choose the command 

you want from the submenu.

To cancel color changes without closing a color 

adjustment dialog box, hold down Option 

(Macintosh) or Alt (Windows) to change the Cancel 

button to the Reset button, and then click Reset.

A
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Previewing color adjustments

In most cases, when you make color changes to a 

selection, Adobe Photoshop displays the changes 

throughout the entire screen. The program 

modifies the video card’s color lookup table 

(VLUT) in response to the changes you specify. 

Color table animation, also called video table 

lookup, is controlled by the video card, not by 

Adobe Photoshop. Color table animation allows 

faster previewing of color adjustments when you 

are making changes to a Photoshop image; 

however, it does not always preview the image 

accurately. 

Note: On most systems running Windows, color 

table animation works only if the monitor is set to 

256 colors. For color table animation to work in 

24-bit mode with Windows, you must have installed 

a color table animation extension, supplied by your 

video card manufacturer, in the Plug-Ins directory. 

You can display an accurate preview by selecting 

the Preview option in one of the color adjustment 

dialog boxes. When you select Preview, you turn 

off the color table animation; only the image or the 

selected area of the image is shown with the color 

correction. This allows you to see accurately the 

effect of color adjustments on a selected area.

Image with Preview Image with Preview
option off option on

To turn on previewing and deactivate color table 
animation:

Select the Preview option in any color correction 

dialog box. 

The color table animation is deactivated, and 

Adobe Photoshop displays the effects of the 

changes on the current selection only. 
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To turn off color table animation:

1 Choose File > Preferences > Display & Cursors.

2 Deselect Video LUT Animation and click OK.

Previewing with a 24-bit or 32-bit 
video card (Macintosh only)

The color table animation feature can cause 

problems if you are using a 24-bit or 32-bit video 

card for which certain color QuickDraw™ 

commands have not been properly implemented. 

If you have a problem, contact your video card 

manufacturer for ROM updates. You should also 

reset the video mode, and turn off the Video LUT 

Animation option in the Display & Cursors 

preferences dialog box. 

To reset the video mode to preview changes using 
a 24-bit or 32-bit video card:

1 Choose Control Panels from the Apple menu, 

and double-click Monitors.

2 Click one of the other color display options 

(such as 256 Colors), and perform a preview to see 

the results.

3 Click your original color display option.

4 Close the Control Panel.

5 In Photoshop, choose File > Preferences > 

Display & Cursors and deselect Video LUT 

Animation; then click OK.

Although you will be able to preview changes 

correctly with the Preview option selected, you 

will not be able to turn the color table animation 

off and on by clicking the Preview option in the 

dialog box.

Previewing color values

You can use the Color palette and the Info palette 

to preview the color values of pixels affected by the 

color adjustments you’re making. 

When you move the pointer over an area of your 

image that contains pixels while working with one 

of the color adjustment dialog boxes, the Info 

palette displays two values. The value in the left 

column is the original pixel’s color value; the value 

in the right column is the color value after the 

adjustment is made. 

To use the Info palette to preview color changes:

1 Choose Window > Show Info. (See “Custom-

izing the Info palette” on page 13 for information 

on the Info palette display options.)

2 Open a color adjustment dialog box (see “Using 

color adjustment commands” on page 67).

3 Move the pointer over an area of the image you 

want to examine. The eyedropper reads the value 

of a single screen pixel, a 3-by-3 screen pixel area, 

or a 5-by-5 screen pixel area, depending on the 

Sample Size option you have chosen in the 

Eyedropper Options palette.

Note: While a color adjustment dialog box is open, 

the eyedropper tool is automatically active outside 

the dialog box; however, you still have access to the 

scroll controls and to the hand and zoom tools when 

using keyboard modifier keys.



CHAPTER 470
Making Color and Tonal Adjustments

The Info palette displays the before and after color 

values at the location under the pointer.

Adjusted image Info palette
A. Before and after Levels adjustment

Levels dialog box

To use the Color palette to preview color values: 

1 Choose Window > Show Color.

2 Open a color adjustment dialog box (see “Using 

color adjustment commands” on page 67).

3 Click the pixel you want to preview. The color 

values of the pixel after the adjustment has been 

made are shown in the Color palette. 

To cancel color changes without closing a color 

adjustment dialog box, hold down Option 

(Macintosh) or Alt (Windows) to change the Cancel 

button to the Reset button, and then click Reset.

Saving and loading color adjustment 
settings

The Save and Load buttons in the Levels, Curves, 

and the Hue/Saturation dialog boxes let you save 

the color corrections you make using those dialog 

boxes and let you apply the corrections to other 

images.

To apply a color correction adjustment to another 
image: 

1 Click the Save button in the color correction 

dialog box you are using and name and save the 

color correction settings. 

2 Close the color correction dialog box, and 

open the image to which you want to apply the 

corrections. 

3 Reopen the color correction dialog box and 

click the Load button. Locate and open the saved 

color correction file.

4 Click OK to apply the corrections to the image.

Step 1: Check the scan quality 
and tonal range
Although you can use Photoshop to correct 

certain scanning flaws, if not enough detail has 

been captured in the original image, it’s difficult if 

not impossible to produce high-quality printed 

output. See “Scanning images” on page 37 for 

information on making a scan.

A
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A histogram is a graphic representation of the 

number of pixels at each brightness level in an 

image. You can use the histogram to verify that the 

image contains enough detail to make a good 

correction. Too little detail in an image may be the 

result of a bad scan or photograph, or it may be 

caused by too many color corrections, which result 

in loss of pixel values. If you think that an image 

may have been overcorrected, revert to the original 

image before applying the color correction proce-

dures described in this chapter.

The histogram also gives you a quick picture of the 

tonal range of the image, also known as the image 

key type. An image whose detail is concentrated in 

the shadows is known as a low-key image; an 

image whose detail is concentrated in the 

highlights is known as a high-key image. Identi-

fying the tonal range of the image helps determine 

the appropriate tonal corrections.

To determine whether enough information has 

been captured in the scanning 

process, check the pixel values of your highlight and 

shadow areas in the Info palette. In general, RGB 

highlight values of about 240 and shadow values of 

about 10 indicate that the scan contains enough 

detail to produce high-quality output. 

To check the histogram for an image: 

Open the image you want to examine, and choose 

Image > Adjust > Levels.

Histogram of gray levels in entire image

The x axis of the histogram represents the color 

values from darkest (0) at the far left to brightest 

(255) at the far right; the y axis represents the total 

number of pixels with that value. 
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LOOKING AT THE HISTOGRAM The histogram gives you a picture of how the pixels’ values in an image are 
distributed, and whether the image contains enough detail in the highlights, midtones, and shadows to 
produce a good correction.

Shadows Midtones Highlights

The histogram Enough detail  
for correction

Corrected image Corrected image Corrected image

Average-key image High-key image Low-key image

Not enough detail  
for correction
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Step 2: Set the highlight and 
shadow values
The first task in professional tonal correction is to 

assign values to the extreme highlight and shadow 

pixels in the image, so that the overall tonal range 

provides the sharpest detail possible throughout 

the image. This process is known as setting the 

highlights and shadows or setting the white and 

black points. You can set highlights and shadows in 

Adobe Photoshop using several different methods. 

Setting the highlights and shadows using 
target values

Professional color technicians typically set the 

highlights and shadows in the image by assigning 

the lightest and darkest printing ink values to the 

lightest and darkest areas of detail in the image. 

When identifying these areas of the image, it’s 

important to identify a truly representative 

highlight and shadow area so that the tonal range 

is not expanded unnecessarily to include extreme 

pixel values that don’t give the image detail. 

To set the highlight and shadow using target values:

1 Double-click the eyedropper tool, and set the 

Sample Size option in the Eyedropper Options 

palette to 3 by 3 Average. This option tells Adobe 

Photoshop to display the average value of each 

3-by-3-screen-pixel area and ensures that you get a 

truly representative sample of an area in the image 

rather than a single screen-pixel value. 

2 Do one of the following:

• Open the Info palette, and move the pointer 

around the image to help identify the lightest 

neutral areas in the image (See “Previewing color 

values” on page 69).

• Use Threshold mode in the Levels dialog box to 

identify the highlight area in the image.

Note that your goal in this step is to identify a 

representative highlight area in the image—a 

printable highlight—and not an area that is simply 

pure white with no detail, such as a spot of glare in 

the image. White with no detail, also called 

specular white, is reproduced by printing no ink on 

paper.

Selecting the specular Values in representative
highlight area highlight area

Selecting the representative Values in representative
highlight area highlight area
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DETERMINING TARGET VALUES High-key and low-key images may benefit from slightly different target values 
than those shown on page 8 and page 10. With a low-key image, you might want to set the highlight to a 
lower value to avoid too much contrast; with a high-key image, you might want to set the shadow to a higher 
value to maintain detail in the highlights. Experiment with shadow Brightness values between 4 and 20 and 
highlight Brightness values between 96 and 80.

Low-key image

High-key image Shadow set 

using average-key 

target brightness 

values (B: 4)

Shadow set 

using higher 

target brightness

values (B: 20)

Highlight set 

using average-key 

target brightness 

values (B: 96)

Highlight set 

using lower

target brightness 

values (B: 80)
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3 Choose Image > Adjust > Levels or Curves to 

open the Levels or Curves dialog box, and double-

click the white eyedropper tool to display the color 

picker. In the color picker, enter the value that you 

want to assign to the highlight you identified in 

step 2. 

In most situations when you are printing on white 

paper, you can achieve a good highlight in an 

average-key image using RGB values of 244, 244, 

and 244, respectively. (The grayscale equivalent is 

a 4% dot.) 

You can reproduce these target values quickly by 

entering a value of 96% in the Brightness text box.

Target printable highlight values

4 Click OK in the Color Picker dialog box when 

you’ve entered the values; then click the highlight 

area that you identified in step 2. If you acciden-

tally click the wrong highlight, hold down Option 

(Macintosh) or Alt (Windows) and click Reset in 

the dialog box.

The pixel values throughout the image are 

adjusted proportionately to the new highlight 

values. Any pixels lighter than the area you clicked, 

such as any pixels in a spot of glare, become 

specular white. The Info palette shows the values 

both before and after the color adjustment.

5 Now use the Info palette to help identify a repre-

sentative shadow area in the image. (Don’t click 

the area yet.) 

6 Double-click the black eyedropper tool in the 

Levels or Curves dialog box, and enter a target 

shadow value. In a typical situation where you are 

printing on white paper, you can achieve a good 

shadow in an average-key image using RGB values 

of 10, 10, and 10, respectively. (The grayscale 

equivalent is a 96% dot.) 

You can reproduce these same values quickly by 

entering a value of 4 in the Brightness text box. 

Target printable shadow values

7 Click OK when you’ve entered the values; then 

click the shadow area that you identified in step 5. 

After setting shadows

A
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To use Threshold mode to identify the lightest and 
darkest areas in the image:

1 Choose Image > Adjust > Levels to display the 

Levels dialog box. Make sure that the Preview 

option is deselected.

Note: On most systems running Windows, 

Threshold mode works only if the monitor is set to 

256 colors. The Video LUT Animation option in the 

Display & Cursors preferences dialog box must be on 

for Threshold mode to work. See “Previewing color 

adjustments” on page 68 for more information.

2 Hold down Option (Macintosh) or Alt 

(Windows) and drag the white or black Input 

Levels triangle.

The image changes to Threshold mode, and a 

high-contrast preview image appears. The visible 

areas of the image indicate the lightest parts of the 

image if you are dragging the white slider and the 

darkest parts of the image if you are dragging the 

black slider. If you have a channel of a color image 

selected in the Levels dialog box, the black area 

indicates where none of the given color 

component exists.

To see a high-contrast hold down Option/Alt
preview of highlight or and move one of the 
shadow areas... Input Levels triangles.

3 Slowly drag the slider to the center of the 

histogram to identify the light or dark areas in 

the image.

Setting the highlights and shadows using 
the Levels sliders

An alternative way to set the highlights and 

shadows in an image that shows a lack of pixels on 

either end of the histogram is simply to move the 

Levels input sliders to the first group of pixels on 

both ends of the histogram. Doing so maps these 

pixels—the darkest and lightest pixels in each 

channel—to black and white. The corresponding 

pixels in the other channels are adjusted propor-

tionately so as not to affect the color balance.

Using the Levels sliders to set highlights and 

shadows is less exact than assigning target values, 

but it often gives good results. In addition, because 

it doesn’t affect the color balance of the image, this 

method is preferable if you want to maintain a 

color cast in the highlights and shadows. 

To set the highlights and shadows using the Levels 
sliders:

1 Choose Image > Adjust > Levels to reopen the 

Levels dialog box if necessary, and drag the input 

Levels sliders to the edge of the first group of pixels 

on either end of the histogram. Then click OK. 
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2 To view the new histogram, reopen the Levels 

dialog box. Notice that the histogram has been 

stretched out to accommodate the new white and 

black points, causing gaps in the histogram. 

These gaps do not indicate a perceptible problem 

in the image unless they are large or accompanied 

by a low pixel count.

Notice that although both adjustments improved 

the contrast in the image, setting the highlights 

and shadows to neutral color values also elimi-

nated the color cast, whereas adjusting the Levels 

sliders did not affect the color balance. 

In this example, eliminating the color cast by 

assigning target values was useful. However, in 

another image—for example, one without neutral 

highlights—using the Levels sliders to set the 

highlights and shadows might produce better 

results precisely because it does not affect the 

color balance.

Setting the highlights and shadows 
automatically

The Auto Levels command and Auto button in the 

Levels and Curves dialog boxes automatically 

adjust the levels or curves, respectively. These Auto 

commands perform the equivalent of the Levels 

slider adjustment automatically; that is, these 

features automatically define the lightest and 

darkest pixels in the image as white and black and 

then redistribute the intermediate pixel values 

proportionately. 

In general, the Auto feature gives good results 

when a simple contrast adjustment is needed to an 

image with an average distribution of pixel values; 

however, this feature does not provide the more 

precise control that can be achieved by adjusting 

the Levels or Curves controls manually.

To set the black and white points automatically:

Choose an Auto option:

• Choose Image > Auto Levels.

• Choose Image > Adjust > Levels or Curves. In 

the Levels or Curves dialog box, click Auto. 

By default, the Auto feature clips the white and 

black pixels by 0.5%—that is, when identifying the 

lightest and darkest pixels in the image, it ignores 

the first 0.5% of either extreme. This clipping of 

color values ensures that the program bases its 

white and black values on truly representative light 

and dark pixels rather than on a single extreme 

pixel value in the image.
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To change the amount of white and black values 
clipped:

1 Hold down Option (Macintosh) or Alt 

(Windows), and click the Options button in the 

Levels or Curves dialog box. 

2 In the Auto Range Options dialog box, enter the 

percentage of extreme highlight pixels and 

extreme shadow pixels you want the Auto feature 

to ignore; then click OK. A value between 0.5% 

and 1% is recommended.

Step 3: Adjust the midtones and 
fine-tune the tonal correction
Once you have set the highlights and shadows, you 

may want to adjust the midtones or otherwise 

fine-tune the contrast. Most often, this step is not 

necessary with average-key images; setting the 

highlights and shadows typically redistributes the 

midtone pixel values appropriately. When pixel 

values are concentrated on either end of the 

grayscale, however, further adjustments to the 

midtones are often needed to redistribute where 

the midtones fall.

In addition, you can use the gray eyedropper 

button in the Levels or Curves dialog box to set the 

intermediate points along the grayscale and 

eliminate color casts in the midtones. (See “Setting 

the highlights and shadows using the Levels 

sliders” on page 76 for a description of how the 

eyedropper buttons work.) For precise control 

over midtone adjustments, however, it is recom-

mended that you adjust the Levels midtone slider 

or the midtone values in the Curves dialog box.

The Levels sliders let you make gradual adjust-

ments to the brightness, contrast, and midtones in 

an image. Adjusting the midtones lets you change 

the brightness values of the middle range of gray 

tones without dramatically altering the shadows 

and highlights. 

To use the Levels sliders:

1 Choose Image > Adjust > Levels.

The Levels dialog box displays a histogram of the 

image. (See “Looking at the histogram” on page 72 

for more information.)
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2 Adjust the contrast:

• Use the Input Levels slider controls directly 

below the histogram to increase the contrast in the 

image. The black triangle controls the shadows, 

the gray triangle controls the midtones, and 

the white triangle controls the highlights. You 

can also enter values directly into the Input Levels 

text boxes.

• Use the Output Levels slider controls at the 

bottom of the Levels dialog box to reduce the 

contrast in the image. The black triangle controls 

the shadows, and the white triangle controls the 

highlights. You can also enter the values directly 

into the Output Levels text boxes. 

A. Increases shadows B. Increases highlights
C. Decreases shadows D. Adjusts gamma or gray levels
E. Decreases highlights

For example, suppose your image contains pixels 

that cover the entire 0-to-255 scale and you want 

to increase the contrast in the image. If you drag 

the Input Levels white triangle to 233, pixels with 

brightness values of 233 and higher are mapped to 

255, and pixels with lower brightness values are 

mapped to corresponding lighter values. This 

lightens the image and increases the contrast in the 

highlight areas. 

Original Contrast increased in
highlights

On the other hand, suppose you want to decrease 

the contrast of the image. If you drag the Output 

Levels white triangle to 220, pixels with brightness 

values of 255 are remapped to 220, and pixels with 

lower brightness values are mapped to corre-

sponding darker values. This darkens the image 

and decreases the contrast in the highlight areas.

C E

A B

D
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Using Curves 

Like Levels, Curves lets you adjust the tonal range 

of an image. However, instead of making the 

adjustments using just three variables (highlights, 

shadows, and midtones), you can adjust any point 

along the 0–255 scale while keeping up to 15 other 

values constant.

You can also use the Arbitrary Map option in the 

Curves dialog box to draw a tonal curve by 

dragging. This feature lets you create a variety of 

interesting tonal and color effects.

To use the Curves dialog box:

1 Choose Image > Adjust > Curves. 

A. Shadows B. Midtones C. Highlights

The horizontal axis of the graph represents the 

original brightness values of the pixels (input 

levels); the vertical axis represents the new 

brightness values (output levels). The diagonal 

line that appears by default shows the current 

relationship between the input and output values: 

no pixels have been mapped to new values, so all 

pixels have the identical input and output values.

Note: By default, Curves displays brightness values 

from 0–255 with shadows (0) on the left in RGB 

mode. To reverse the curve and change the display at 

any time, click the double arrow below the curve.

2 Move the pointer to the area you want to 

correct, and hold down the mouse button.

A circle appears to mark the pixel’s position on 

the graph, and the output and input values are 

displayed at the bottom of the dialog box. This 

step identifies the portion of the curve you want 

to adjust. 

Clicking in the image... displays the pixel values and 
location on the curve.

A B C
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3 Click any points on the curve that you want to 

remain fixed. For example, if you want to adjust 

the midtones while minimizing the effect on the 

highlights and shadows, click the quarter and 

three-quarter points on the curve. 

You can add up to 15 points to the curve to lock 

those values as you make adjustments. To keep 

values constant, add points to the grid where the 

input and output points are equal. To remove a 

fixed point from the curve, drag it off the graph. 

Avoid sharp curves (which posterizes color) or 

clustering points in front of locked points (which 

can cause colors to blend together or shift 

unevenly).

4 Drag the curve until the image looks as you 

want it. 

Click to fix a point on and then drag to adjust.
the curve...

Changes to the curve becomes the new default, 

until you reset the curve. 

 To make the Curves grid finer, hold down 

Option (Macintosh) or Alt (Windows), and 

click the grid. Option/Alt-click again to make the 

grid larger.

To use the Arbitrary Map option in the Curves 
dialog box:

1 Click the pencil at the bottom of the Curves 

dialog box. 

2 Drag to draw the curve you want in the Curves 

graph area.

The pencil pointer appears automatically when 

you move into the graph. To constrain the curve to 

a straight line, hold down Shift and click to define 

the endpoints of the curve. You can create a 

negative of an image, for example, by holding 

down Shift and clicking the upper left corner of 

the graph and then the lower right corner.

3 If desired, click Smooth to smooth the curve 

you’ve drawn.

Step 4: Adjust the color balance
With the tonal correction complete, you can 

accurately examine and diagnose any problems 

with color in the image, such as a color cast or 

oversaturated or undersaturated colors. 

About adjusting color balance

When adjusting the individual color components 

in an image, it’s important to understand that 

every color adjustment affects the overall color 

balance in the image, and that there are numerous 

ways to achieve similar effects. If you’re not yet 

used to adjusting individual color components in 

an image, it helps to keep a diagram of a color 

wheel on hand as you work. 
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You can use the color wheel to help predict how 

changing one color component will affect the 

other colors in the image. For example, you can 

decrease the amount of any color in an image by 

increasing the amount of the opposite color on the 

color wheel—and vice versa. Similarly, you can 

increase and decrease a color by adjusting the two 

adjacent colors on the color wheel, or even by 

adjusting the two colors adjacent to the opposite 

color on the color wheel. 

For example, you can decrease the magenta in an 

image by removing red and blue or by adding 

green. All of these adjustments result in an overall 

color balance that contains less magenta. How you 

choose which adjustment is appropriate for your 

image depends on the image and on the particular 

effect you want.

Using the Color Balance command

The Color Balance command lets you change the 

mixture of colors in a color image. Like the 

Brightness/Contrast command, this tool provides 

generalized color correction. For precise control 

over individual color components, use Levels, 

Curves, or the Hue/Saturation command.

To adjust the levels of a particular color in 
an image: 

1 Choose Image > Adjust > Color Balance. 

2 Do one of the following:

• Click Shadows, Midtones, or Highlights to select 

the tonal range on which you want to focus 

the changes. 

• With RGB images, click Preserve Luminosity to 

prevent changing the brightness values in the 

image as well as changing the color. This option 

maintains the tonal balance in the image.

3 Drag a triangle toward a color if you want to 

increase that color in the image; drag the triangle 

away from the color if you want to decrease the 

color.

The values at the top of the Color Balance dialog 

box show the color changes for the red, green, 

and blue channels. Values can range from –100 

to +100.

Using the Hue/Saturation command

The Hue/Saturation command lets you adjust the 

hue, saturation, and lightness of individual color 

components in an image. Like the Color Balance 

command, the Hue/Saturation command is based 

on the color wheel. Adjusting the hue, or color, 

represents a move around the color wheel; 

adjusting the saturation, or purity of the color, 

represents a move across the diameter of the color 

wheel. You can also use the Colorize option to add 

color to a grayscale image you have converted to 

RGB or to create a monotone effect.

To adjust an image using Hue/Saturation: 

1 Choose Image > Adjust > Hue/Saturation to 

display the Hue/Saturation dialog box. 

Along the left side of the dialog box are six color 

swatches of the additive and subtractive colors in 

the order in which they appear on the color wheel: 

red, yellow, green, cyan, blue, and magenta. 
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In addition, the Sample swatch at the bottom of 

the dialog box lets you monitor the adjustment’s 

effect on a selected color (by default, the 

foreground color). Click a color in the image to 

change the swatch color. 

2 Select the button next to the color component 

you want to adjust, or select Master to adjust all 

colors at once. 

3 Drag the Hue slider until the colors appear the 

way you want them. You can also type a value into 

the Hue text box.

The values displayed in the text box reflect the 

number of degrees of rotation around the wheel 

from the pixel’s original color. A positive value 

indicates a clockwise rotation; a negative value 

indicates a counterclockwise rotation. 

4 Drag the Saturation triangle to the right to 

increase the saturation; drag to the left to decrease 

the saturation. This shifts the color away from or 

toward the center of the color wheel, relative to the 

beginning color values of the selected pixels. 

5 Drag the Lightness slider to the right to increase 

the lightness; drag to the left to decrease the 

lightness. Values can range from –100 to +100.

To colorize a grayscale image or create a monotone 
effect: 

1 If you are colorizing a grayscale image, choose 

Image > Mode > RGB to convert the image to 

RGB.

2 Open the Hue/Saturation dialog box, as 

described under “Using color adjustment 

commands” on page 67.

3 Click Colorize. The image is converted to shades 

of red, the 0° point on the color wheel, at 100% 

saturation. Note that the lightness value of each 

pixel does not change.

4 Use the Hue slider to select the new color. 

5 Use the Saturation and Lightness sliders to 

adjust the saturation and lightness of the pixels; 

then click OK. 

Step 5: Sharpen the image
Unsharp masking, or USM, is a traditional film 

compositing technique used to sharpen edges in 

an image. The Unsharp Mask filter corrects 

blurring in the original photograph or scan, and it 

compensates for blurring that occurs during the 

resampling and printing process. Applying the 

Unsharp Mask filter is recommended whether 

your final destination is print or online.

The Unsharp Mask filter locates every two 

adjacent pixels with a difference in brightness 

values that you specify, and then increases the 

pixels’ contrast by an amount that you specify. In 

addition, you specify the number of surrounding 

pixels to which the sharpening effect is applied.

When sharpening an image, it’s important to 

understand that the effects of the Unsharp Mask 

filter are far more pronounced on-screen than in 

high-resolution output. If your final destination is 

print, use the samples in this chapter to help 

determine what dialog box settings will work best 

for your image.
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To sharpen an image using the Unsharp Mask filter: 

1 Choose Filter > Sharpen > Unsharp Mask. 

2 In the Unsharp Mask dialog box, select the 

following options:

• Choose an Amount to determine how much the 

contrast of pixels is increased. For high-resolution 

printed images, an amount between 150% and 

200% is recommended. 

Before Unsharp Mask Unsharp Mask: Amount 
filter 150%; Radius 1; Threshold 0

UNSHARP MASKING Until you are familiar with the printed results of applying the Unsharp 
Mask filter, use the examples in this chapter to help determine what dialog box settings are best 
for your image. Because of the resolution limitations of your monitor, the effects of the filter 
are much more dramatic on-screen than they are in your final output.

Notice how the default Threshold value of 0 adds noise to the skintones of this image and 
makes the skin appear grainy; higher Threshold settings sharpen the edges of the figure 
without affecting the skintones. Increasing the Threshold also lets you increase the Amount 
without adding noise to areas that need less sharpening.

Original image USM 200, Radius 1, 
Threshold 0

USM 200, Radius 2, 
Threshold 0

USM 300, Radius 1, 
Threshold 15
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• Choose a Radius to determine the number of 

pixels surrounding the edge pixels that are affected 

by the sharpening. For high-resolution images, a 

Radius between 1 and 2 is recommended.

In the examples shown here, only the edge pixels in 

the first image have been sharpened, whereas the 

higher radius value sharpened a wider band of 

pixels in the second image. This effect is much less 

noticeable in the high-resolution printed version 

than on-screen because a two-pixel radius repre-

sents a smaller area in the printed image.

Radius 1 (Amount 150%, Radius 2 (Amount 150%,
Threshold 0) Threshold 0)

• Choose a Threshold to determine how different 

the brightness values between two pixels must be 

before they are considered edge pixels and are 

sharpened by the filter. For images with fleshtones 

and other areas in which you want to avoid intro-

ducing noise, experiment with Threshold values 

between 2 and 20. The default Threshold value (0) 

sharpens all pixels in the image.

In the example shown here, notice that increasing 

the Threshold eliminates much of the noise in the 

bricks and the ground.

Unsharp Mask: Amount Unsharp Mask: Amount 
150%; Radius 1; 150%; Radius 1; 
Threshold 10 Threshold 0 

Using the Variations command 
for generalized tonal and color 
adjustments
The Variations command lets you visually adjust 

the color balance, contrast, and saturation of an 

image or selection. This command is most useful 

when you’re working in an average-key image that 

doesn’t require precise color adjustments. 

To use the Variations command:

1 Choose Image > Adjust > Variations to display 

the Variations dialog box.

Note: If the Variations command does not appear in 

the Adjust submenu, the Variations plug-in module 

may not have been installed. See “Using plug-in 

modules” on page 18 for more information.
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The two thumbnails at the top of the dialog box 

show the original selection (Original) and the 

selection with its currently selected adjustments 

(Current Pick). When you first open the dialog 

box, these two images are the same. As you make 

adjustments, the Current Pick image changes to 

reflect your choices. 

2 Choose the following options:

• Deselect Show Clipping if you do not want to see 

a neon preview of the areas in the image that will 

be clipped—that is, converted to pure white or 

pure black when the adjustment is applied. 

Clipping does not occur when you adjust 

midtones. 

• Select Shadows, Midtones, or Highlights to 

indicate whether you want to adjust the dark, 

middle, or light areas of the selection, respectively.

• Select Saturation to change the degree of hue in 

the image. Note that if the Show Clipping option is 

selected, and the image shows clipping after the 

adjustment, you have exceeded the maximum 

saturation for the color.

• Use the Fine/Coarse slider to determine the 

amount of each adjustment. Moving the slider one 

tick mark to the right or left doubles the 

adjustment amount. 

3 Adjust the color and brightness as follows:

• To add a color to the image, click the appropriate 

color thumbnail. 

• To subtract a color, click its opposite, located in 

the opposite position on the color wheel; for 

example, to subtract cyan, click the red thumbnail.

4 Click the thumbnails on the right of the dialog 

box to adjust the brightness in the image. 

Note that each time you click a thumbnail, all 

thumbnails change. The center thumbnail always 

reflects the current choices. 

Using the Brightness/Contrast 
command
Using the Brightness/Contrast command is the 

easiest way to make simple adjustments to the 

tonal range of the image. Unlike Curves and 

Levels, this command adjusts all pixel values in 

the image—highlights, shadows, and midtones—

at once and so is not recommended for high-end 

output or for subtle color adjustments. 

To use the Brightness/Contrast dialog box: 

1 Choose Image > Adjust > Brightness/Contrast 

to display the Brightness/Contrast dialog box. 

2 Drag the sliders to adjust the brightness and 

contrast.

Dragging to the left decreases the level; dragging 

to the right increases it. The number at the right 

of each slider value displays the brightness or 

contrast value. Values can range from –100 

to +100. 

3 When you’ve finished making adjustments, 

click OK.
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Special-purpose color 
adjustment tools
The Invert, Equalize, Threshold, and Posterize 

commands also change the colors or brightness 

values in an image. In most cases, these commands 

provide dramatic overall effects that are applied to 

the selected layer. These commands are typically 

used for color enhancement and for producing 

special effects rather than for color correction. 

Using the Invert command 

The Invert command creates a negative of an 

image. You might use this command to make a 

positive image negative or to make a positive from 

a scanned negative.

When you invert an image, the brightness value of 

each pixel in the image is converted to the inverse 

value on the 256-step color-values scale. For 

example, a pixel in a positive image with a value of 

255 is changed to 0, and a pixel with a value of 5 is 

changed to 250.

To invert an image:

Choose Image > Adjust > Invert.

Original image Invert command applied

Using the Equalize command

The Equalize command redistributes the 

brightness values of the pixels in an image so that 

they more evenly represent the entire range of 

brightness levels. When you choose this 

command, Adobe Photoshop finds the brightest 

and darkest values in the image and averages all 

the brightness values so that the darkest value 

represents black (or as close to it as possible) and 

the brightest value represents white. Photoshop 

then attempts to equalize the brightness—that is, 

to distribute the intermediate pixel values evenly 

throughout the grayscale. 

You might use this command when a scanned 

image appears darker than the original and 

you want to balance the values to produce a 

lighter image. 

To equalize the brightness values of pixels: 

1 Choose Image > Adjust > Equalize. 

If you have an area of the image selected, the 

Equalize dialog box appears. 

• Select Selected Area Only to equalize only the 

pixels in the selection.

• Select Entire Image Based on Area to equalize 

the pixels in the entire image based on the pixels in 

the selected area. 
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2 Click OK to equalize the image or the 

selection.

Original image Equalize command applied

Using the Threshold command

Use the Threshold command to convert grayscale 

or color images to high-contrast black-and-white 

images. This command lets you specify a certain 

level as a threshold. All pixels lighter than the 

threshold are converted to white. All pixels darker 

than the threshold are converted to black.

To use the Threshold command: 

1 Choose Image > Adjust > Threshold. 

The Threshold dialog box displays a histogram of 

the luminance levels of the pixels in the current 

selection.

2 Drag the slider below the histogram until the 

threshold level you want appears at the top of the 

dialog box. As you drag, the image changes to 

reflect the new threshold setting.

Note: On the Macintosh, the Video LUT Animation 

option in the Display & Cursors preferences must 

be on to preview the Threshold adjustment. See 

“Previewing color adjustments” on page 68 for more 

information.

Original image Threshold command 
applied: 70
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Using the Posterize command

The Posterize command lets you specify the 

number of tonal levels (or brightness values) for 

an image and then maps pixels to the level that is 

the closest match. This command is useful for 

creating special effects, such as large, flat areas in a 

photograph. The effects of this command are most 

evident when you reduce the number of gray levels 

in a grayscale image; however, you can also use this 

command to produce some interesting effects in 

color images. Posterize can also be useful for 

reducing the number of colors in an image you 

want to distribute over the Web.

To specify the number of levels in an image: 

1 Choose Image > Adjust > Posterize. 

2 Enter the number of levels you want; then 

click OK.

3 When you’ve finished making adjustments, 

click OK.

Original image Posterize command 
applied: 4 levels of color
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Chapter 5: Selecting

o modify part of an image in Adobe 

Photoshop Limited Edition, you must first 

select the area you want to edit. A selected 

area is indicated by its surrounding selection 

border, also called a selection marquee. Once you 

have made a selection, you can move, copy, paint, 

or apply numerous special effects to the selected 

area. See Chapter 6, “Editing” for information on 

editing selections.

This chapter provides an overview of the basic 

selection tools and methods in Adobe Photoshop. 

It also explains how to adjust and refine selections 

by increasing or decreasing the selected area, 

softening the edges of a selection, and deselecting 

a selected area. 

Area selected

Making selections
You make selections by clicking and dragging with 

the marquee, lasso, polygon lasso, or magnetic 

lasso tool, or by targeting color areas with the 

magic wand tool. The choices associated with a 

selection tool appear in its Options palette. 

Making a new selection replaces the existing one.

Note: When making a selection in a file that contains 

layers, make sure that the layer you want is the active 

layer.

To select all pixels on a layer within the canvas 
boundaries:

1 Select the layer in the Layers palette, as 

explained in “Using the Layers palette” on 

page 154.

2 Choose Select > All. 

This command selects all the pixels that fall inside 

the boundaries of the canvas. 

To deselect selections:

Do one of the following:

• If you are using the rectangular marquee, ellip-

tical marquee, or lasso tool, click anywhere in the 

image outside the selected area.

• Choose Select > None. 

T
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Using the marquee tool

The marquee tool ( / / / ) lets you select 

rectangular or elliptical areas by dragging over an 

area of the image. By default, the marquee is 

dragged from its corner.

Elliptical selection Rectangular selection

To use the marquee tool:

1 Drag to select one of the following marquee 

tools from the toolbox:

• Rectangle marquee to make a rectangular 

selection. 

• Ellipse marquee to make an elliptical selection.

• Single row or single column marquee to 

define the selection marquee as a 1-pixel-wide 

row or column. 

 To switch between the rectangle and ellipse 

marquees quickly, Option-click (Macintosh) 

or Alt-click (Windows) the marquee tool, or press 

Shift+M.

2 If you’ve selected the rectangle or ellipse 

marquee, choose one of the following options for 

Style in the Marquee Options palette:

• Normal to determine the proportions of the 

marquee by dragging. 

• Constrained Aspect Ratio to set a height-to-

width ratio for the marquee. Enter the values 

(including decimal values) for the aspect ratio. For 

example, to draw a marquee that is twice as wide as 

it is high, you would enter 2 for the width and 1 for 

the height in the marquee. 

• Fixed Size to specify set values for the marquee’s 

height and width. Enter the pixel values for the 

fixed-size marquee in whole numbers. Keep in 

mind that the number of pixels needed to create a 

1-inch selection depends on the resolution of the 

image. For a file that has 72 pixels per inch, for 

example, you need 72 pixels to make 1 inch. See 

“About resolution and image size” on page 25 for 

information on image resolution.

3 To define a feather edge as you make a selection, 

enter a pixel value for Feather. See “Softening the 

edges of a selection” on page 102 for more infor-

mation.

4 To make a selection, do one of the following:

• If you’re using the rectangle or ellipse marquee, 

drag over the area you want to select. Hold down 

Shift as you drag to constrain the marquee to a 

square or circle. To drag a selection marquee from 

its center, begin dragging; then hold down Option 

(Macintosh) or Alt (Windows), and continue 

to drag.

Dragging from corner Dragging from center
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• If you’re using the Single Row or Single Column 

marquee, click near the area you want to select; 

then drag the marquee to the exact location. If no 

marquee is visible, increase the magnification of 

your image view (see “Magnifying and reducing 

the view” on page 16).

 To adjust the position of a rectangular or ellip-

tical marquee, first drag to create the marquee, 

keeping the mouse button depressed; then hold down 

the spacebar and continue to drag.

Using the lasso tool

The lasso tool ( ) lets you make a selection by 

dragging a freehand outline around an area. You 

can also constrain all or part of the outline to 

straight-edged segments.

To use the lasso tool:

1 Double-click the lasso tool to open its Options 

palette.

2 To define a feathered edge as you make a 

selection, enter a pixel value for Feather.

3 To turn off anti-aliasing, deselect Anti-aliased.

See “Softening the edges of a selection” on 

page 102 for more information on feathering.

4 To draw a freehand selection border, drag 

around the area in the image. 

Freehand selection with 
lasso tool

5 To draw a straight-edged selection border, start 

dragging; then hold down Option (Macintosh) or 

Alt (Windows), and click where you want the 

segments to begin and end.

You can switch between drawing a freehand and 

straight-edged selection border while making a 

selection. When you release the mouse without 

holding down Option/Alt, Photoshop closes the 

selection border.

Using the polygon lasso tool

The polygon lasso tool lets you make a selection 

outline by clicking to set straight-edged segments 

and Option-dragging (Macintosh) or Alt-

dragging (Windows) to draw freehand segments. 
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To use the polygon lasso tool:

1 Drag to select the polygon lasso tool in the 

toolbox.

2 To define a feathered edge as you make a 

selection, enter a pixel value for Feather in the 

Options palette.

3 To turn off anti-aliasing, deselect Anti-aliased. 

See “Softening the edges of a selection” on 

page 102 for more information on feathering.

4 Click in the image to set the starting point for 

the selection.

5 Position the pointer where you want the first 

straight segment to end, and click. Continue 

clicking to set endpoints for subsequent straight 

segments.

6 To draw a freehand segment, hold down Option 

(Macintosh) or Alt (Windows) and drag. When 

you are finished with the freehand segment, 

release Option/Alt and the mouse button.

7 Continue to click and Option/Alt-drag to finish 

making the selection. Double-click to close the 

selection border.

Using the magnetic lasso tool

Like the lasso and polygon lasso tools, the 

magnetic lasso tool lets you draw both straight-

edged and freehand segments of a selection 

border. With the magnetic lasso tool, the border 

snaps to the edges of defined areas in the image. 

The magnetic lasso tool is especially useful for 

quickly selecting objects with complex edges set 

against high-contrast backgrounds.

To use the magnetic lasso tool:

1 Position the pointer next to the lasso tool in the 

toolbox, and drag to the right to select the 

magnetic lasso tool ( ). 

 To switch lasso tools quickly, press 

Shift+L.

2 To select options for the tool, double-click the 

magnetic lasso tool to display its Options palette, 

and set any of these options:

• To define a feathered edge as you make a 

selection, enter a pixel value for Feather.

• To turn off anti-aliasing, deselect Anti-aliased. 

See “Softening the edges of a selection” on 

page 102 for more information on feathering.

3 Click in the image to set the first fastening point. 

Fastening points anchor the selection border in 

place.

4 To draw a freehand segment, move the pointer 

along the edge you want to trace. (You can also 

drag with the mouse button depressed.) 
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The most recent segment of the selection border 

remains active. As you move the pointer, the active 

segment snaps to the strongest edge in the image. 

Periodically, the magnetic lasso tool adds fastening 

points to the selection border to anchor previous 

segments.

5 If the border doesn’t snap to the desired edge, 

click once to add a fastening point manually. 

Continue to trace the edge and add fastening 

points as needed.

Fastening points anchor selection border to edges.

6 To switch temporarily to the other lasso tools, 

do one of the following:

• To activate the lasso tool, hold down Option 

(Macintosh) or Alt (Windows) and drag with the 

mouse button depressed.

• To activate the polygon lasso tool, hold down 

Option/Alt and click.

7 To erase recently drawn segments and fastening 

points, press Delete. 

8 Close the selection border:

• To close the border with a freehand magnetic 

segment, double-click, or press Return 

(Macintosh) or Enter (Windows).

• To close the border with a a straight segment, 

hold down Option (Macintosh) or Alt (Windows), 

and double-click.

Using the magic wand tool
The magic wand tool ( ) lets you select portions 

of an image based on the color similarities of 

adjacent pixels. This tool can be useful for 

selecting a consistently colored area (for example, 

a red flower) without having to trace the outline 

with the lasso tool. When you use the magic wand 

tool, Adobe Photoshop determines whether the 

adjacent pixels are within the color range, or 

tolerance, that you specify. 

Note: You cannot use the magic wand tool on an 

image in Bitmap mode.

To use the magic wand tool:

1 Double-click the magic wand tool to display its 

Options palette.

2 For Tolerance, enter a value in pixels.

The tolerance can range from 0 to 255. Enter a low 

tolerance value to select colors very similar in color 

value to the pixel you click. Enter a higher 

tolerance to select a broader range of colors. 

Tolerance: 30 Tolerance: 60
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3 To turn off anti-aliasing, deselect Anti-aliased.

4 In the image, click the color you want to select. 

All adjacent pixels within the tolerance range are 

selected.

Selecting non-transparent pixels on a 
layer

You can quickly load a selection (called a trans-

parency mask) of all non-transparent areas on a 

layer, that is, all pixels that have color values. This 

is useful for making selections on a layer that 

contains both transparent and non-transparent 

areas.

To select all non-transparent pixels on a layer:

Do one of the following:

• In the Layers palette, Command-click 

(Macintosh) or Ctrl-click (Windows) the layer 

containing the pixels you want to load as a 

selection. See “Using the Layers palette” on 

page 154 for more information.

• To add the pixels to an existing selection, press 

Command+Shift/Ctrl+Shift and click the layer in 

the Layers palette.

• To subtract the pixels from an existing selection, 

press Command+Option/Ctrl+Alt and click the 

layer in the Layers palette.

• To load the intersection of the pixels and an 

existing selection, press Command+Option+ 

Shift/Ctrl+Alt+Shift and click the layer in the 

Layers palette.

Adjusting selections
Adobe Photoshop provides a variety of ways for 

you to adjust and refine your selections. You can 

refine a selection based on color similarity, or you 

can adjust the selection borders and add or 

subtract selections. You can also invert selections 

to select all the areas that were previously 

unselected. Before adding to or subtracting from a 

selection, make sure you have the same feather and 

anti-aliased settings in the Options palette that 

you used when you made the original selection so 

that the new selection border appears uniform.

Moving a selection border

You can easily move a selection border so that it 

encloses a different area of the image. This feature 

is useful for fine-tuning selections that are slightly 

misplaced.

You can drag a selection border partially beyond 

the canvas boundaries without clipping the 

selection border. The original border remains 

intact when you drag it back within the canvas 

boundaries.
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To move just the selection border: 

1 With any selection tool selected, position the 

pointer inside the selection border (the pointer 

becomes the selection pointer).

2 Drag the selection border to the location

you want. 

Original selection border Selection border moved

 Use the following methods to control the 

movement of a selection:

• To constrain the direction of movement to a 

multiple of 45°, begin dragging; then hold down Shift 

as you continue to drag. 

• To move the selection in 1-pixel increments, use the 

arrow keys on the keyboard.

• To move the selection in 10-pixel increments, hold 

down Shift and press an arrow key.

Adding to a selection

You can add to an existing selection or select more 

than one area of an image at a time. The resulting 

selection contains all the pixels in both the original 

and the new selection.

To add to a selection:

1 Make a selection.

2 With any selection tool selected, hold down 

Shift and select the area you want to add to the 

selection. 

Original selection using Selection extended using
rectangle marquee tool polygon lasso tool

Subtracting from a selection

You subtract from an existing selection by 

selecting the area you want to subtract. The 

resulting selection contains all the pixels in the 

original selection that are not in the new selection.

To subtract from a selection:

1 Make a selection. 

2 With any selection tool selected, hold down 

Option (Macintosh) or Alt (Windows) and select 

the area you want to subtract from the selection. 

Original selection using Subtracted selection using
rectangle marquee tool polygon lasso tool
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Selecting parts of selections

You can use any selection tool to select a portion of 

an existing selection. The area that intersects the 

original selection and the new selection becomes 

the resulting selection.

To select a portion of an existing selection: 

With a selection tool selected, press Option+Shift 

(Macintosh) or Alt+Shift (Windows) and drag 

over the areas of the original selection you want 

to keep. 

Using the Grow and Similar commands

The Grow and Similar commands let you expand 

a selection to include areas similar in color to the 

current selection. These commands use the 

tolerance specified in the Magic Wand Options 

palette to define the color range of pixels to be 

included in the expanded selection. 

Note: You cannot use the Grow and Similar 

commands on images that are in Bitmap mode.

To extend a selection based on color:

Do one of the following:

• Choose Select > Grow to include adjacent pixels 

that fall within the specified tolerance range. 

Original selection Grow command applied

• Choose Select > Similar to include pixels 

throughout the image, not just the ones next to the 

selection, that fall within the specified tolerance 

range. 

Original selection Similar command applied

You can choose either command more than once 

to increase the selection in increments.

Smoothing a selection

In some instances, making a color-based selection 

leaves stray pixels both inside and outside the 

selected area. You can clean up a selection by using 

the Smooth command to include or eliminate 

stray pixels in the selection. Smoothing is 

especially effective when you are blending, 

cloning, or making other changes that you want to 

appear seamless in the final selection.

To smooth a selection:

1 Choose Select > Modify > Smooth. 

2 For Sample Radius, enter a pixel value between 

1 and 16 and click OK.
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Adobe Photoshop checks the area around each 

pixel to find any unselected pixels that fall within 

the specified range. For example, if you enter 16 

for the sample radius, the program uses each pixel 

as the center of a 33-by-33-pixel area (16 pixels in 

the horizontal and vertical directions). If most of 

the pixels in the range are selected, any unselected 

pixels are added to the selection. If most of the 

pixels are unselected, any selected pixels are 

deleted from the selection.

Note: The relationship between physical distance 

and pixel distance varies, depending on the 

resolution of the image. For example, 5 pixels is a 

longer distance in an image with a resolution of 72 

ppi than it is in an image with a resolution of 300 

ppi. See “About resolution and image size” on 

page 25 for more information.

Expanding and contracting a selection 
border

Once you have made a selection, you can modify it 

by expanding or contracting the selection border. 

To expand a selection border:

1 Choose Select > Modify > Expand. 

2 For Expand By, enter a pixel value between 1 

and 16 and click OK.

The selection border is increased by the specified 

number of pixels. 

To contract a selection border:

1 Choose Select > Modify > Contract.

2 For Contract By, enter a pixel value between 1 

and 16 and click OK.

The selection border is decreased by the specified 

number of pixels. If part of the selection border 

runs along an edge of the image, that part is not 

affected by the Contract command.

Selecting a border around an area

You can define a selection and then select an area 

of a specified width framing the original selection. 

To select an area around an existing selection border: 

1 Choose Select > Modify > Border. 

2 Enter a value between 1 and 64 pixels for the 

width of the border, and click OK.

Original selection Border: 5 pixels
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Inverting a selection

Sometimes it is more convenient to select part of 

an image by first selecting the parts you don’t want 

and then inverting the selection. For example, if 

you want to select an object that is placed against a 

solid-colored background, you can use the magic 

wand tool to select the background first and then 

invert to select the foreground object. 

To select the unselected parts of an image:

Choose Select > Inverse. You can choose Inverse 

again to return to the original selection.

Background selected Inverse command selects
everything but the background

Softening the edges of a 
selection
In some cases, you might want to smooth the hard 

edges of a selection you plan to modify. You can 

make the transition between the pixels in the 

selection and the surrounding pixels more gradual 

by feathering or anti-aliasing.

Feathering a selection

Feathering blurs the edges of the selection by 

building a transition boundary between the 

selection and the surrounding pixels. The 

transition gradually blends the edges of the 

selection. This smoothing can cause some loss of 

detail at the edge of the selection. You can define a 

feathered edge for selections you make with the 

lasso tool, polygon lasso tool, or marquee tool, or 

you can add feathering to the edges of an existing 

selection. Be sure to feather a selection before you 

apply any editing changes. 

Original selection Selection feathered

Selection pasted into new

file with 10-pixel feather

Selection pasted into new

file with 30-pixel feather
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To define a feathered edge for the marquee tool or 
the lasso tool:

Enter a Feather value in the Marquee Options 

palette, the Lasso Options palette, or the Polygon 

Lasso Options palette. This value defines the width 

of the feathered edge and can range from 1 to 250 

pixels.

To define a feathered edge for an existing selection:

1 Choose Select > Feather.

2 Enter a value for the Feather Radius and 

click OK.

Note: When you make a small selection with a large 

feather radius, it’s possible to create such a faint 

selection that the selection edges are invisible. 

If a message appears stating “No pixels are more 

than 50% selected,” decrease the feather radius 

for the active selection tool, or increase the size of 

the selection.

Using the Anti-aliased option

Anti-aliasing produces a smooth-edged selection 

by partially filling edge pixels so that they are 

semitransparent. Because anti-aliasing removes 

jagged edges, it is especially useful when you’re 

creating composite images by cutting and pasting. 

No detail is lost, since only the edge pixels change. 

You can specify anti-aliasing for the lasso tool, 

polygon lasso tool, elliptical marquee tool, and 

magic wand tool. You must specify this option 

before using the selection tool; once the selection 

is made, you cannot add anti-aliasing to it.

To use anti-aliasing:

Make sure that Anti-aliased is selected in the Lasso 

Options palette, the Polygon Lasso Options 

palette, the Marquee Options palette, or the Magic 

Wand Options palette before using the tool. 

The following illustration shows a selection pasted 

into another image with and without anti-aliasing.

Anti-aliased option on Anti-aliased option off
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Hiding a selection border 
When you want to view a selection without the 

border—for example, to preview a moved 

selection—you can temporarily hide the selection 

border. Any changes you specify, such as fills or 

color adjustments, are still applied to the current 

selection, but the border remains hidden. 

The Hide Edges command affects the current 

selection only. The selection border reappears 

when you make another selection.

To hide or show a selection border:

Choose View > Hide Edges or Show Edges.

Using Quick Mask mode
Quick Mask mode lets you isolate and refine a 

selection by covering the unselected areas of your 

image with a temporary mask. Color differentiates 

the protected (masked) and unprotected 

(selected) areas. 

You can start with a selected area and then use 

Quick Mask mode to add to or subtract from it to 

make the mask. Or you can create the mask 

entirely in Quick Mask mode. Once you leave 

Quick Mask mode, the unprotected areas become 

a selection.

To create a quick mask:

1 Using any selection tool, select the part of the 

image you want to change.

2 Click the Quick Mask mode button ( ) in the 

toolbox.

A color overlay (similar to a piece of rubylith) 

covers the masked area outside the selection. By 

default, Quick Mask mode colors the masked area 

using a red, 50% opaque overlay. 

3 To edit the mask, select a painting tool from the 

toolbox, and do one of the following:

• To subtract from the selection and increase the 

masked area, paint with black in the image.

• To subtract from the masked area and add to the 

selection, paint with white in the image.

Note: If you have selected the Selected Areas option 

in the Quick Mask Options dialog box, the painting 

effects are reversed. 

4 Click the Standard mode button ( ) in the 

toolbox to turn off the quick mask and return to 

your original image. The unprotected area of the 

quick mask is now surrounded by a selection 

border.

5 Apply the desired changes to the image. 

Changes affect only the selected area. 

6 Choose Select > None to deselect the selection. 
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To change the Quick Mask options:

1 Double-click the Quick Mask mode button 

( ) in the toolbox.

2 Choose one of the following display options:

• Masked Areas to color only the protected areas. 

This default option colors the areas outside the 

selection. Painting with black adds to the mask, 

while painting with white subtracts from the 

mask.

• Selected Areas to color only the selected, or 

unprotected, areas. Painting with white adds to the 

mask, and painting with black subtracts from the 

mask.

To toggle between the Masked Areas and 

Selected Areas options, Option-click 

(Macintosh) or Alt-click (Windows) the Quick Mask 

mode button.

3 To choose a different color for the mask, click 

the color swatch and choose a new color, as 

explained in “Using the Adobe Photoshop Color 

Picker” on page 146. Then click OK.

4 Enter an Opacity value for the mask color. Use 

this setting to change the transparency of the mask 

color. This setting controls only the mask’s 

appearance; it does not indicate how much of the 

underlying area is actually protected.

When the Masked Areas option is selected in the 

Quick Mask Options dialog box, the Quick Mask 

button in the toolbox appears as a white circle on 

a gray background ( ). When the Selected Areas 

option is selected, the icon appears as a gray circle 

on a white background ( ).
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Chapter 6: Editing

dobe Photoshop Limited Edition lets you 

edit and modify selections and layers of 

images in many ways. (For information 

on how to make selections, see Chapter 

5, “Selecting.”) This chapter describes the editing 

tools and techniques, including how to move, 

copy, and paste selections, how to use the eraser 

tool, the smudge tool, the blur/sharpen tool, the 

dodge/burn/sponge tool, and the type and type 

mask tools, and how to apply special effects to a 

selected area.

Keep in mind that pixels can exist beyond the 

visible canvas when you drag or paste a selection 

onto a layer, apply a transformation, or create 

artwork or type. You can move the pixels back 

onto the visible canvas using the move tool or 

selection arrow; modify or reposition the pixels 

using the Scale, Rotate, or Flip Transform 

commands; or increase the canvas size to incor-

porate the pixels without discarding them. But as 

long as the pixels are beyond the visible canvas, 

you cannot paint or modify them (for example, 

using filters or the Levels command). 

Indicating when tasks finish
The Beep When Done preference setting causes 

Adobe Photoshop to sound a beep whenever the 

program finishes performing a task requiring 

a progress bar. After the beep, you can continue 

working with the program.

To set the beep:

1 Choose File > Preferences > General.

2 Select Beep When Done, and click OK.

Interrupting operations
When trying to cancel an operation in progress 

(when Adobe Photoshop displays a progress bar), 

press Command+[.] (Macintosh) or hold down 

Esc until the operation in progress has stopped 

(Windows).

Correcting a mistake
You don’t need to be overly concerned about 

making mistakes while using the Adobe 

Photoshop program. Most operations can be 

undone using the Undo command. 

In some cases, the information held in memory by 

the Undo command or Clipboard can be so large 

that it prevents Photoshop from performing the 

next operation. The Purge command clears the 

operation stored by the Undo command or the 

Clipboard to free up memory, preventing you 

from undoing an operation or reapplying the 

information held on the Clipboard. 

To undo the last performed operation only:

Choose Edit > Undo. 

If an operation can’t be undone, the Undo choice 

is dimmed and reads “Can’t Undo.”

A
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To free memory used by the Undo command or by the 
Clipboard:

Choose Edit > Purge, and choose Undo to clear the 

operation stored by the Undo command or 

Clipboard to free up memory. 

If the Undo buffer or Clipboard is empty, it 

appears dimmed.

You cannot undo the Purge command.

Restoring an image
You can undo a series of operations that you have 

performed by restoring all or part of an image to 

its last saved version.

To reverse all changes made to the image since it was 
last saved:

Choose File > Revert, and click Revert.

To restore part of an image to its previously saved 
version:

Use the eraser tool with the Erase to Saved option 

selected in its Options palette. For more infor-

mation, see “Using the eraser tool” on page 130.

Duplicating images
You can copy an entire image (including all layers) 

into the available memory on your system without 

saving the image to disk by using the Duplicate 

command or by dragging and dropping. Dupli-

cating is useful when you want to experiment with 

different effects on an image without permanently 

changing it. For example, you can duplicate an 

image, modify it, and then compare the results to 

the original.

To duplicate an image using the Duplicate command:

1 Open the image you want to duplicate.

2 Choose Image > Duplicate.

3 Enter a name for the duplicate image.

4 Click OK.

 To duplicate an image without naming it, hold 

down Option (Macintosh) or Alt (Windows) as 

you choose Image > Duplicate.
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Moving selections
You move a selection by dragging it to a new 

location using the move tool. 

To move a selection:

1 Select the move tool ( )in the toolbox. 

To activate the move tool when any other tool is 

selected, hold down Command (Macintosh) or 

Ctrl (Windows). 

2 Move the pointer inside the selection border, 

and drag the selection to the position you want. 

If you have selected multiple areas, all move as 

you drag.

Original selection Moving selection with 
move tool

Using rulers
Photoshop includes rulers to help you align 

artwork. When visible, rulers appear along the top 

and left side of the active window. Markers in 

the ruler display the pointer’s position when you 

move it. 

Changing the ruler origins (the 0, 0 mark on the 

top and left ruler) lets you measure from a specific 

point on the image.

To display or hide rulers:

Choose View > Show Rulers or Hide Rulers.

To change the rulers’ zero origin:

Position the pointer over the intersection of the 

rulers in the upper left corner of the window and 

drag diagonally down onto the image. To make the 

ruler origin snap to the ruler ticks, hold down Shift 

as you drag. A set of crosshairs appears, marking 

the new origin on the rulers.

Note: To reset the ruler origin to its default value, 

double-click the upper left corner of the rulers.
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To change the rulers’ settings:

1 Do one of the following:

• Double-click a ruler. 

• Choose File > Preferences > Units & Rulers.

2 For Units, choose a unit of measurement.

3 For Width and Gutter, enter values for the 

column size. If desired, you can change the units 

for these options.

Some layout programs use the column width 

setting to specify the display of an image across 

columns. The Image Size and Canvas Size 

commands also use the column width setting; 

for more information, see “Changing the print 

dimensions and resolution of an image” on 

page 34 and “Increasing the size of the work 

canvas” on page 48.

4 For Point/Pica Size, choose from the following 

options:

• PostScript (72 points per inch) if you are 

printing to a PostScript device.

• Traditional to use 72.27 printer’s points per inch.

5 Click OK.

Copying a selection
You can copy a selection by choosing Edit > Copy. 

You can also copy a selection as you move it within 

an image, or as you drag it from one image to 

another.  A valid drag-and-drop destination 

appears outlined in boldface when you drag 

over it. 

Copying a selection as you move it

You can copy a selection as you use the move tool 

to drag it, or you can use the arrow keys to create 

multiple duplicates of the selection. 

To copy a selection while dragging: 

1 Select the move tool or hold down Command 

(Macintosh) or Ctrl (Windows) to activate the 

move tool. 

2 Hold down Option (Macintosh) or Alt 

(Windows), and drag the selection you want to 

copy and move.

Original selection Duplicate selection

To create multiple copies of a selection: 

1 Select the move tool or hold down Command 

(Macintosh) or Ctrl (Windows) to activate the 

move tool.

2 Do one of the following:

• To copy the selection and offset the duplicate by 

1 pixel, hold down Option (Macintosh) or Alt 

(Windows), and press an arrow key.

• To copy the selection and offset the duplicate by 

10 pixels, press Option+Shift/Alt+Shift, and press 

an arrow key.
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As long as you hold down Option/Alt, each press 

of an arrow key creates a copy of the selection and 

offsets it by the specified distance from the last 

duplicate. 

Copying a selection from one Photoshop 
image to another

You can use the Edit > Copy and Paste commands 

to copy selections between Photoshop images. 

However, it is often faster and easier to drag a 

selection from one Photoshop image and drop it 

into another; it also saves memory by not using the 

Clipboard. The drag-and-drop method requires 

that both images be open, and creates a new layer 

when the selection is dropped. 

To copy a selection from one open Adobe Photoshop 
image to another:

Select the move tool, and drag the selection from 

the active image window into the destination 

image window. If nothing is selected, the entire 

active layer is copied. A valid drag-and-drop desti-

nations appears outlined in boldface when you 

drag over it.

Selection dragged to new image

Result

Copying between applications
In some cases, you can copy selections between a 

Photoshop image and another application by 

dragging and dropping. You can also use the 

Clipboard to copy a selection in Adobe Photoshop 

and paste it in another application, or vice versa. 

Dragging selections between 
applications

On the Macintosh, you can drag and drop images 

between Adobe Photoshop and other applications 

that support Macintosh Drag Manager, provided 

that your system is running System 7.0. or 7.1 

or higher with the Drag Manager Extension 

or System 7.5 or higher. Dragging vector artwork 

from Adobe Illustrator or from other applications 

that use the Illustrator Clipboard rasterizes 

the artwork.
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Copying selections between Adobe 
Photoshop and another application

A selection cut or copied using the Edit > Cut or 

Edit > Copy command remains on the Clipboard 

until you copy or cut another selection. By default, 

when you quit Adobe Photoshop, or switch to 

another application, the contents of the Clipboard 

are converted to bitmap format (that is, 

rasterized). This conversion lets you paste 

the Clipboard’s contents into a file created in 

another application.

To save time, you can disable this automatic 

conversion if you don’t plan to paste the Clipboard 

contents into other applications. The automatic 

conversion does not affect the pasting of selections 

between Photoshop images. 

To change the Export Clipboard preference:

1 Choose File > Preferences > General. 

2 Do one of the following:

• Select Export Clipboard to save the contents 

of the Clipboard upon quitting Photoshop 

(Macintosh) or to display a prompt upon quitting 

Photoshop asking you whether to make the 

contents of the Clipboard available to other 

applications (Windows). 

• Deselect Export Clipboard to delete the 

Clipboard contents upon quitting the program. In 

Windows, the Clipboard contents are also deleted 

when you switch applications.

3 Click OK.

Pasting a selection 
Adobe Photoshop offers a range of pasting options 

that control how the pasted selection appears in 

the image. The Paste command pastes a cut or 

copied selection into another part of the image or 

into another image as a new layer. You can then 

control the opacity of the pasted pixels using the 

Layers palette.

Pasting using different resolutions

When you’re pasting between images that have 

different resolutions, the pasted data retains its 

current pixel dimensions when pasted. This can 

make the pasted contents appear out of 

proportion to the new image. To match the 

images, use the Image Size command to make the 

source and destination images the same resolution 

before copying and pasting (see“Changing the 

pixel dimensions of an image” on page 34). 

Deleting a selection
To delete a selection, choose Edit > Clear or press 

Delete (Macintosh) or Backspace (Windows). To 

cut a selection to the Clipboard, choose Edit > Cut. 

Deleting a selection on a background or on a layer 

with the Preserve Transparency option selected 

replaces the original location with the background 

color; deleting a selection on a layer with the 

Preserve Transparency option deselected replaces 

the original area with the layer transparency.
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Rotating and flipping an image
The Image > Rotate Canvas commands let you 

rotate or flip the entire contents of an image.

To rotate or flip an image:

Choose Image > Rotate Canvas and, from the 

submenu, choose one of the following commands:

• 180º to rotate by a half-turn.

• 90º CW to rotate clockwise by a quarter-turn.

• 90º CCW to rotate counterclockwise by a 

quarter-turn.

• Arbitrary to enter an amount of rotation 

between 0 and 359.99º; then select CW to rotate 

clockwise or CCW to rotate counterclockwise, and 

click OK. 

Note: Entering a negative number between 

–359.99º and 359.99º rotates the image in the 

opposite direction specified.

• Flip Horizontal to flip horizontally, along the 

vertical axis.

• Flip Vertical to flip vertically, along the 

horizontal axis.

Original Canvas rotated

Applying transformations
Using the Edit > Transform commands, you can 

transform a selection or layer by rotating, scaling, 

or flipping it. When you transform a linked layer, 

the transformation affects all the layers in the 

linking group.

Note: You cannot apply transformations to the 

background as a layer. You can, however, transform 

selections on the background.

Using interpolation

To calculate the color values of pixels that are 

added or deleted during transformation, Adobe 

Photoshop uses the interpolation method selected 

in the General Preferences dialog box.

This option directly affects the speed and quality 

of the transformation. The default Bicubic inter-

polation is the slowest method, but yields the best 

results. For more information on different inter-

polation options, see “Choosing an interpolation 

method” on page 36.

Applying a specific transformation

The commands under the Transform submenu let 

you apply specific transformations to a selection 

or layer. When you use the Scale or Rotate 

command, Photoshop previews the effect and 

surrounds the selected area with a bounding 

border. You drag the handles at the corners and 

sides of the bounding border to manipulate 

the selection or layer according to the specified 

transformation. 
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You can manipulate a selection or layer using 

several transformation commands in succession 

before applying the cumulative transformation. 

For example, you can choose Edit > Transform > 

Scale, and drag a handle to scale; you can then 

choose Edit > Transform > Rotate, drag to rotate, 

and press Return (Macintosh) or Enter 

(Windows) to apply both transformations. 

To scale or rotate:

1 Do one of the following:

• To transform part of a layer, select that area of 

the layer.

• To transform an entire layer, make the layer 

active and make sure that nothing is selected. 

2 Choose Edit > Transform > Scale or Rotate.

3 Drag the handles to achieve the desired effect.

4 To apply additional transformations, repeat 

steps 2 and 3.

5 Press Return (Macintosh) or Enter (Windows) 

to apply the cumulative transformation. Press Esc 

to cancel the transformation.

Original Green leaf layer rotated

To flip or rotate a selection or layer:

1 Do one of the following:

• To transform part of a layer, select that area of 

the layer.

• To transform an entire layer, make the layer 

active (see“Using the Layers palette” on page 154), 

and make sure that nothing is selected.

2 Choose Edit > Transform and, from the 

submenu, choose one of the following commands:

• Rotate 180º to rotate by a half-turn.

• Rotate 90º CW to rotate clockwise by a quarter-

turn.

• Rotate 90º CCW to rotate counterclockwise by a 

quarter-turn.

• Flip Horizontal to flip horizontally, along the 

vertical axis.

• Flip Vertical to flip vertically, along the 

horizontal axis.

Original selection Selection on green leaf 
layer flipped
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Using the rubber stamp tool 
The rubber stamp tool ( ) lets you paint a copy, 

or a modified copy, of an image or color into the 

same image or into another image. The Clone 

options of the rubber stamp tool make a copy of, 

or sample, an image and paint an exact duplicate of 

that image. 

To use the rubber stamp tool:

1 Double-click the rubber stamp tool ( ) to 

display its Options palette.

2 Choose a mode, as explained in “Selecting a 

blending mode” on page 136.

3 Drag the slider to set the opacity, as explained in 

“Specifying the opacity, pressure, or exposure” on 

page 135.

4 Choose a Clone option. The Clone options 

determine how the tool takes a sample of the 

image, which you can then apply, or paint, over 

another image or over another part of the same 

image. Each stroke of the tool paints on more of 

the sampled image. See the following sections on 

the Clone options.

5 Position the pointer on the part of the image 

you want to sample, and Option-click 

(Macintosh) or Alt-click (Windows). This sample 

point is the location from which the image will 

begin to be duplicated as you paint. 

Option-click (Macintosh) or Alt-click 

(Windows) with the rubber stamp tool to 

sample from any open Adobe Photoshop window 

without changing the active window. 

6 Drag to paint with the rubber stamp tool.

Clone (aligned) option

The Clone (aligned) option applies the entire 

sampled area once, regardless of how many times 

you stop and resume painting. This option is 

useful when you want to use different sized 

brushes to paint an image. You can also use the 

Clone (aligned) option for duplicating two halves 

of a single image and placing them at different 

locations. 

In the following illustration, the image is sampled 

using the petal in the upper left as the sampling 

point; the petal in the lower right is then painted 

in. Crosshairs mark the part of the original 

sampled image that is currently being applied.
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Clone (nonaligned) option

This option applies the sampled area from the 

initial sampling point each time you stop and 

resume painting. Because the rubber stamp tool 

samples the entire image, this option is useful for 

applying multiple copies of part of an image to 

different locations. 

Sampling point Crosshairs mark the part 
of the original being applied.

Using the smudge tool
The smudge tool ( ) simulates the actions of 

dragging a finger through wet paint. The tool picks 

up color from where the stroke begins and pushes 

it in the direction in which you drag. 

Note: The smudge tool cannot be used with Bitmap 

or Indexed color mode images.

To use the smudge tool:

1 Double-click the smudge tool ( ) to display its 

Options palette.

2 Choose a mode, as explained in “Selecting a 

blending mode” on page 136.

3 Drag the slider to set the pressure, as explained 

in “Specifying the opacity, pressure, or exposure” 

on page 135.

4 To smudge using the foreground color at the 

beginning of each stroke, select Finger Painting. If 

you leave this option deselected, the smudge tool 

uses the color under the pointer at the beginning 

of each stroke.

5 Drag in the image to smudge color in the 

direction of the drag.

Smudging an image

Press Option (Macintosh) or Alt (Windows) as 

you drag with the smudge tool to use the Finger 

Painting option.

+
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Using the focus tools
The focus tools include the blur tool ( ), which 

lets you blur hard edges or areas in an image to 

reduce detail, and the sharpen tool ( ), which lets 

you sharpen soft edges to increase clarity or focus. 

Note: The blur and sharpen tools cannot be used 

with Bitmap or Index color mode images.

For other ways to adjust image sharpness, see 

“Step 5: Sharpen the image” on page 83 or 

“Choosing a filter effect” on page 183.

To use the blur or sharpen tool:

1 Double-click the blur or sharpen tool ( / ) in 

the toolbox to display the Focus Tools Options 

palette. 

2 For Tool, choose Blur or Sharpen.

3 Choose a mode, as explained in “Selecting a 

blending mode” on page 136.

4 Drag the slider to set the pressure, as explained 

in “Specifying the opacity, pressure, or exposure” 

on page 135.

5 Drag over the part of the image you want to blur 

or sharpen.

Blurring an image Sharpening an image

Using the toning tools
The toning tools include the dodge and burn tools 

( / ), which let you lighten or darken, respec-

tively, specific areas of an image, and the sponge 

tool ( ), which lets you change the color 

saturation of an area. 

The dodge and burn tools are based on the tradi-

tional photographer’s technique of increasing the 

amount of exposure given to a specific area on a 

print. Photographers hold back light during an 

exposure to lighten an area on the print (dodging) 

or increase the exposure to darken areas on a print 

(burning-in). The sponge tool is useful for subtly 

increasing or reducing the saturation in an area. In 

Grayscale mode, the sponge tool increases or 

decreases contrast by moving gray levels away 

from or toward the middle gray.

Note: The dodge, burn, and sponge tools cannot be 

used with Bitmap or Index color mode images.

To use the dodge or burn tool:

1 Double-click the dodge, burn, or sponge tool in 

the toolbox to display the Toning Tools Options 

palette. 

2 For Tool, choose Dodge or Burn.

3 Choose one of the following modes to limit the 

changes to specific parts of the image:

• Midtones to change only the middle range of 

grays in the image.

• Shadows to alter the dark portions of the image.
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• Highlights to modify only the light pixels. 

Original image Dodging an image

4 Drag the slider to set the exposure, as explained 

in “Specifying the opacity, pressure, or exposure” 

on page 135.

5 Drag over the part of the image you want to 

lighten or darken.

To use the sponge tool:

1 Double-click the dodge, burn, or sponge tool 

in the toolbox to display the Toning Tools Options 

palette.

2 For Tool, choose Sponge.

3 Choose one of the following modes to define the 

action of the sponge:

• Saturate to intensify the color’s saturation.

• Desaturate to dilute the color’s saturation. 

4 Drag the slider to set the pressure, as explained 

in “Specifying the opacity, pressure, or exposure” 

on page 135.

5 Drag over a portion of the image to change its 

saturation.

Using the type and type mask 
tools
Adobe Photoshop lets you add bitmap type to an 

image using the type tool ( ). You can specify the 

leading, spacing, type styles, and alignment of the 

type. Normally, large bitmap characters appear 

jagged on the screen. However, if you use the 

Adobe Type Manager® (ATM®) program installed 

with Adobe Photoshop, or if you use TrueType™ 

fonts, characters appear almost as smooth and as 

well-defined as outline type. 

Bitmap type differs from the outline type 

generated in object-oriented applications such as 

Adobe Illustrator. In bitmap applications such as 

Adobe Photoshop, type is rendered at the 

resolution of the image. For example, if the 

resolution of the image is 100 ppi, the resolution of 

the type will also be 100 ppi. You can’t edit the text 

contents of the bitmap type after you have placed 

it into the image.

For best results, import your Adobe Photoshop 

image into a page-layout program that supports 

PostScript language type, and create the type using 

that program.

Bitmap type; inset Outline type; inset
zoom 350% zoom 350%
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Adding type to an image

You use the type tool to create bitmap type, which 

is added to the image as a new layer using the 

foreground color. You can also use the type mask 

tool to create a selection border in the shape of the 

type. This type selection can be moved, edited, 

filled, or stroked just like any other selection. 

To add type filled with the foreground color: 

1 Select the type tool ( ).

2 Click where you want the type to appear.

3 Choose a font, and specify a size for the type. 

If you’ve added or removed fonts from your system 

since starting Photoshop, you can update the Font 

menu in the Type Tool dialog box by holding down 

Shift and clicking in the image with the type tool.

4 Enter values for the leading and spacing. See 

“Setting the leading” on page 122 and “Setting the 

letterspacing” on page 122 for information on 

these options.

5 Select a style and alignment for the type. See 

“Selecting style options for type” on page 122 and 

“Aligning type” on page 123 for information on 

these options.

6 Type the text in the text box. Press Return 

(Macintosh) or Enter (Windows) to create a line 

break.

The type automatically wraps in the dialog box, 

but it appears as a single line in the image unless 

you press Return/Enter. You can enter up to 32,000 

characters (or as much as the Windows text box 

holds, whichever is smaller).

7 To display the text in the text box as it will 

appear in the image, select Font and Size for Show. 

(When working with very large type sizes, deselect 

Size to prevent the pointer or type fro disappearing 

from the text box.)

8 Click OK. Type appears in the foreground color 

on a new layer.

Type with foreground color New layer

Note: In Windows, incompatibilities with some 

video drivers may cause TrueType fonts to rasterize 

incorrectly or not at all. (Type 1 fonts rasterized with 

ATM are not affected.) To work around the problem, 

create type at a large point size and then scale it 

down as desired using the Scale command. Contact 

your video driver manufacturer for an updated 

driver that addresses this problem.
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To create a type selection border:

1 Select the type mask tool ( ).

2 Click where you want the type selection border 

to appear.

3 Specify type options and enter the text as 

described in steps 3 through 6 in the previous 

procedure.

4 Click OK. The type selection border appears in 

the image on the active layer.

Changing type opacity

Type created using the type tool appears as a new 

layer in the Layers palette. To change the type’s 

opacity, choose a different opacity from the 

Layers palette. 

Change type opacity...  using the Layers palette.

Setting the leading 

You control the spacing between lines of text, 

called leading, using the Leading option in the 

Type Tool dialog box. Leading is measured from 

baseline to baseline. The leading setting uses the 

same unit of measurement you specify for the font 

size (either points or pixels); by default, the 

leading built into the font is used. Values can range 

from 1 to 1000.

Setting the letterspacing 

You can control the spacing between letters using 

the Spacing option in the Type Tool dialog box. 

The Spacing setting uses the same unit of 

measurement that is specified for the font size 

(either points or pixels). Positive values increase 

the spacing; negative values reduce the spacing. 

Spacing increments can be as small as tenths of 

a point or pixel (from –99.9 to 999.9).

Selecting style options for type 

You can apply six Style options for type—bold, 

italic, underline, outline, strikethrough, and anti-

aliased—individually or in combination.

Type, like all images in Adobe Photoshop, is 

composed of pixels. The Anti-aliased option in 

the Type Tool dialog box lets you minimize the 

pixel contrast at the edges of the text. When you 

select this option, the edges of the text appear 

smooth and blend into the background. You’ll 

probably want to use anti-aliased type in your 

images, unless you are working with type in 

small point sizes.

Anti-aliased type; inset Type without anti-aliasing;
zoom 350% inset zoom 350%
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Aligning type 

Adobe Photoshop aligns type in reference to the 

last point you clicked with the type tool. For 

example, to center type on the image, select the 

type tool, click the center of the image, and then 

click the Center Alignment option in the Type Tool 

dialog box.

The Type Tool dialog box includes the following 

Alignment options:

• The left column of Alignment options aligns 

text horizontally. 

• The right column aligns text vertically.

• The top alignment options begin the text at the 

insertion point that you click in the image.

• The center alignment options center the text 

around the insertion point.

• The bottom alignment options end the text at 

the insertion point. 

Adjusting individual characters 

When a text block is on its own layer, you can 

select individual characters and words in the text 

block. You then can move these characters to 

another position on the image and adjust letter-

spacing. You use a similar technique for 

deselecting characters in a type mask.

To select type characters or to deselect characters 
in a type mask:

Do one of the following:

• To select type characters, select the lasso tool, 

and drag around the character or characters you 

want selected. To add additional characters to the 

selection, hold down Shift and drag the lasso 

around the additional characters.

• To deselect characters in a type mask, select the 

lasso tool, hold down Option (Macintosh) or Alt 

(Windows), and drag around the character or 

characters you want to deselect. 

Note: Be sure to encircle the entire character you 

want to select or deselect; any part of a character 

outside the lasso is not changed.

To move characters in a type mask, switch to 

Quick Mask mode. Then select 

the characters you want to move, press 

Command+Option (Macintosh) or Ctrl+Alt 

(Windows) and press an arrow key. Deselect the 

characters and exit Quick Mask mode. 
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To adjust letterspacing manually:

Do one of the following:

• Hold down Command (Macintosh) or Ctrl 

(Windows) to activate the move tool, position the 

pointer inside one of the selected characters, and 

drag the characters to their new positions. To 

constrain the direction of movement to a multiple 

of 45º, hold down Shift as you drag.

• Hold down Command (Macintosh) or Ctrl 

(Windows) to activate the move tool, and press 

the arrow keys to move the selected characters 

in 1-pixel increments (or hold down Shift and 

press an arrow key to move the type in 10-pixel 

increments).
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Chapter 7: Painting 

he painting tools and fill commands let you 

change the color of pixels to modify and 

create areas in your image. This chapter 

describes how to paint an image using the painting 

tools, how to fill and stroke selections, and how to 

choose and edit colors for painting and filling. 

Choosing the foreground and 
background colors
Adobe Photoshop Limited Edition uses the 

foreground color, which appears in the top color 

selection box in the toolbox, to paint, fill, and 

stroke (paint the border of) selections. The 

background color, shown in the lower color 

selection box, is used for making gradient fills and 

for filling in the erased areas of an image. 

The default foreground color is black, and the 

default background color is white. (If you are 

in Quick Mask Mode, the default foreground 

and background colors are white and black, 

respectively.)

A. Switch Colors icon B. Foreground color
C. Background color D. Default Colors icon

To reverse the foreground and background colors:

Click the Switch Colors icon in the toolbox. 

To return to the default foreground and background 
colors:

Click the Default Colors icon in the toolbox.

To change the foreground or background color:

1 Do one of the following:

• To change the foreground color, click the top 

color selection box in the toolbox.

• To change the background color, click the lower 

color selection box in the toolbox.

2 Choose a color, as explained in “Using the 

Adobe Photoshop Color Picker” on page 146, and 

click OK.

To switch between the foreground and 

background colors, press X on the keyboard.

Using the painting tools
The painting tools include the paintbrush tool, the 

airbrush tool, and the pencil tool. Each painting 

tool paints with the specified brush and tool 

pointer. For more information, see “Using the 

Brushes palette” on page 131 and “Using the tool 

pointers” on page 9.

To save time when working with painting tools, 

make sure that the Navigator/Info/Options palette 

group and the Color/Swatches/Brushes palette 

group are open on your desktop. 

T

B

C

A

D

B

C

A

D
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Using the paintbrush tool

The paintbrush tool ( ) lets you create soft 

strokes of color.

To use the paintbrush tool:

Select the paintbrush tool and drag in the image.

To draw a straight line with any painting tool, 

click a starting point in the image; then hold 

down Shift and click an endpoint.

To choose options for the paintbrush tool:

1 Double-click the paintbrush tool ( ) in the 

toolbox to display its Options palette. 

2 Choose a mode, as explained in “Selecting a 

blending mode” on page 136.

3 Drag the slider to set the opacity, as explained in 

“Specifying the opacity, pressure, or exposure” on 

page 135.

4 Select Fade to set a fade-out rate, as explained in 

“Specifying the paint fade-out rate” on page 135.

5 Select Wet Edges to paint with a watercolor 

effect. With this option selected, the paint builds 

up along the edges of the brush stroke. 

Using the airbrush tool

The airbrush tool ( ) lets you apply gradual tones 

(including sprays of color) to an image. It 

simulates the effect produced by traditional 

airbrush techniques. The edges of the stroke are 

more diffused than those created with the paint-

brush tool. The pressure setting for the airbrush 

tool determines how quickly the spray of paint 

is applied.

To use the airbrush tool:

Select the airbrush tool and drag in the image. To 

build up color, hold down the mouse button 

without dragging.

To choose options for the airbrush tool:

1 Double-click the airbrush tool in the toolbox to 

display its Options palette. 

2 Choose a mode, as explained in “Selecting a 

blending mode” on page 136.

3 Drag the slider to set the pressure, as explained 

in “Specifying the opacity, pressure, or exposure” 

on page 135.

4 Select Fade to set a fade-out rate, as explained in 

“Specifying the paint fade-out rate” on page 135.

Using the pencil tool

The pencil tool ( ) creates hard-edged freehand 

lines and is most useful for bitmapped images. See 

“Using the Auto Erase option” on page 131 for 

information on erasing with the tool.

Off

On
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To draw a freehand line:

Select the pencil tool and drag in the image.

To choose options for the pencil tool:

1 Double-click the pencil tool ( ) to display its 

Options palette.

2 Choose a mode, as explained in “Selecting a 

blending mode” on page 136.

3 Drag the slider to set the opacity, as explained in 

“Specifying the opacity, pressure, or exposure” on 

page 135.

4 Select Fade to set a fade-out rate, as explained in 

“Specifying the paint fade-out rate” on page 135.

Using the line tool
The line tool ( ) draws straight lines on an image. 

Line tool options let you specify the width of lines, 

set anti-aliasing, and create lines with arrowheads. 

To draw a line:

Select the line tool and drag in the image. To 

constrain the line angle to a multiple of 45°, hold 

down Shift as you drag. 

Constraining angles when 
using the line tool

To choose options for the line tool: 

1 Double-click the line tool in the toolbox to 

display its Options palette. 

2 Choose a mode, as explained in “Selecting a 

blending mode” on page 136.

3 Drag the slider to set the opacity, as explained in 

“Specifying the opacity, pressure, or exposure” on 

page 135.

4 Enter the line width in pixels.

5 To draw anti-aliased lines, make sure that Anti-

aliased is selected. 

6 To include arrowheads, select Start, End, or 

both to specify where you want arrowheads.

7 To edit the appearance of arrowheads, click 

Shape and do the following:

• Enter a value from 10 to 1000% of the line width 

for the width of the arrowhead. 

• Enter a value from 10 to 5000% of the line width 

for the length of the arrowhead. 

90°

45°

0°
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• Enter a value from –50 to +50% for the 

concavity of the arrowhead. The concavity value 

defines the amount of curvature on the widest part 

of the arrowhead, where the arrowhead meets 

the line. 

Arrowheads created with
different values

Erasing
The eraser tool and the Auto Erase option for the 

pencil tool let you replace colors in an image either 

with the background color or with transparency.

Using the eraser tool

The eraser tool changes pixels in the image as 

you drag through them. You can choose to change 

the color and transparency of the affected pixels, 

or to revert the affected area to its previously 

saved version.

To use the eraser tool:

Select the eraser tool ( ) and drag through the 

area you want to erase.

If you’re working in the background, the pixels 

are changed to the background color. If you’re 

working in a layer, the color is replaced by 

transparency.

Erasing pixels from a layer exposes background

To choose options for the eraser tool:

1 Double-click the eraser tool to display its 

Options palette. 

2 Choose the tool type you want to use as an 

eraser—paintbrush, airbrush, pencil, or block. 

To cycle through the eraser tool types, Option-

click (Macintosh) or Alt-click (Windows) the 

eraser tool, or press Shift+E on the keyboard.

3 Drag the slider to set the opacity or pressure, as 

explained in “Specifying the opacity, pressure, or 

exposure” on page 135.

4 Select Fade to set a fade-out rate, as explained in 

“Specifying the paint fade-out rate” on page 135.

Note: If you’re using the paintbrush option, you can 

select Wet Edges to erase with a watercolor effect. 

With this option selected, the erased effect builds up 

along the edges of the brush stroke. 
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5 To erase to a saved version of the image, select 

Erase to Saved. 

To use the eraser tool in Erase to Saved mode, 

hold down Option (Macintosh) or Alt 

(Windows) as you drag in the image.

6 To erase an entire layer to transparency or to 

erase a background to the background color, click 

Erase Layer. (If the image has no layers, this button 

becomes Erase Image.)

Using the Auto Erase option

The Auto Erase option for the pencil tool ( ) lets 

you paint the background color over areas 

containing the foreground color.

To use the Auto Erase option:

1 Double-click the pencil tool to display its 

Options palette.

2 Select Auto Erase.

3 Drag over the image. 

If you drag over the foreground color, the area is 

erased to the background color (according to the 

tool’s opacity). If you begin dragging from an area 

that doesn’t contain the foreground color, the area 

is painted with the foreground color. 

Using the Brushes palette
The brushes you use for the painting and editing 

tools appear in the Brushes palette. Round brush 

shapes for the painting and editing tools are 

available in several sizes. Adobe Photoshop retains 

the brush settings for each painting and editing 

tool, so you can select a different default brush for 

each tool. The Brushes palette also contains 

commands for creating and deleting brushes, 

defining brush options, and saving and loading 

sets of brushes. 

Choosing a brush 

You use the Brushes palette to choose a brush 

shape for any painting tool. When a brush is too 

large to fit in a square on the palette, it appears in 

a reduced size with a number that indicates the 

brush diameter in pixels.
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To choose a brush:

1 Select the tool you want to use.

2 Choose Window > Show Brushes. 

3 Click the brush you want to use.

Creating and deleting brushes

If the Brushes palette does not contain the brushes 

you need, you can create new brushes. New 

brushes are added at the bottom of the palette. If 

you find that you no longer use a brush, you can 

delete it from the Brushes palette. 

To create a brush:

1 Do one of the following:

• Click in the empty area outside the brush 

squares in the Brushes palette.

• Choose New Brush from the Brushes palette 

menu.

The preview box in the lower right corner of the 

New Brush dialog box shows the current brush tip. 

The box in the lower left corner shows the current 

brush angle and roundness. These boxes change to 

reflect the new brush as you enter brush options. 

Brush angle and roundness

2 Set the brush options. (See “Setting brush 

options” on page 133 for a description of 

these options.)

3 Click OK.

To delete a brush:

Do one of the following:

• Press Command (Macintosh) or Ctrl 

(Windows) (the pointer turns into scissors) and 

click the brush you want to delete.

• Click the brush in the Brushes palette and 

choose Delete Brush from the palette menu.

Creating custom brushes

You can use part of an image to create a custom 

brush shape. If you want to define brushes with 

soft edges, select brush shapes composed of pixels 

with gray values. 

To create a custom brush shape: 

1 Select the part of the image you want to use as a 

custom brush. The brush shape can be up to 1000 

pixels by 1000 pixels in size. To be most effective, 

the shape should appear on a solid white 

background.

2 Choose Define Brush from the Brushes 

palette menu. 

3 Double-click the newly created brush in the 

Brushes palette to open the Brush Options 

dialog box.

4 Specify Spacing as described in the next section.
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5 To make the brush placement more accurate, 

make sure that Anti-aliased is selected. Then 

click OK.

The Anti-aliased option is not available for large 

brushes.

Pear painted with custom
brush shown in inset

Setting brush options

You can define a number of options for the 

default brushes and any brushes you create. 

Only the spacing option can be changed for 

custom brushes.

To set brush options:

1 Do one of the following:

• Double-click the brush you want to edit. 

• Select the brush in the Brushes palette you 

want to edit, and choose Brush Options from the 

palette menu.

2 Set the options as described in the following 

sections. Then click OK. 

Diameter Controls the size of the brush. Enter a 

value in pixels or drag the slider.

Brush strokes with different 
diameter values

Hardness Controls the size of the hard center of 

the brush. Type a number or use the slider to enter 

a value that is a percentage of the brush diameter.

Brush strokes with different 
hardness values

1pt

6pt

0%

100%
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Spacing Controls the distance between the brush 

marks in a stroke. To change the spacing, type a 

number or use the slider to enter a value that is a 

percentage of the brush diameter. To paint strokes 

without defined spacing, deselect this option.

Increasing the spacing 
makes the brush skip.

Angle Specifies the angle by which an elliptical 

brush’s long axis is offset from horizontal. Type a 

value in degrees, or drag the horizontal axis in the 

left preview box to set a new angle.

Angled brushes create a 
chiseled stroke.

Roundness Specifies the ratio between the brush’s 

short and long axes to determine its shape. Enter a 

percentage value or drag the points in the left 

preview box. A value of 100% indicates a circular 

brush, a value of 0% indicates a linear brush, and 

intermediate values indicate elliptical brushes.

Adjusting roundness 
affects shape of brush tip

Saving, loading, and replacing brushes

The Brushes palette can hold as many brushes as 

you want. However, to make the palette more 

manageable and to group related or special 

brushes, you might want to create your own sets of 

brushes. A number of files containing different 

brush sets are included in the Adobe Photoshop 

program folder.

100%

200%

25°

125°

25%

100%
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To save and use custom brush sets:

Choose one of the following commands from the 

Brushes palette menu:

• Reset Brushes to return to the default brushes. 

You can either replace the current brush set or 

append the default brushes to the current set.

• Load Brushes to add the brushes stored in a file 

to the current palette. 

• Replace Brushes to replace the current brush set 

with brushes stored in a file.

• Save Brushes to save a brush set in a file. 

When you exit Adobe Photoshop, the current 

Brushes palette is saved in the Preferences file.

Specifying painting and editing 
options
You specify options for a painting or editing tool 

by using the Options palette for that tool, as 

described in the following sections.

Specifying the opacity, pressure, or 
exposure

The slider in the Options palette lets you specify 

the opacity, pressure, or exposure for various 

painting and editing tools. You can determine the 

opacity used by the gradient fill, pencil, paint-

brush, and rubber stamp tools. You can adjust the 

pressure of action applied by the airbrush, 

smudge, blur, sharpen, and sponge tools. You can 

also adjust the amount of exposure used by the 

dodge and burn tools. 

Opacity can range from 1 to 100%. To use trans-

parent paint, specify a low percentage value. To use 

more opaque paint, specify a high value. 

Pressure and exposure can range from 1 to 100%. 

To create a strong effect, specify a high percentage 

value. To create a weaker effect, specify a low value.

Painting with various
opacity settings

To set the opacity, pressure, or exposure for any 

selected painting or editing tool in multiples of 

10%, press a number from 0 through 9. For example, 

press 5 to choose 50%. Press 0 to choose 100%. To set 

an exact opacity or pressure, quickly type the desired 

value on the keyboard.

Specifying the paint fade-out rate 

You can specify the rate at which the pencil, paint-

brush, airbrush, and eraser strokes fade out to 

simulate actual brush strokes. 

To set a fade-out rate:

1 Select Fade in the tool’s Options palette.

2 Enter a value for the number of steps of the fade.

50%

100%
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The steps determine the rate of the fade from the 

beginning to the end of the stroke. Each step is 

equal to one mark of the brush tip. The value can 

range from 1 to 9999. For example, entering 10 

steps produces a fade in 10 increments. 

3 Choose one of the following options:

• Transparent to fade the stroke from the 

foreground color to transparency.

• Background to fade the stroke from the 

foreground color to the background color. 

Fade-out showing setting of 
40, 60, and 80 steps

Specifying stylus pressure options

Adobe Photoshop supports pressure-sensitive 

digitizing tablets such as the Wacom  and 

Calcomp tablets. If the Control Panel software 

for your tablet is installed, you can specify the 

type of effect that results from varying the stylus 

pressure. These stylus pressure options affect 

the pencil, paintbrush, airbrush, eraser, rubber 

stamp, smudge, blur, sharpen, dodge, burn, and 

sponge tools. 

To set the effect of different stylus pressures:

Display the tool’s Options palette, and select from 

the following options:

• Size if you want increasing pressure to result in a 

bigger brush stroke.

• Opacity/Pressure/Exposure if you want 

increasing pressure to result in more opaque paint 

or a more intense effect.

• Color if you want increasing pressure to add 

more of the foreground color.

Note: The highest pressure of your stylus may not 

reach 100%. This problem is due to the driver 

software and is not caused by the Adobe Photoshop 

program. If you experience this problem, contact 

your tablet vendor for more information. 

Selecting a blending mode

You can control which pixels are affected by a 

painting or editing tool by choosing a blending 

mode in the tool’s Options palette. When using 

blending modes, it’s helpful to think of the effects 

in terms of the following three colors:

• The base color is the original color in the image. 

• The blend color is the color being applied with 

the painting or editing tool.

• The result color is the color resulting from 

the blend. 

Note: To select the next or previous blending mode 

from the Options palette using the keyboard, press 

Shift+[+] or Shift+[-], respectively.

The following sections describe each of the 

painting and editing modes. 



137ADOBE PHOTOSHOP 5.0 LIMITED EDITION
User Guide

Normal Edits or paints each pixel to make it the 

result color. (To set the mode from the keyboard, 

press Shift+Option+N (Macintosh) or 

Shift+Alt+N (Windows).) This is the default 

mode. (Normal mode is called Threshold when 

you’re working with a bitmapped or indexed-color 

image.)

Dissolve Edits or paints each pixel to make it the 

result color; however, the result color is a random 

replacement of the pixels with the base color or the 

blend color, depending on the opacity at any pixel 

location. (Press Shift+Option/Alt+I.) This mode 

works best with the paintbrush or airbrush tool 

and a large brush.

Behind Edits or paints only on the transparent 

part of a layer. (Press Shift+Option/Alt+Q.) This 

mode works only in layers that contain trans-

parency. When you apply paint, it appears that 

you’re painting on the back of the transparent 

areas in a sheet of acetate.

Clear Edits or paints each pixel and makes it trans-

parent. (Press Shift+Option/Alt+R.) This mode is 

available for the line tool (l), the paint bucket tool 

(t), the Fill command, and the Stroke command. 

You must be in a layer to use this mode. 

Multiply Looks at the color information in each 

channel and multiplies the base color by the blend 

color. (Press Shift+Option/Alt+M.) The result 

color is always a darker color. Multiplying any 

color with black produces black. Multiplying any 

color with white leaves the color unchanged. 

When you’re painting with a color other than 

black or white, successive strokes with a painting 

tool produce progressively darker colors. The 

effect is similar to drawing on the image with 

multiple magic markers. 

Screen Looks at each channel’s color information 

and multiplies the inverse of the blend and base 

colors. (Press Shift+Option/Alt+S.) The result 

color is always a lighter color. Screening with black 

leaves the color unchanged. Screening with white 

produces white. The effect is similar to painting 

over an area with bleach. 

Overlay Multiplies or screens the colors, 

depending on the base color. (Press 

Shift+Option/Alt+O.) Patterns or colors overlay 

the existing pixels while preserving the highlights 

and shadows of the base color. The base color is 

not replaced but is mixed with the blend color to 

reflect the lightness or darkness of the original 

color. 
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Soft light Darkens or lightens the colors, 

depending on the blend color. (Press 

Shift+Option/Alt+F.) The effect is similar to 

shining a diffused spotlight on the image. 

If the blend color (light source) is lighter than

50% gray, the image is lightened, as if it were 

dodged. If the blend color is darker than 50% gray, 

the image is darkened, as if it were burned in. 

Painting with pure black or white produces a 

distinctly darker or lighter area but does not result 

in pure black or white. 

Hard light Multiplies or screens the colors, 

depending on the blend color. (Press 

Shift+Option/Alt+H.) The effect is similar to 

shining a harsh spotlight on the image. 

If the blend color (light source) is lighter than 

50% gray, the image is lightened, as if it were 

screened. This is useful for adding highlights to an 

image. If the blend color is darker than 50% gray, 

the image is darkened, as if it were multiplied. This 

is useful for adding shadows to an image. Painting 

with pure black or white results in pure black 

or white.

Darken Looks at the color information in each 

channel and selects the base or blend color—

whichever is darker—as the result color. (Press 

Shift+Option/Alt+K.) Pixels lighter than the 

blend color are replaced, and pixels darker than 

the blend color do not change.

Lighten Looks at the color information in each 

channel and selects the base or blend color—

whichever is lighter—as the result color. (Press 

Shift+Option/Alt+G.) Pixels darker than the 

blend color are replaced, and pixels lighter than 

the blend color do not change.

Difference Looks at the color information in each 

channel and subtracts either the blend color from 

the base color or the base color from the blend 

color, depending on which has the greater 

brightness value. (Press Shift+Option/Alt+E.) 

Exclusion Creates an effect similar to but lower in 

contrast than the Difference mode. Blending with 

white inverts the base color values. Blending with 

black produces no change.

Hue Creates a result color with the luminance and 

saturation of the base color and the hue of the 

blend color. (Press Shift+Option/Alt+U.) 

Saturation Creates a result color with the 

luminance and hue of the base color and the 

saturation of the blend color. (Press 

Shift+Option/Alt+T.) If you paint with this mode 

in an area with a saturation of zero (gray), there is 

no change. 

Color Creates a result color with the luminance of 

the base color and the hue and saturation of the 

blend color. (Press Shift+Option/Alt+C.) This 

preserves the gray levels in the image and is useful 

for coloring monochrome images and for tinting 

color images.
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Luminosity Creates a result color with the hue and 

saturation of the base color and the luminance of 

the blend color. (Press Shift+Option/Alt+Y.) This 

mode creates an inverse effect from that of the 

Color mode.

Using the paint bucket tool
The paint bucket tool ( ) fills adjacent pixels that 

are similar in color value to the pixels you click. 

The paint bucket options let you specify a mode 

and opacity, and indicate the color range, or 

tolerance, of pixels to be filled. You can also choose 

to create smooth edges for the filled selection.

Note: The paint bucket tool cannot be used with 

images in Bitmap or Index color mode. 

If you’re working on a layer and do not want to 

fill transparent areas, make sure that Preserve 

Transparency is selected in the Layers palette. See 

“Preserving a layer’s transparency” on page 164.

To use the paint bucket tool:

Select the paint bucket tool and then click the part 

of the image you want to fill. All adjacent pixels 

within the specified tolerance are filled with the 

foreground color.

To choose options for the paint bucket tool: 

1 Double-click the paint bucket tool to display its 

Options palette.

2 Choose a mode, as explained in “Selecting a 

blending mode” on page 136.

3 Drag the slider to set the opacity, as explained in 

“Specifying the opacity, pressure, or exposure” on 

page 135.

4 Enter the tolerance for the fill.

The tolerance defines how similar in color a 

pixel must be to be filled. Values can range from

0 to 255. A low tolerance fills pixels that have

color values very similar to the pixel you click. 

A high tolerance fills pixels within a broader range 

of colors.

5 To smooth the edges of the filled selection, 

select Anti-aliased. See “Using the Anti-aliased 

option” on page 103 for more information on 

anti-aliasing.

Using the gradient tool
The gradient tool ( ) lets you create a gradual 

transition between two colors. If you don’t select a 

specific part of the image to fill, the gradient tool 

applies the fill to the entire active layer. 
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A gradient fill can be applied as either a radial or a 

linear fill. A linear gradient fill creates a gradient 

from one point to another in a straight line. A 

radial fill creates a gradient fill from a center point 

outward in all directions.

Linear fill Radial fill

Note: The gradient tool cannot be used with bitmap 

or indexed-color images.

To apply a gradient fill: 

1 Select the part of the image you want to fill. If 

you do not make a selection, the gradient fill is 

applied to the entire active layer. 

2 Double-click the gradient tool ( ) in the 

toolbox to display its Options palette.

3 Choose a mode, as explained in “Selecting a 

blending mode” on page 136.

4 Drag the slider to set the opacity, as explained in 

“Specifying the opacity, pressure, or exposure” on 

page 135.

5 If you want to create a smoother blend with less 

banding, select Dither.

6 For Type, choose one of the following options:

• Linear to create a linear fill.

• Radial to create a radial fill.

7 Select a gradient fill from the list.

8 Position the pointer in the image where you 

want to set the starting point of the gradient, and 

drag to define the length and direction of a linear 

fill or to define the radius of a radial fill. To 

constrain the line angle to a multiple of 45º, hold 

down Shift as you drag.

9 Release the mouse button where you want to set 

the ending point of the gradient.

Drag to create linear Result
gradient

If you’re creating a linear fill, the portion of the 

layer or selection before the starting point is filled 

with the starting color; the portion after the 

ending point is filled with the ending color. If 

you’re creating a radial fill, the ending color fills 

the portion after the ending point.
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Filling a selection, layer, or work 
canvas

 

The Fill command lets you fill a selection or a layer 

with a color or a saved portion of an image. You 

can also use keyboard shortcuts to fill a selection 

or layer quickly, and you can use the paint bucket 

tool to fill the work canvas.

 

To fill the work canvas:

 

1

 

Set the foreground color to the color you want 

to use for the canvas. See “Choosing the 

foreground and background colors” on page 127 

for more information. 

 

2

 

Select the paint bucket tool. Then hold down 

Shift and click in the work canvas area.

 

To fill a selection or layer using shortcuts: 

 

1

 

Select the area or layer you want to fill.

 

2

 

Do one of the following:

 

•

 

To fill with the foreground color, press 

Option+Delete (Macintosh) or Alt+Backspace 

(Windows).

 

•

 

To apply a foreground color fill only to the areas 

that contain pixels, press Option+Shift+Delete 

(Macintosh) or Alt+Shift+Backspace (Windows). 

This operation preserves the transparency of 

the layer.

 

•

 

To fill with the background color, press Delete 

(Macintosh) or Backspace (Windows). 

 

•

 

To apply a background color fill only to the areas 

that contain pixels, press Shift+Command+Delete 

(Macintosh) or Shift+Ctrl+Backspace 

(Windows).

 

To fill a selection or a layer: 

 

1

 

Select the area you want to fill. To fill an entire 

layer, select the layer in the Layers palette.
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2 Choose Edit > Fill to fill the selection or layer. 

To display the Fill dialog box, press 

Shift+Delete (Macintosh) or Shift+Backspace 

(Windows). 

3 Choose a mode, as explained in “Selecting a 

blending mode” on page 136.

4 Set the opacity, as explained in “Specifying the 

opacity, pressure, or exposure” on page 135.

5 Click OK to fill the selection.

Stroking a selection
The Stroke command uses the foreground color to 

paint a border around a selection or around the 

edge of a layer. As with the Fill command, you can 

specify the opacity and blending mode of the fill. 

To stroke a selection or layer:

1 Select the area or layer you want to stroke. 

2 Choose Edit > Stroke. 

3 Specify the width and location of the border. 

Values for the width can range from 1 to 16 pixels. 

4 Set the opacity, as explained in “Specifying the 

opacity, pressure, or exposure” on page 135.

5 Choose a mode, as explained in “Selecting a 

blending mode” on page 136.

6 If you’re working in a layer and want to stroke 

only areas containing pixel values, select the 

Preserve Transparency option. See “Preserving a 

layer’s transparency” on page 164.

7 Click OK to stroke the selection or layer.

Selected area Selection stroked: 10 pixels

Using the eyedropper tool
The eyedropper tool ( ) lets you sample color 

from an area of an image to designate a new 

foreground or background color. You can sample 

from the active image or from another image. 

(When you’re using the eyedropper, you can click 

in a background window without making it the 

active window.)

You can also specify the sample area that the 

eyedropper tool reads. For example, you can set 

the eyedropper to sample the color values of a 

3-by-3-screen-pixel area under the pointer. 

To select the foreground or background color using 
the eyedropper:

1 Click the eyedropper tool ( ).

2 Do one of the following:

• To select a new foreground color from an image, 

click the color you want.

•  To select a new background color from an 

image, Option-click (Macintosh) or Alt-click 

(Windows) the color you want.
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If you drag the eyedropper tool, the foreground 

color selection box changes dynamically as you 

drag. Option-drag (Macintosh) or Alt-drag 

(Windows) to activate the background color 

selection box. Release the mouse button to pick 

the new color.

To use the eyedropper tool temporarily while 

using any painting tool, hold down Option 

(Macintosh) or Alt (Windows). 

To change the sample size of the eyedropper:

1 Double-click the eyedropper tool to display the 

Eyedropper Options palette.

2 Choose one of the following options from the 

Sample Size menu: 

• Point Sample to read the precise value of the 

pixel you click.

• 3 by 3 Average or 5 by 5 Average to read the 

average value of the specified number of screen 

pixels within the area you click.

Using the Color palette 
The Color palette displays the color values for the 

current foreground and background colors. Using 

the sliders in the Color palette, you can edit the 

foreground and background colors according to 

several different color models. 

To edit the foreground or background color using 
the Color palette: 

1 Choose Window > Show Color. 

A. Foreground color B. Background color C. Slider
D. Color bar

2 From the Color palette menu, choose the color 

model you want to use for color readout values. 

See “Setting color readout values” on page 144 for 

a discussion of these models.

3 To edit the foreground or background color, 

make sure that its color selection box is active 

(outlined in black). To make the foreground or 

background color selection box active, click 

the box. 

4 To specify a new color, do one of the following:

• Drag the color sliders.

D

B CA
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By default, the slider colors change as you drag. If 

you want to turn off this preview feature to 

improve performance, choose File > Preferences > 

General and deselect Dynamic Color Sliders.

• Enter values next to the color sliders. 

• Click the color selection box, choose a color as 

described in “Using the Adobe Photoshop Color 

Picker” on page 146, and click OK. 

Choosing a color from the color bar

The color bar along the bottom of the Color 

palette lets you quickly choose a background 

or foreground color from a specified spectrum 

of colors. 

To sample colors from the color bar:

1 To edit the foreground or background color, 

make sure that its color selection box is active 

(outlined in black). To make the foreground or 

background color selection box active, click

the box. 

2 Position the pointer over the color bar (the 

pointer turns into the eyedropper), and click to 

sample a color.

To change the display of the color bar:

1 Choose Color Bar from the Color palette menu. 

2 For Style, choose a model and then click OK. 

The Current Colors option displays a transition 

from the current foreground color to the current 

background color. 

To change the display style of the color bar 

quickly, Shift-click in the color bar until you see 

the style you want.

Setting color readout values

The Color palette and the Adobe Photoshop Color 

Picker let you display color values using a number 

of different color models. See “Color modes and 

models” on page 53 for more information on these 

color models.

• Grayscale: Lets you choose a color with a gray 

value from 0% to 100%.

• RGB: Lets you choose a color with red, green, 

and blue values ranging from 0 to 255.

• HSB: Lets you choose a color with a hue from 

0º to 360º and with saturation and brightness 

values from 0 to 100%. The angle for hue is 

defined as an angle relative to pure red on the color 

wheel. See “HSB model” on page 53.

Using the Swatches palette
The Swatches palette contains the current color 

palette. You can choose a foreground or 

background color from the swatches, or you can 

add or delete colors to create a custom palette. You 

can also save a set of swatches and reload them for 

use in another image.

To display the Swatches palette:

Choose Window > Show Swatches.

To choose a color:

Do one of the following:

• To choose a foreground color, click a color in the 

Swatches palette. 
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• To choose a background color, Option-click 

(Macintosh) or Alt-click (Windows) a color in the 

Swatches palette.

Adding or deleting a color

You can add, delete, and insert colors in the 

Swatches palette to create a customized palette. 

Swatches can be added to the blank areas in 

the palette. 

To add a color to the Swatches palette: 

1 Use the eyedropper tool, the Color palette, 

or the Color Picker to select the color you want 

to add. 

2 Position the pointer over an empty space in the 

bottom row of the Swatches palette (the pointer 

turns into the paint bucket tool), and click to add 

the color.

To replace or insert a color in the Swatches palette:

1 Use the eyedropper tool ( ), the Color palette, 

or the Color Picker to select the color you want 

to add. 

2 Do one of the following:

• To replace an existing swatch, hold down Shift, 

position the pointer over a swatch (the pointer 

turns into a paint bucket), and click the swatch. 

• To insert a new swatch, press Shift+Option 

(Macintosh) or Shift+Alt (Windows) and click 

a swatch.

To delete a color from the Swatches palette:

Hold down Command (Macintosh) or Ctrl 

(Windows), position the pointer over a swatch 

(the pointer turns into scissors), and click.

To return to the default Swatches palette:

1 Choose Reset Swatches from the Swatches 

palette menu.

2 Do one of the following:

• Click OK to replace the current swatches with 

the default set.

• Click Append to attach the default swatches to 

the end of the current set.

s
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Saving, loading, and replacing swatches 

The Swatches palette can hold as many colors as 

you want. However, to make the palette more 

manageable and to group related or special colors, 

you might want to create your own Swatches 

palettes. A number of files containing different 

swatch sets are included in the Adobe Photoshop 

program folder.

To save and use custom swatch sets:

Choose one of the following commands from 

the Swatches palette menu:

• Reset Swatches to use the default set of swatches. 

You can either replace the current swatch set or 

append the default swatches to the current set.

• Load Swatches to append the swatches stored in 

a file to the current set of swatches.

• Replace Swatches to replace the current swatch 

set with the swatches stored in a file.

• Save Swatches to save the current swatches in 

a file. 

When you exit the program, the current Swatches 

palette is saved in the Adobe Photoshop prefer-

ences file.

Using the Adobe Photoshop 
Color Picker 
The Adobe Photoshop Color Picker lets you select 

the foreground or background color from a color 

spectrum or to define color components for a 

color numerically. In addition, you can select 

colors based on the HSB or RGB color models.

By default, the Photoshop program uses the Adobe 

Photoshop Color Picker. You can also use plug-in 

and system color pickers to select foreground and 

background colors. For more information, see 

“Using the Apple Color Picker” on page 148, 

“Using the Windows Color Picker” on page 148, 

and “Using plug-in color pickers” on page 149.

To display the Adobe Photoshop Color Picker:

Do one of the following:

• Click the foreground or background color 

selection box in the toolbox.

• Click the active color selection box in the Color 

palette. 

To return to the Adobe Photoshop Color Picker after 
using another color picker:

1 Choose File > Preferences > General.
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2 For Color Picker, choose Photoshop.

Specifying a color using the color field 
and color slider

With the HSB and RGB color models, you can use 

the color field and the color slider in the Color 

Picker dialog box to select a color. The color slider 

displays the range of color levels available for the 

selected color component (for example, R, G, or 

B). The color field displays the range for the 

remaining two components—one on the 

horizontal axis and one on the vertical axis.

For example, if the current color is black and you 

click the red component (R) using the RGB color 

model, the color slider displays the range of color 

for red (0 is at the bottom of the slider and 255 is 

at the top). The color field displays the values for 

blue along its horizontal axis and the values for 

green along its vertical axis. 

To choose a color:

Do one of the following:

• Drag the white triangles along the slider.

• Click inside the color slider.

• Click inside the color field. 

When you click in the color field, a circular marker 

indicates the color’s position in the field. 

As you adjust the color using the color field and 

color slider, the numerical values change to reflect 

the new color. The color rectangle to the right of 

the color slider displays the new color in the top 

section of the rectangle. The original color appears 

in the bottom of the rectangle.

Specifying a color using numeric values

In the Adobe Photoshop Color Picker, you can 

select a color in either color model by specifying 

numeric values for each color component. 

To specify colors using numeric values:

Do one of the following:

• In the RGB color model (this is the model your 

monitor uses), specify component values from 0 to 

255 (0 is black, and 255 is the pure color). 

• In the HSB color model, specify saturation and 

brightness as percentages; and specify hue as an 

angle, from 0˚ to 360˚, that corresponds to a 

location on the color wheel. (See “Color modes 

and models” on page 53 for information on the 

color wheel.)
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Using the Apple Color Picker
On the Macintosh, you can use the Apple Color 

Picker (also known as the color wheel) to change 

the foreground or background color. The Apple 

Color Picker lets you select colors based on the 

HSB or the RGB color model. 

This section briefly describes how to use the Apple 

Color Picker. For more information, see your 

Macintosh documentation.

To use the Apple Color Picker: 

1 Choose File > Preferences > General.

2 For Color Picker, choose Apple and click OK.

3 Click the foreground or background color 

selection box in the toolbox. 

4 Enter values for Hue, Saturation, and Lightness, 

or click the color you want in the color wheel. 

To select colors based on the RGB model, click 

Apple RGB at the left of the dialog box and enter 

values for Red, Blue, and Green. 

Using the Windows Color Picker
In Windows, you can use the Windows Color 

Picker to change the foreground or background 

color. The Windows Color Picker lets you select 

colors from an array of basic colors or define up to 

16 custom colors based on the HSB or the RGB 

color model.

This section briefly describes how to use the 

Windows Color Picker. For more information, see 

your Windows documentation.

To use the Windows Color Picker: 

1 Choose File > Preferences > General. 

2 For Color Picker, choose Windows and 

click OK.

3 Click the foreground or background color 

selection box in the toolbox. 

4 To choose a color from the Basic Colors palette, 

click the color you want.

5 To specify a custom color, click Define Custom 

Colors to bring up the Custom Color Selector. 

This dialog box functions similarly to the Adobe 

Photoshop Color Picker. Specify a color by using 

the color field and color slider or by entering 

numerical values for each color component. 
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The new color is displayed on the left side of the 

Color/Solid box. The right side of this box displays 

the solid color closest to the color you have 

specified. (You can choose the displayed solid 

color by double-clicking the right side of the box.)

6 When you are satisfied with the color, click 

Add to Custom Colors to add it to the Custom 

Colors palette.

7 To choose a custom color from the Windows 

Color Picker, click the color you want.

8 Click OK.

Using plug-in color pickers
In addition to the default Adobe Photoshop Color 

Picker and the Apple or Windows Color Picker, 

you can install and use plug-in color pickers. Any 

plug-in color pickers you install appear under 

Color Picker when you choose File > Preferences > 

General. For information on installing and using a 

plug-in color picker, see the documentation that 

came with the plug-in.
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Chapter 8: Using Layers

hen you create a new Adobe Photoshop 

Limited Edition document, the image 

consists of a background, which is 

analogous to the canvas under a painting. You can 

add one or more layers to the document. 

Layers let you edit specific areas of your image 

without affecting any other data. You can draw, 

edit, paste, use masks, and reposition elements 

on a layer without disturbing any other layers in 

the image. 

W

Transparent 
areas on a layer 
(represented 
here in blue) 
allow you to see 
through to the 
layers below

Zebra is on
topmost layer

UNDERSTANDING LAYERS Think of layers as sheets of acetate stacked one on top of the other. Where there is 
no image on a layer, you can see through to the layers below. Behind all the layers is the background. In the 
illustration below, each animal and the map are on separate layers. The red texture is the background. All layers 
in a file share the same number of pixels and the same image mode (RGB or Grayscale).
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With layers, you can experiment freely with 

different combinations of graphics, type, special 

effects, and opacities. Until you merge (that is, 

combine) the layers, each one remains 

independent of the other layers in the image.

Note: Images created using the Transparent option 

in the New dialog box are created without a 

background. Images with no background, as well as 

images with layers, can be saved only in the 

Photoshop format.

Layers are not available for 16-bit mode images.

Images created in versions of Adobe Photoshop 

earlier than 3.0 consist only of a single background 

layer. If you add layers to such images using this 

version of Photohsop LE, you can save them only 

in the Photoshop format. 

Using the Layers palette
The Layers palette lists all the layers in the image, 

starting with the topmost layer. A thumbnail of the 

layer contents appears to the left of the layer name. 

This thumbnail is updated as you edit the layer. 

Use the scroll bars or resize the palette to see 

additional layers.

You use the Layers palette to create, hide, display, 

copy, merge, and delete layers. (Additional 

commands appear in the menu.) When you 

modify an image, the changes affect only the active 

layer, that is, the highlighted layer in the Layers 

palette. You select a layer to make it active, and 

only one layer can be active at a time. The name of 

the active layer also appears in the image window’s 

title bar. 

A. Show/Hide B. Selected layer icon
C. Link/Unlink D. New Layer E. Trash Layer
F. Selected Layer is active layer

F

ED

B

A

C
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To select a layer:

Do one of the following:

• In the Layers palette, click a layer to make 

it active.

• Select the move tool and Control-click 

(Macintosh) or right-click (Windows) in the 

image and choose the layer you want from the 

context menu. The context menu lists all the 

layers that have pixels under the current pointer 

location.

Creating a layered image
Adobe Photoshop lets you create up to 99 layers in 

an image, each with its own blending mode and 

opacity. However, the amount of memory in your 

system may put a lower limit on the number of 

layers you can have in a single image. 

You can create new layers by using the New Layer 

button or command, by dragging or pasting selec-

tions into your image, or by converting selections 

into layers. You can also copy layers between two 

open Adobe Photoshop images (see “Duplicating 

layers in a single image” on page 160). 

Adding new layers

You add layers to an image using the New Layer 

button at the bottom of the Layers palette or 

the New Layer command, which appears in the 

Layer > New menu or in the Layers palette menu. 

New layers appear above the active layer in the 

Layers palette.

To create a new layer using default options:

Click the New Layer button ( ) at the bottom of 

the Layers palette. The layer uses Normal mode 

with 100% opacity and is named according to the 

order in which it was created.

Click New layer button. . . to create a layer.

To add a new layer and specify options:

1 Do one of the following:

• Choose Layer > New > Layer.

• Choose New Layer from the Layers palette 

menu.

• Option-click (Macintosh) or Alt-click 

(Windows) the New Layer button at the bottom of 

the Layers palette.

2 Name the layer, and select mode, opacity, and 

fill options as described in “Specifying layer 

options” on page 165. Then click OK.



CHAPTER 8156
Using Layers

Adding selections as layers

When you drag or paste a selection into a 

document, the selection is automatically pasted 

into a new layer. The new layer is created using the 

default options of Normal mode and 100% 

opacity and appears above the active layer in the 

Layers palette. You can also convert a selection to 

a layer.

To turn a selection into a new layer: 

1 Make a selection. 

2 Choose Layer > New and choose one of the 

following commands from the submenu:

• To copy the selection from the existing layer onto 

a new layer, choose Layer Via Copy.

Original Selection copied to new layer

• To cut the selection from the existing layer and 

paste it into a new layer, choose Layer > New > 

Layer Via Cut. 

Original Selection cut to new layer

Viewing layers
You use the Layers palette to show, hide, and 

preview layers. You can also control how trans-

parent areas in a layer appear in your image. 

Map layer and background hidden 
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Showing and hiding layers

You can make layers temporarily invisible to speed 

performance as you edit or print other parts of the 

image. Only visible layers are printed. When a 

layer is visible, an eye icon appears in the leftmost 

column of the Layers palette for that layer. 

To show or hide a layer:

Do one of the following:

• In the Layers palette, click the eye icon next to a 

layer to hide that layer. Click in the column again 

to redisplay the layer. 

• Drag through the eye column to show or hide 

multiple layers.

• Option-click (Macintosh) or Alt-click 

(Windows) the eye icon for a layer to display just 

that layer. Option/Alt-click in the eye column 

again to redisplay all the layers. 

Note: You can use this procedure to hide the active 

layer; if you do, however, you won’t be able to edit it.

Hiding and resizing layer thumbnails

You can change the size or turn off the display of 

thumbnails in the Layers palette. Thumbnails are 

the most convenient way of monitoring layer 

contents, but turning off thumbnails can improve 

performance and save disk space. Using smaller 

thumbnails reduces the space required by the 

Layers palette and can be helpful when you’re 

working on a smaller monitor. 

A. Thumbnail

To change the display of layer thumbnails:

1 Choose Palette Options from the Layers

palette menu.

2 Click a size or click None to turn off the thumb-

nails, and then click OK.

A
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Setting transparency preferences

A layer is transparent until you add pixels to it. By 

default, the transparent areas of a document 

appear as a checkerboard pattern. You can change 

the appearance of this pattern. 

To change the transparency settings:

1 Choose File > Preferences > Transparency. 

2 For Grid Size, select a new size for the pattern. If 

you choose None, transparent areas in the layer 

appear white. 

3 For Grid Colors, select one of the following 

options:

• Light, Medium, or Dark to specify a gray 

pattern. 

• Any other color from the list to display the 

checkerboard in that color.

• Custom to choose a color that does not appear in 

the list. 

4 If you chose Custom, click either of the color 

selection boxes (with the current pattern colors) to 

choose a custom color from the Color Picker. 

5 Click OK.

Moving and copying layers
You can move, copy, and change the stacking order 

of layers. 

Changing the order of layers

You can use the Layer menu or the Layers palette 

to change the stacking order of layers in an image.

To change the order of a single layer:

1 In the Layers palette, select the layer that you 

want to move.

2 Choose Layer > Arrange, and choose one of the 

following options from the submenu:

• Bring to Front to make the layer the topmost 

layer.

• Bring Forward to move the layer one level up in 

the stacking order.

• Send Backward to move the layer one level down 

in the stacking order.

• Send to Back to make the layer the bottommost 

layer in the image (except for the background).

 To move a selected layer one level up in the 

Layers palette, press Command+] (Macintosh) 

or Ctrl+] (Windows). To move one level down, press 

Command+[ or Ctrl+[. To move to the topmost 

level, press Command+Shift+] or Ctrl+Shift+]. To 

move to the bottommost level (above the 

background), press Command+Shift+[ or 

Ctrl+Shift+[.
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To change the order of layers by dragging:

1 In the Layers palette, select the layer that you 

want to move.

2 Drag the layer up or down in the Layers palette. 

When the highlighted line appears in the position 

where you want to position the layer, release the 

mouse button. 

Original image Map layer dragged below
elephant layer

Note: By default, the background cannot be moved 

and is always at the bottom of the layer list. To move 

the background to a different location, first convert 

the background into a layer by double-clicking the 

background name, typing a new name, and 

clicking OK. 

Moving layers

You can move the contents of a layer within its 

image window. You can also link multiple layers 

and move their contents together. 

To move a layer in an image:

1 In the Layers palette, select the layer that you 

want to move to make it the active layer.

2 Select the move tool. To activate the move tool 

when any other tool is selected, hold down 

Command (Macintosh) or Ctrl (Windows).

3 Drag anywhere in the image to move the 

selected layer into the desired position. To 

constrain the direction of movement to a multiple 

of 45°, hold down Shift as you drag.

To move the layer contents in 1-pixel incre-

ments when the move tool is selected, press the 

arrow keys on the keyboard. To move the layer in 10-

pixel increments (or to move one frame if you’re 

editing an Adobe Photoshop filmstrip file), press 

Shift and an arrow key.
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To move multiple layers:

1 In the Layers palette, select one of the layers you 

want to move.

2 Click in the column immediately to the left of 

any additional layers you want to move. The link 

icon appears in the column. 

A. Link icon

3 Use the move tool to move the linked layers in 

the image window.

Original image Gazelle and zebra layers
linked and moved

4 To unlink a layer, click the link icon next to the 

layer’s name.

Duplicating layers in a single image

You can duplicate any layer (including the 

background) in the same image using the 

Duplicate Layer command (which prompts you 

for the new layer name) or by dragging and 

dropping the layer onto the New Layer button 

(without any prompt).

To duplicate a layer in an image without naming it:

Drag the layer name in the Layers palette to the 

New Layer button ( ) at the bottom of the palette.

The new layer is named according to the order in 

which it was created.

Copying layers between images

You can copy any layer or the background from 

one Adobe Photoshop image to another using 

copy and paste, drag and drop, or the Duplicate 

Layer command. The Duplicate Layer command 

also lets you create a new image with the copied 

layer.

A
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To copy a layer between images:

1 Open the two images you want to use.

2 In the Layers palette of the source image, select 

the name of the layer that you want to copy.

3 Choose Select > All to select all of the pixels on 

the layer that fall inside the canvas boundaries. 

Pixels beyond the visible canvas are not included 

in the selection.

4 Choose Edit > Copy.

5 Make active the image window into which you 

want to paste the layer.

6 Choose Edit > Paste to paste the layer as a new 

layer in the destination image. 

To copy a layer between images by dragging:

1 Open the two images you want to use. 

2 In the Layers palette of the source image, select 

the name of the layer that you want to copy. 

3 Do one of the following:

• Drag the layer’s name from the Layers palette 

into the destination image. 

• Select the move tool and drag the layer from the 

source image to the destination image. 

Drag selected layer from one image to the other

Resulting image and palette
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A new layer appears in the Layers palette of the 

image into which you copied the layer. 

If the layer you’re dragging is larger than the image 

into which you’re copying, only part of the layer is 

visible, although all the layer contents are still 

available. To see other sections of the layer, use the 

move tool to drag the layer into position. 

Hold down Shift as you drag a layer to copy it 

in the same position it occupied in the source 

image (if the source and destination images have the 

same pixel dimensions) or to the center of the desti-

nation image (if the source and destination images 

have different pixel dimensions).

To copy multiple layers into another image:

1 Make sure that both the source and destination 

images are open, and select one of the layers you 

want to copy.

2 In the Layers palette, click in the column 

immediately to the left of any additional layers 

you want to move. The link icon appears in 

the column. 

3 Use the move tool to drag the linked layers from 

the source image to the destination image.

To copy a layer into another image or a new image:

1 If you plan to copy a layer to an existing image, 

open both the source and destination images.

2 In the source document’s Layers palette, select 

the name of the layer you want to duplicate.

3 Do one of the following:

• Choose Layer > Duplicate Layer.

• Choose Duplicate Layer from the Layers palette 

menu. 

4 Type a name for the duplicate layer.

5 For Document, choose a destination for the 

layer. To create a new document for the layer, 

choose New and type a name for the new 

document. 

6 Click OK.

A new image created with a duplicate layer doesn’t 

have a background. 
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Converting and adding 
backgrounds
At times you may want to convert a background to 

a layer—for example, to change its position in the 

Layers palette or to apply a mode or opacity to it. 

You can also add a background to an image 

without a background. An image can contain only 

one background.

To convert a background into a layer:

1 Double-click Background in the Layers palette. 

2 Enter a name, opacity, and mode for the layer. 

See the section, “Specifying layer options” on 

page 165 for information on layer options. 

3 Click OK.

To add a background to an image:

Choose Layer > New > Background.

Editing layers
You can use the painting and editing tools to draw 

on a layer, and you can copy and paste selections to 

a layer. 

All editing occurs on the active layer. To keep track 

of your editing, you should keep the Layers palette 

open and refer to it as you edit.

Adding pixels to a layer

When you add a layer to an image, the new layer 

has no pixels. Pasting, painting, and editing in a 

layer fills the selected areas with pixels. Once an 

area on a layer contains pixels, you can paint or 

edit the pixels, apply filters, or use special effects to 

modify the layer. 

Using blending modes and opacity on 
a layer

When you use the painting and editing tools to 

draw on a layer, keep in mind that the opacity and 

mode settings for these tools interact with the 

opacity and mode settings for the active layer, and 

that the actions affect the active channel.

For example, suppose you have a layer that uses the 

Dissolve mode and an opacity of 50%. You paint 

on this layer using the paintbrush with a Normal 

mode and an opacity of 100%. As it is displayed on 

the layer, the paint appears in Dissolve mode with 

a 50% opacity because this is the maximum the 

layer can display.

On the other hand, if you were working on a layer 

created using Normal mode and 100% opacity, but 

were using the eraser tool with the paintbrush 

option set to 50% opacity, only 50% of the paint 

would disappear as you painted. For more infor-

mation, see “Selecting a blending mode” on 

page 136 and the examples in “Layer blending 

modes” on page 167.
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Preserving a layer’s transparency

You can confine editing only to areas of a layer that 

already contain pixels. For example, if you have 

added type to a transparent layer, you may want to 

edit the type (for example, by adding special 

effects or changing its color) without adding pixels 

to the transparent areas of the layer.

To confine editing to the opaque portions of a layer:

1 Select the layer in the Layers palette.

2 Select Preserve Transparency in the Layers 

palette.

The pencil, paintbrush, airbrush, rubber stamp, 

paint bucket, and gradient tools affect only the 

opaque areas of a layer that contain pixels.

Note: When you use the type tool to create a new 

layer, Preserve Transparency is selected by default.

Painting on a layer with Painting on a layer with
Preserve Transparency off Preserve Transparency on
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Deleting layers
Because layers increase a file’s size, it’s important 

to delete layers that you no longer need. 

To delete a layer:

1 Select the layer in the Layers palette.

2 Do one of the following:

• Click the Trash button at the bottom of the 

Layers palette and click Yes.

• Choose Layer > Delete Layer.

• Choose Delete Layer from the Layers palette 

menu. 

To delete a selected layer automatically without 

a confirmation dialog box. Option-click 

(Macintosh) or Alt-click (Windows) the Trash 

button at the bottom of the Layers palette. You can 

also drag the layer name in the Layers palette to the 

Trash button.

Specifying layer options
The layer options let you change a layer’s name 

and opacity.

Renaming a layer

You can rename a layer at any time.

To rename a layer:

1 Do one of the following:

• Double-click the layer’s name in the Layers 

palette. 

• Select the layer in the Layers palette and choose 

Layer > Rename Layer.

• Select the layer in the Layers palette and choose 

Rename Layer from the palette menu.

2 Enter a new name for the layer, and click OK. 
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Specifying opacity

You can use the Opacity option in the New Layer 

dialog box or the Opacity slider in the Layers 

palette to specify the opacity of a layer. A layer with 

0% opacity is completely transparent, while a layer 

with 100% opacity is completely opaque. Each 

layer can be created with its own opacity.

Elephant layer with 60% opacity

If you have selected a tool that does not have a 

slider option in its Options palette, you can 

change the opacity of the active layer in multiples 

of 10% by pressing a number key from 0 to 9 

(for example, pressing 1 sets the opacity to 10%). 

Pressing 0 sets the opacity to 100%. To specify 

an exact opacity, type the two-digit number quickly 

or enter the desired value using the keyboard.

Specifying blending modes

You use blending modes to determine how the 

pixels in a layer are blended with underlying pixels 

on other layers. By applying modes to individual 

layers, you can create a variety of special effects. 

For example, if you create a layer using Darken 

mode, the pixels in the layer that are darker than 

the underlying pixels are blended into the image.  

The Layers palette modes include the modes that 

appear in the Options palette when you paint or 

edit an image. For a description of these modes, 

see “Selecting a blending mode” on page 136.

 
Elephant layer in Hard Light mode
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LAYER BLENDING MODES  The layer blending modes let you control how the pixels in the layer are blended with 
the pixels in underlying layers. For a description of each mode, see “Selecting a blending mode” on page 136.

Screen

Darken

Luminosity Luminosity 50%ColorHue

Screen 50%Dissolve

Saturation

Lighten

Hard Light

Color Dodge

Multiply

Overlay 50%Overlay

Difference

ExclusionSoft Light

Color Burn

Background

Layer 1

Original images
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Filling a new layer with a neutral color

Some Adobe Photoshop effects (such as the 

Lighting Effects filter) cannot be applied to layers 

that do not contain pixels. Selecting Fill with 

Neutral Color in the New Layer dialog box lets you 

apply these effects to empty layers by first filling 

the layer with a preset, neutral color. If no effect is 

applied, filling with a neutral color has no effect on 

the remaining layers. The Fill with Neutral Color 

option is unavailable when you create a layer using 

the Normal, Dissolve, Hue, Saturation, Color, or 

Luminosity modes.

You fill a layer with a neutral color when you create 

a new layer. For more information, see “Adding 

new layers” on page 155.

Note: Not all filters produce a visible effect when 

applied to a layer filled with a neutral color.

Creating clipping groups
Clipping groups let you define a layer as a mask for 

one or more layers above that layer. For example, if 

you have a shape on one layer, a texture on the 

overlying layer, and some text on the topmost 

layer, you can define all three layers as a clipping 

group so that the texture and the text appear only 

through the shape. In a layer group, the bottom 

layer in the group (called the base layer) affects the 

mode and opacity of all other layers in the group; 

this blending applies only to the layers within the 

group. Note that only successive layers can be 

included in a clipping group. 

In the Layers palette, dotted lines separate the 

layers in a clipping group. The base layer in a 

clipping group is indicated by its underlined 

name, and the thumbnails for the overlying layers 

are indented. 

Original Clipping group with map
and Africa layers

To create a clipping group:

1 In the Layers palette, select one of the layers that 

you want.

2 Click in the column immediately to the left of 

the layers you want to add to the clipping group. 

Link icons appear in the column.
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3 Choose Layer > Group Linked to create a 

clipping group from the linked layers.

Layers linked and made into clipping group

To add a layer to a clipping group:

1 Do one of the following:

• Hold down Option (Macintosh) or Alt 

(Windows), position the pointer over the solid line 

dividing two layers in the Layers palette (the 

pointer changes to two overlapping circles), and 

click.

• Select a layer in the Layers palette and choose 

Layer >  Group with Previous.

The layer is grouped with the layer below it and is 

assigned the opacity and mode attributes of the 

bottommost layer in the group.

2 Repeat step 1 for each layer that you want to add 

to the clipping group.

To remove a layer from a clipping group:

Do one of the following:

• Hold down Option (Macintosh) or Alt 

(Windows), position the pointer over the dotted 

line separating two grouped layers in the Layers 

palette (the pointer changes to two overlapping 

circles), and click.

• In the Layers palette, select the topmost layer in 

the clipping group and choose Layer > Ungroup.

To ungroup all layers in a clipping group:

1 In the Layers palette, select any layer in the 

clipping group.

2 Choose Layer > Ungroup.

Using layer masks
A layer mask lets you control how different areas 

of a layer are hidden and revealed. By making 

changes to the layer mask, you can apply a variety 

of special effects to the layer without actually 

affecting the pixels on that layer. You can then 

apply the mask and make the changes permanent, 

or remove the mask without applying the changes. 

You can save all layer masks with a layered 

document.
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In the Layers palette, a layer mask appears as an 

additional thumbnail to the right of the layer 

thumbnail. Black indicates the portions of the 

layer that are hidden and white indicates the 

portions of the layer that are revealed. Gray 

indicates portions of the layer that are partially 

visible.

Adding a layer mask

You can add one layer mask per layer. By painting 

the mask, you can control which areas of the layer 

are hidden or revealed. 

To add a mask to a layer:

1 In the Layers palette, select the layer to which 

you want to add a mask.

2 If you want to base the boundaries of the mask 

on a selection, select the desired area in the image.

3 Do one of the following:

• To create a mask that reveals the entire layer, 

choose Layer > Add Layer Mask > Reveal All.

• To create a mask that hides the entire layer, 

choose Layer > Add Layer Mask > Hide All. 

• To create a mask that reveals the selected area 

and hides the remaining portion of the layer, 

choose Layer > Add Layer Mask > Reveal 

Selection.

• To create a mask that hides the selected area and 

reveals the remaining portion of the layer, choose 

Layer > Add Layer Mask > Hide Selection.

Animal shapes mask areas of the map layer

Map, gazelle and elephant layers with masks blended 

from black to white
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• To create a layer mask that reveals the entire 

selection or layer, click the New Layer Mask ( ) 

button at the bottom of the Layers palette.

Selection Layer mask revealing selection

• To create a mask that hides the entire selection or 

layer, Option-click (Macintosh) or Alt-click 

(Windows) the New Layer Mask button.

A layer mask thumbnail appears to the right of the 

layer thumbnail in the Layers palette. The layer 

mask is selected, as indicated by the mask icon that 

appears to the left of the layer thumbnail. The layer 

mask thumbnail represents the temporary mask.

A. Layer mask selected B. Layer mask C. New layer mask

To edit a layer mask:

1 Click the layer mask thumbnail in the Layers 

palette to make it active (the mask icon appears to 

the left of the layer thumbnail).

2 Select any of the editing or painting tools.

Because the layer mask is an 8-bit grayscale 

channel, the foreground and background colors 

default to grayscale values when the mask is active. 

As you edit, the mask thumbnail displays the 

changes. 

A CB
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3 Do one of the following:

• To hide the layer and add to the mask, paint the 

mask with black.

• To reveal the layer and subtract from the mask, 

paint the mask with white.

• To make the layer partially visible, paint the 

mask with gray.

To edit the layer instead of the layer mask, make 

the layer active by clicking its thumbnail in the 

Layers palette. The paintbrush icon appears to the 

left of the thumbnail to indicate that you are 

editing the layer. Inverting the contents of the layer 

mask reverses the masking effect.

Unlinking layers and layer masks

By default, a layer is linked to its layer mask—that 

is, both the layer and layer mask move together in 

the image when you move either one with the 

move tool. In the Layers palette, a link icon 

appears between the layer and layer mask thumb-

nails to indicate this linking behavior. 

You can unlink the layer from its layer mask by 

clicking the link icon. Unlinking a layer from its 

layer mask lets you move the layer and the layer 

mask independently. You can click between the 

layer and layer mask thumbnails to redisplay the 

link icon and return to the linking behavior.

Linked Unlinked

Turning off the layer mask

As you edit a layer mask, all editing changes appear 

on the layer. If you want to view the layer without 

the mask, you can temporarily turn off the mask in 

the document window. 
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To turn off the layer mask temporarily:

1 Do one of the following:

• Press Shift and click the layer mask thumbnail in 

the Layers palette. 

• Choose Layer > Disable Layer Mask.

A red X appears over the layer mask thumbnail in 

the Layers palette, and the entire underlying layer 

is visible. 

Layer mask on... and off 

2 To turn on the mask, do one of the following:

• Click the layer mask thumbnail in the Layers 

palette.

• Choose Layer > Enable Layer Mask.

Viewing the layer mask

By default, the layer mask is not visible as you edit 

the layer mask. However, you can view and edit the 

mask without viewing the layer contents.

To view the layer mask channel:

Do one of the following:

• Option-click (Macintosh) or Alt-click 

(Windows) the layer mask thumbnail to view only 

the mask. The eye icons in the Layers palette are 

dimmed because you are not seeing any of the 

layers. Click an eye icon to redisplay the layers.

• Hold down Option+Shift (Macintosh) or 

Alt+Shift (Windows) and click the layer mask 

thumbnail to view the mask on top of the layer in 

the red masking color. Hold down 

Option+Shift/Alt+Shift and click the layer mask 

thumbnail again to turn off the color display.

Applying and removing a layer mask

When you have finished creating a layer mask, you 

can either apply the mask and make the changes 

permanent or remove the mask without applying 

changes. Applying and removing layer masks may 

help reduce file size. 

To remove a layer mask:

1 Click the layer mask thumbnail in the Layers 

palette.

2 Do one of the following:

• Click the Trash button at the bottom of the 

Layers palette.

• Choose Layer > Remove Layer Mask.

3 Do one of the following:

• To remove the layer mask and make the changes 

permanent, click Apply.

• To remove the layer mask without applying the 

changes, click Discard.
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Managing layered documents
Adding layers to an image increases the file size. 

(Transparent areas in a layer, however, do not add 

to the file size.) To conserve disk space, you can 

merge two or more layers together, or flatten all the 

layers in an image into one layer. 

Keeping track of file sizes

Adobe Photoshop lets you monitor file size as you 

add, delete, and edit layers.

To track file size:

Check the values in the Document Sizes box at the 

lower left corner of the image window 

(Macintosh) or the screen (Windows).

A. Flattened file size B. Unflattened file size

The first (left) value indicates the size the file will 

have when it is flattened. The second (right) value 

shows the estimated file size of the unflattened file, 

including any layers.

To track the use of the Adobe Photoshop scratch 

disk (temporary disk space used for storing data 

when RAM is insufficient), position the pointer over 

the triangle at the bottom of the image window, hold 

down the mouse button, and choose Scratch Sizes. 

See “Using RAM, scratch disks, and system virtual 

memory” on page 225 for more information.

Merging layers

Merging layers combines several layers into one 

and keeps the file size manageable, especially when 

you’re working in large files. When you’ve finalized 

the characteristics and positioning of the layer 

contents, you can merge a layer with one or more 

other layers to create partial versions of your 

composite image. You can also merge linked layers 

into one layer.

If you merge layers into an image with a trans-

parent background, the intersection of all trans-

parent areas remains transparent. 

BA
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To merge a layer with the layer below it:

1 Make sure that the two layers you want to merge 

are visible. Select the top layer in the Layers palette.

2 Do one of the following:

• Choose Layer > Merge Down.

• Choose Merge Down from the Layers palette 

menu.

To merge all visible linked layers:

1 Make visible all the linked layers you want to 

merge. 

2 Select one of the visible linked layers.

3 Choose Layer > Merge Linked.

To merge all the visible layers in an image:

1 Hide any layers you do not want to merge. 

2 Do one of the following:

• Choose Layer > Merge Visible.

• Choose Merge Visible from the Layers palette 

menu.

Flattening all layers

A flattened image contains only a background 

with no layers, and thus has a greatly reduced file 

size. You can save a flattened version of the file 

when you have finished creating the composite 

image. In most cases, you won’t want to flatten a 

file until you are absolutely sure that you no longer 

want to change individual layers. 

Note: Converting an image between some modes 

flattens the file. Be sure to save a copy of your file that 

includes all layers if you want to edit the image after 

the conversion.

To flatten an image:

1 Make sure that all the layers you want to keep 

are visible.

In a flattened image, all the visible layers are 

merged into the background. Hidden layers are 

discarded, and the final image contains only a 

background. If the background is transparent, the 

transparent areas are filled with white.
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2 Do one of the following:

• Choose Flatten Image from the Layers palette 

menu.

• Choose Layer > Flatten Image.

Flattening an image

Result

Saving layered documents

If you plan to send files out for proofs, you may 

want to save two versions of the file—one version 

with all the layers and layer masks intact so that 

you can easily incorporate editing changes, and 

another version with flattened layers to send to the 

printer. 

The Save a Copy command in the File menu lets 

you save a flattened version of your file while 

keeping the original source file intact. The Save a 

Copy command saves in any of the file formats 

supported by Adobe Photoshop. Unlike Save As, 

the Save a Copy command allows you to keep 

working in the original file. The copy is saved to 

your disk but does not replace the active window. 

For more information on saving documents and 

for a complete description of the file formats, see 

“Saving files” on page 203.
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Chapter 9: Using Filters

he filters that are built into Adobe 

Photoshop Limited Edition let you apply 

special effects to your images. For example, 

you can apply an impressionistic or mosaic effect, 

add or reduce noise (pixels with randomly 

distributed color values), distort images, and 

produce many other interesting visual effects.

About plug-in filters
Adobe Photoshop also supports plug-in filters 

developed by non-Adobe software developers. For 

information on installing these plug-in modules, 

see “Using plug-in modules” on page 18. Once 

installed, plug-in filters appear in the Filter menu 

and work the same as built-in filters. If you are 

interested in creating Adobe Photoshop-

compatible plug-in modules, please contact Adobe 

Systems Developer Support.

Previewing and applying filters
To use a filter, choose the appropriate submenu 

command from the Filter menu. The last filter 

chosen appears at the top of the menu.

Note: Filters cannot be applied to Bitmap-mode, 

indexed-color, 48-bit RGB, or 16-bit grayscale 

images.

Some Photoshop filters let you preview a filter 

effect on the active layer before applying the filter. 

Because applying a filter—especially to large 

images—can be time-consuming, use the Preview 

option to save time and prevent unintended 

results. Several filter dialog boxes also have a built-

in preview box that shows the filter’s effect on the 

active layer. 

To preview and apply a filter:

1 To apply a filter to an area of a layer, select that 

area. To apply a filter to the entire layer, leave the 

image unselected. 

2 Choose a filter from the submenus in the 

Filter menu. If a filter name has ellipses, a dialog 

box appears. 

3 If a dialog box appears, enter values or select 

options.

4 To preview the effect using the filter’s preview 

box, use the following navigation methods:

• Drag in the image window to center a specific 

area of the image in the preview box. 

• To see part of the layer that is not visible, move 

the cursor inside the preview box to activate the 

hand tool. Drag to move the layer preview. 

T
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• Use the + or – button under the preview box to 

zoom in or zoom out on the preview. 

A. Click and drag to move image in preview box.
B. Click + to zoom in or - to zoom out on image
in preview box.

A flashing line beneath the preview size indicates 

that Adobe Photoshop is still rendering the 

preview. 

5 If the Preview option is available, select the 

option to preview the filter effect on the image.

6 Click OK to apply the filter. 

When a filter takes a while to be applied, Adobe 

Photoshop displays a progress bar (Macintosh) or 

progress indicator in the status bar (Windows) so 

that you can gauge the time remaining until the 

filter is applied.

See the various examples of filter effects in this 

chapter. 

Using filter shortcuts

These techniques can help save time when 

working with filters:

• To cancel a filter as it is being applied, press 

Command-period (Macintosh) or Esc (Windows). 

• To undo a filter, press Command+Z 
(Macintosh) or Ctrl+Z (Windows). 

• To reapply the most recently used filter with its 

last values, press Command+F (Macintosh) or 

Ctrl+F (Windows).

• To display the dialog box for the last filter you 

applied, press Command+Option+F (Macintosh) 

or Ctrl+Alt+F (Windows).

Loading images and textures

Some filters let you load other images, such as 

textures and displacement maps, to use with a 

filter. These filters include the Conté Crayon, 

Displace, Glass, Lighting Effects, Rough Pastels, 

Texture Fill, Texturizer, Underpainting, and 

Custom filter dialog boxes. Not all these filters load 

images or textures in the same way; see “Using the 

Displace filter” on page 187 and “Using the 

Lighting Effects filter” on page 189.

B

A
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To load images and textures:

1 Choose the filter you want from the appropriate 

filter submenu.

2 For Texture, choose Load Texture, and locate 

and open a texture image. The texture must be in 

the Photoshop format. If you choose a color file, 

most filters will use only its grayscale information.

3 Click OK in the filter dialog box to apply the 

settings.

Defining undistorted areas

The Displace, Shear, and Wave filters in the Distort 

submenu, and the Offset filter in the Other 

submenu let you choose the following ways to 

treat areas undefined by the filter:

• Wrap Around copies the image to fill the 

undefined space so that the area is filled with 

content from the opposite side of the image.

• Repeat Edge Pixels extends the colors of the 

pixels along the edge of the image in the direction 

specified. Banding may result if the edge pixels are 

different colors.

• Set to Background fills the selected area with the 

current background color (available for the Offset 

filter only).

Using texture and glass surface controls

Five filters included in Adobe Photoshop have 

texturizing options—the Conté Crayon, Glass, 

Rough Pastels, Texturizer, and Underpainting 

filters. The texturizing options can make an image 

appear as though painted onto various textures, 

such as canvas and brick, or viewed through glass 

blocks. 

To use texture and glass surface controls:

1 From the Filter menu, choose Artistic > Rough 

Pastels, Artistic > Underpainting, Distort >Glass, 

Sketch > Conté Crayon, or Texture > Texturizer.

2 For Texture, choose a texture type or choose 

Load Texture to specify a Photoshop file.

3 Drag the Scaling slider to enlarge or reduce the 

effect on the image surface. 

4 Drag the Relief slider (if available) to adjust the 

depth of the texture’s surface.

5 Select Invert to reverse the surface’s light and 

dark colors.

6 For Light Direction, indicate the direction of the 

light source on the image.

7 Click OK.
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Tips for creating special effects
Try the following techniques to create special 

effects with filters.

Create edge effects When you apply an effect to 

only a selected part of an image, you can use 

various techniques to blend the effect into the 

original image. 

For a distinct edge, apply the filter effect as is, to 

contrast it with the rest of the image. For a soft 

edge, feather the edge and then apply a filter. 

Distinct edge Feathered edge

Apply filters to layers Another way to vary filter 

effects is by applying them to individual layers or 

to several layers in succession to build up an effect. 

For a filter to affect a layer, the layer must be visible 

and it must contain pixels with color values.

Create backgrounds By applying effects to solid-

color or grayscale shapes, you can generate a 

variety of backgrounds and textures. You can also 

apply a texture, and then blur it. Try these filters to 

create background texture: Add Noise, Chalk & 

Charcoal, Clouds, Conté Crayon, Craquelure, 

Difference Clouds, Glass, Grain, Graphic Pen, 

Halftone Pattern, Mezzotint, Mosaic, Note Paper, 

Patchwork, Pointillize, Reticulation, Rough 

Pastels, Sponge, Stained Glass, Texture Fill, 

Texturizer, and Underpainting. Note that some 

filters, such as Glass, have little or no visible effect 

when applied to a solid color.

Combine multiple effects with duplicate images Use 

two duplicate images to apply various effects to 

selected areas in each image, and then recombine 

the two images. For example, apply a different 

effect to each of two copies of an image, and then 

use the Clone option of the rubber stamp tool to 

paint one copy onto the other copy.

Improve image consistency If you’re working with 

a series of photos of varying or poor quality, you 

can achieve a unified look in the final piece by 

applying the same effect to each image to disguise 

the faults of the original or to alter or enhance the 

mode of the image. 

Improving performance with 
filters
Some filter effects can be memory intensive, 

especially when applied to a high-resolution 

image. You use these techniques to improve 

performance when applying filters:

• Try out a filter on a small portion of an image.

• Change the settings. Some filters are extremely 

memory intensive, such as the Lighting Effects, 

Cutout, Stained Glass, Chrome, Ripple, Spatter, 

Sprayed Strokes, and Glass filters. Try different 

settings to increase the speed of the filter. (For 

example, with the Stained Glass filter, increase the 

cell size; with the Cutout filter, increase the Edge 

Simplicity or decrease the Edge Fidelity, or both.)
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• If you plan to print to a grayscale printer, convert 

a copy of the image to grayscale before applying 

filters. Note, however, that in some cases applying 

a filter to a color image and then converting it to 

grayscale may not have the same effect as applying 

the same filter to a grayscale version of the image.

Choosing a filter effect
The Adobe Photoshop filters fall into 13 general 

categories. In addition, third-party filters appear 

at the bottom of the Filter menu. 

Artistic filters Give an image the appearance of 

different media for a more organic (and less 

computer-generated) look. For specific infor-

mation on the Rough Pastels and Underpainting 

filters, see “Using texture and glass surface 

controls” on page 181.

Blur filters Soften a selection or an image and are 

useful for retouching images. Blur filters smooth 

transitions by averaging the pixels next to the hard 

edges of defined lines and shaded areas where 

significant color transitions occur in an image. 

Brush Strokes filters Give an image a painterly 

or fine-arts look using different brush and ink 

stroke effects. Some of the filters add grain, paint, 

noise, edge detail, or texture to an image for a 

pointillist effect. 

Distort filters Geometrically distort an image and 

can be used to create 3-D or other plastic effects. 

For more information on the Displace filter, see 

“Using the Displace filter” on page 187. For 

specific information on individual filters, see 

“Using texture and glass surface controls” on 

page 181 and “Defining undistorted areas” on 

page 181.

Noise filters Add or remove noise from an image 

and help make a selection into the surrounding 

pixels. Noise in an image is pixels with randomly 

distributed color levels. You can use the Noise 

filters to remove problem areas from an image, 

such as dust and scratches, and to create unusual 

textures, such as those used as backgrounds 

behind title text. The Add Noise filter can also be 

useful in reducing banding in feathered selections 

and graduated fills and in giving a more realistic 

look to heavily retouched areas. For specific infor-

mation on the Dust & Scratches filter, see “Using 

the Dust & Scratches filter” on page 186.

Pixelate filters Sharply define a selection by 

clumping pixels of similar color values in cells. For 

specific information on Color Halftone filter, see 

“Using the Color Halftone filter” on page 185.
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Render filters Create blending cloud patterns by 

varying the foreground and background color (the 

Clouds and Difference Clouds filters), create 

refraction patterns simulating light reflections in 

the image (the Lens Flare filter), and create fills 

from a grayscale file or part of a file (the Texture 

Fill filter). You can also create 3-D-like lighting 

effects; see “Using the Lighting Effects filter” on 

page 189.

When using the Clouds filter, generate a more 

stark cloud pattern by holding down Option 

(Macintosh) or Alt (Windows) as you choose Filter > 

Render > Clouds. 

Sharpen filters Focus blurry images by increasing 

the contrast of adjacent pixels. These include the 

Sharpen and Sharpen More filters, and the 

Sharpen Edges and Unsharp Mask filters—both of 

which find the areas in the image where significant 

color changes occur (such as at the edges) and 

sharpen them. The Unsharp Mask filter is 

commonly used for high-end color correction; for 

more information, see “Step 5: Sharpen the image” 

on page 83.

Sketch filters Add fine-arts and hand-drawn 

effects to an image. For specific information on the 

Conté Crayon filter, see “Using texture and glass 

surface controls” on page 181.

When using the Conté Crayon filter, for a truer 

effect, change the foreground color to one of the 

common Conté Crayon colors (black, sepia, 

sanguine) before applying the filter. 

Stylize filters Produce bold, exaggerated effects by 

displacing pixels and by finding and heightening 

contrast in an image. 

Texture filters Add texture to an image. For specific 

information about the Texturizer filter controls, 

see “Using texture and glass surface controls” on 

page 181.

Video filters Include the National Television 

Standards Committee Colors and De-Interlace 

filters. The NTSC Colors filter restricts the gamut 

of colors to those acceptable for television repro-

duction, to prevent oversaturated colors from 

bleeding across television scan lines. The De-

Interlace filter smooths moving images captured 

on video by removing either the odd or even inter-

laced lines in a video image; the filter gives you the 

option of replacing the discarded lines by dupli-

cation or interpolation. 

Other filters Let you create your own filters using 

the Custom filter, use filters to modify masks (the 

Minimum and Maximum filters), offset a selection 

within an image (Offset filter), and make quick 

color adjustments (the High Pass filter, which 

emphasizes very bright areas and highlights and 

removes shading in a selection). 

For more information about defining empty areas 

left by the Offset filter, see “Defining undistorted 

areas” on page 181. For more information about 

the Custom filter, see “Using the Custom filter” on 

page 185.

Digimarc filter Lets you read copyright and 

authorship information for an image that has been 

embedded with a digital watermark using the 

Digimarc PictureMarc technology. For more 

information, see “Viewing copyright and 

authorship information” on page 45.
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Using the Color Halftone filter
The Pixelate > Color Halftone filter simulates the 

effect of using an enlarged halftone screen on each 

channel of the image. For each channel, the filter 

divides the image into rectangles and replaces each 

rectangle with a circle. The circle size is propor-

tional to the brightness of the rectangle. To use the 

Color Halftone filter, you specify a screen-angle 

value for each channel of the image.

To use the Color Halftone filter:

1 Choose Filter > Pixelate > Color Halftone.

2 Enter a value in pixels for the maximum radius 

of a halftone dot, from 4 to 127.

3 Enter a screen-angle value (the angle of the dot 

from the true horizontal) for each channel, as 

follows:

• Grayscale images use only channel 1. 

• In RGB images, channels 1, 2, and 3 correspond 

to the red, green, and blue channels. 

• In CMYK images, the four channels correspond 

to the cyan, magenta, yellow, and black channels, 

respectively. 

• Click Defaults to return all the screen angles to 

their default values. 

4 Click OK.

Using the Custom filter 
The Other > Custom filter lets you change the 

brightness values of each pixel in the image 

according to a predefined mathematical operation 

known as convolution. Each pixel is reassigned a 

value based on the values of surrounding pixels. 

This operation is similar to the Add and Subtract 

calculations for channels. 

You can save the custom filters you create and use 

them with other Adobe Photoshop images. 

To create a Custom filter: 

1 Choose Filter > Other > Custom. 

2 Select the center text box, which represents the 

pixel being evaluated. Enter the value by which 

you want to multiply that pixel’s brightness value, 

from –999 to +999.

3 Select a text box representing an adjacent pixel 

to which to assign a weighted value. Enter the 

value by which you want the pixel in that position 

multiplied. 

For example, to multiply the brightness value of 

the pixel to the immediate right of the current 

pixel by 2, enter 2 in the text box to the immediate 

right of the center text box. 

4 Repeat steps 2 and 3 for all pixels to include in 

the operation. You don’t have to enter values in all 

the text boxes.
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5 For Scale, enter the value by which to divide the 

sum of the brightness values of the pixels included 

in the calculation. 

6 For Offset, enter the value to be added to the 

result of the scale calculation. 

7 Click OK. The custom filter is applied to each 

pixel in the image, one at a time. 

Use the Save and Load buttons to save and reuse 

custom filters. 

Using the Dust & Scratches filter
The Noise > Dust & Scratches filter reduces noise 

by changing dissimilar pixels. You specify how 

different pixel values should be before they are 

eliminated, and a radius for how far the filter 

should search for them. Finding the desired trade-

off between sharpness and hiding defects may 

require trying different combinations of radius 

and threshold settings. If you can’t make the image 

sharp enough, try selecting specific areas on which 

to use the filter.

To use the Dust & Scratches filter:

1 Choose Filter > Noise > Dust & Scratches.

2 If necessary, adjust the preview zoom ratio until 

the area containing the noise is visible. 

3 Drag the Threshold slider to the left to 0 levels to 

turn off the value so that you can examine all pixels 

in the selection or the image. 

The Threshold option determines the degree of 

difference among pixels that will be affected by 

the filter.

Note: The Threshold slider gives greater control for 

values between 0 and 128—the most common range 

for images—than for values between 128 and 255.

4 Drag the Radius slider left or right, or enter a 

value in the text box from 1 to 16 pixels to set how 

far to search for differences among pixels, until the 

defects disappear from the image. 

Adjusting the radius makes the image blurry; 

stop when the value is the smallest that eliminates 

the defects.

5 Increase the threshold gradually by entering an 

exact number or by dragging the Threshold slider 

until it is as high as possible without displaying the 

defects.

6 Click OK.
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Using the Extrude filter
The Stylize > Extrude filter gives a three-dimen-

sional texture to a selection or layer. You choose a 

type of three-dimensional object on which the 

filter is based.

To use the Extrude filter:

1 Choose Filter > Stylize > Extrude. 

2 Choose from the following types of three-

dimensional objects:

• Blocks creates objects with a square front face 

and four side faces. To fill the front face of each 

block with the average color of the block, select the 

Solid Front Faces option. To fill the front face with 

the image, keep the Solid Front Faces option 

deselected. 

• Pyramids creates objects with four triangular 

sides that meet at a point.

3 Enter a value in the Size box to determine 

the length of any side of the object’s base, from 2 

to 255.

4 Enter a value in the Depth box to indicate how 

far the tallest object appears to protrude from the 

screen, from 1 to 255.

5 Choose a depth option: Random to give each 

block or pyramid an arbitrary depth, or Level-

based to make each object’s depth correspond to 

the overall brightness of the object; brighter 

objects appear to protrude more than dark objects.

6 Select Mask Incomplete Blocks to hide any 

object that extends beyond the selection.

7 Click OK.

Using the Displace filter
The Distort > Displace filter uses a second image 

(called a displacement map) to determine how to 

distort the selection. For example, using a 

parabola-shaped displacement map, you can 

create an image that appears as though it were 

printed on a cloth held at its corners. You can use 

any file in the Adobe Photoshop format, except 

one in Bitmap mode, for a displacement map. The 

Adobe Photoshop software also includes several 

maps useful for experimenting (search for the 

Displacement Maps folder on the Macintosh or 

the Dispmaps folder in Windows). 

The Displace filter shifts a selection using a color 

value from the displacement map: 0 is the 

maximum negative shift, 255 is the maximum 

positive shift, and a gray value of 128 produces no 

displacement. (You can use the Curves dialog box 

to modify a gradient to get a particular effect.) If a 

map has one channel, the image shifts along a 

diagonal defined by the horizontal and vertical 

scale ratios. If the map has more than one channel, 

the first channel controls the horizontal 

displacement, and the second channel controls the 

vertical displacement. 

To use the Displace filter:

1 Choose Filter > Distort > Displace.

2 Enter the scale for the magnitude of the 

displacement.

When the horizontal and vertical scale are set to 

100%, the greatest displacement is 128 pixels 

(because middle gray produces no displacement).
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3 If the displacement map is not the same size 

as the selection, choose how the map will fit the 

image: Stretch to Fit to resize the map, or Tile to fill 

the selection by repeating the map in a pattern.

4 Choose from the following options to 

determine how to treat areas of the image 

undefined by the distortion:

• Wrap Around copies the image to fill the 

undefined space so that the area is filled with 

content from the opposite side of the image.

• Repeat Edge Pixels extends the colors of the 

pixels along the edge of the image in the direction 

specified. Banding can result if the edge pixels are 

different colors.

5 Click OK.

6 Select and open the displacement map. The 

distortion is applied to the image.

To make a parabola-shaped displacement map and 
create an arching image effect:

1 Start with a new grayscale image. (For best 

performance, use small images.) 

2 Set the foreground color to black and the 

background color to white.

3 Double-click the gradient tool and choose 

Foreground to Background for Gradient in the 

Gradient Tool Options palette. Then drag the 

gradient tool from left to right in the image 

window to make a linear gradient fill. 

4 Using the Curves dialog box, draw a parabola 

that dips down from the upper left corner of the 

dialog box and back to the upper right corner. 

Then click OK.

5 Save the image to disk in the Photoshop format; 

this is the shape of the displacement map.

6 To apply the displacement map, open the image 

you want to displace, and choose Filter > Distort > 

Displace. 

7 Set the horizontal scale to 0% and the vertical 

scale to 50%. Select the Stretch to Fit option. 

8 Select the displacement map that you saved 

in step 5. 

9 Click Open.
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Using the Lighting Effects filter
The Render > Lighting Effects filter lets you apply 

up to 17 different light styles to an RGB image. 

You can choose from three different types of lights 

and from four sets of properties for each image. 

You can also save your own styles for use in 

other images.

By varying the number of lights, the light types, 

and the light properties, you can produce myriad 

lighting effects. You can also use textures from 

grayscale files (called bump maps) to produce 3-D-

like lighting effects.

Note: The Lighting Effects filter works only on 

RGB images.

To use the Lighting Effects filter:

1 Choose Filter > Render > Lighting Effects. 

2 For Style, choose a style. Press Tab to cycle 

through the lights in a style. For more infor-

mation, see “Choosing a Lighting Effects style” on 

page 192.

3 For Light Type, choose a type. For more infor-

mation, see “Choosing a Lighting Effects type” on 

page 190. If you’re using multiple lights, select and 

deselect On to turn individual lights on and off. 

4 To change the color of the light, click the 

color swatch in the Light Type section of 

the dialog box. 

A. Click swatch to select new color

The color picker chosen in the General Preferences 

dialog box opens. For more information, see 

“Using the Adobe Photoshop Color Picker” on 

page 146, “Using the Apple Color Picker” on 

page 148, or “Using the Windows Color Picker” on 

page 148.

5 To set light properties, drag the corresponding 

slider for the following options:

• Gloss determines how much the surface reflects 

light (as on the surface of a piece of photographic 

paper) from Matte (little reflectance) to Glossy 

(high reflectance). 

A
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• Material determines whether the light or the 

object on which the light is cast reflects more light: 

choose Plastic to reflect the light’s color or choose 

Metallic to reflect the object’s color.

• Exposure increases the light (positive values) or 

darkens the light (negative values). A value of 0 has 

no effect.

• Ambience diffuses the light as if it were 

combined with other light in a room, such as 

sunlight or fluorescent light. Choose a value of 100 

to use only the light source; a value of –100 

removes the light source. To change the color of 

the ambient light, click the color swatch and use 

the Color Picker that appears.

To duplicate a light, Option-drag 

(Macintosh) or Alt-drag (Windows) the 

light within the preview box.

6 To use a texture fill, choose a channel for Texture 

Channel. See “Using a Lighting Effects texture” on 

page 193.

7 Click OK to apply the filter.

To delete a light:

In the Lighting Effects dialog box, drag the light by 

its center circle to the Trash icon at the bottom 

right of the preview box.

Choosing a Lighting Effects type

You can choose from three light types.

• Omni shines in all directions from directly 

above the image, as if a light bulb were over a 

piece of paper. 

Omni light

• Directional shines light from far away, like the 

sun, so that the light angle does not change. 

Directional light
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• Spotlight casts an elliptical beam of light. 

The line in the preview box defines the light 

direction and angle, and four boxes define the 

edges of the ellipse. 

Spotlight

To adjust an Omni light:

1 Choose Filter > Render > Lighting Effects. 

2 For Light Type, choose Omni.

3 Choose from the following:

• To move the light, drag the center circle. 

• To increase or decrease the size of the light (as if 

the light were moving closer to or farther away 

from the paper), drag one of the four boxes, which 

define the edges of the effect.

4 Click OK to apply the filter.

To adjust the angle and height of the directional light 
using the preview box:

1 Choose Filter > Render > Lighting Effects. 

2 For Light Type, choose Directional.

3 Choose from the following:

• To move the light, drag the center circle. 

• To change the direction of the light, drag the 

black square at the end of the line to rotate the 

light’s angle. Command-drag (Macintosh) or 

Ctrl-drag (Windows) to keep the light’s height 

(line length) constant.

• To change the light’s height, drag the square at 

the end of the line that represents the height of the 

light: Shorten the line to create a very bright light; 

if the line gets too short, it produces pure white 

light. Lengthen the line for a less intense light; a 

very long line produces no light. Shift-drag to keep 

the angle constant and change the light’s height 

(line length).

4 Click OK to apply the filter.
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To adjust the angle and height of the spotlight using 
the preview box:

1 Choose Filter > Render > Lighting Effects. 

2 For Light Type, choose Spotlight.

3 Choose from the following:

• To move the light, drag the center circle. 

• To increase or decrease the light angle, drag the 

black square at the end of the line to shorten or 

lengthen the line, respectively

• To stretch the ellipse or rotate the light, drag one 

of the four boxes. Shift-drag to keep the angle 

constant and change only the size of the ellipse. 

Command-drag (Macintosh) or Ctrl-drag 

(Windows) to keep the size constant and change 

the angle or direction of the spotlight.

• To set the light focus (or spotlight intensity), and 

control how much of an ellipse is filled with light, 

drag the Intensity slider: Full intensity (a value of 

100) is brightest; Normal intensity is about 50; a 

negative intensity takes away light; –100 intensity 

produces no light. Use the Focus slider to control 

how much of the ellipse is filled with light.

4 Click OK to apply the filter.

Choosing a Lighting Effects style

Use the Style menu in the Lighting Effects dialog 

box to choose from 17 light styles. You can also 

create your own lighting style by adding lights to 

the Default setting. The Lighting Effects filter 

requires at least one light source. Only one light 

can be active for editing at a time, but all of the 

lights will be used to create the effect.

Note: The names of these styles are abbreviated in 

Windows.

Default One yellow spotlight with a medium 

intensity and a wide focus. 

2 o’clock Spotlight One yellow spotlight with 

medium (17) intensity and wide (91) focus.

Blue Omni One blue overhead omni light with full 

(85) intensity and no focus.

Circle of Light A spotlight made up of red, blue, 

yellow, and white lights with full (100) intensity 

and a concentrated (8) focus.

Crossing A white spotlight with medium (35) 

intensity and a concentrated (8) focus.

Crossing Down Two white spotlights with medium 

(35) intensity and wide (100) focus.

5 Lights Down/5 Lights Up Five white spotlights 

down or up, respectively, with full (100) intensity 

and wide (60) focus.

Flashlight An omni yellow light with medium (46) 

intensity.

Flood Light A white spotlight with medium (35) 

intensity and wide (69) focus.
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Parallel Directional A directional blue light with 

full (98) intensity and no focus.

RGB Lights A red, blue, and green light that 

produces a white spotlight of medium (60) 

intensity and wide (96) focus.

Soft Direct Lights Two unfocused whitish and blue 

directional lights of soft (20) intensity.

Soft Omni A soft omni light of medium (50) 

intensity.

Soft Spotlight A white spotlight with full (98) 

intensity and white (100) focus.

Three Down Three white spotlights with soft (35) 

intensity and wide (96) focus.

Triple Spotlight Three spotlights with slight (35) 

intensity and wide (100) focus.

To add a light: 

In the Lighting Effects dialog box, drag the light 

icon at the bottom of the dialog box into the 

preview area. Repeat as desired for a maximum 

of 16 lights. 

To create a new style:

1 In the Lighting Effects dialog box, choose 

Default for Style. 

2 Drag the light icon at the bottom of the dialog 

box into the preview area. Repeat as desired for a 

maximum of 16 lights. 

To save a style:

1 In the Lighting Effects dialog box, click Save. 

2 Name the style, and click OK.

Saved styles include all the settings for each light 

and appear in the Style menu whenever you open 

the image. 

To delete a style:

1 In the Lighting Effects dialog box, choose a style 

for Style. 

2 Click Delete.

Using a Lighting Effects texture

The Texture Channel in the Lighting Effects dialog 

box lets you use a grayscale texture such as paper 

or water to control how light reflects off an image. 

You can use a layer from any image as a texture, 

or create your own texture, such as 3-D bumps 

that bounce light from their surface; the texture 

channel sets the height of the bumps. For an 

embossed text effect, use a layer with white text 

on a black background, or vice versa.
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To use the Texture Channel in the Lighting Effects 
dialog box:

1 If necessary, create a layer in your image and add 

texture to it. To use a texture from another image, 

copy and paste the image as a new layer. 

2 In the Lighting Effects dialog box, choose a 

channel from the Texture Channel menu. Choose 

the image’s Red, Green, or Blue channel, or any 

layer added to the image.

3 Select White is High to raise the white parts 

of the texture channel from the surface. Turn off 

this option to raise the dark parts of the texture 

channel from the surface.

4 Drag the Height slider to vary the texture from 

Flat (0) to Mountainous (100). 

5 Click OK.

Using the Trace Contour filter
The Stylize > Trace Contour filter finds the transi-

tions of major brightness areas and thinly outlines 

them, similar to the Find Edges filter. 

To use the Trace Contour filter:

1 Choose Filter > Stylize > Trace Contour.

2 Choose an Edge option to outline areas in the 

selection: Lower outlines where the color values of 

pixels fall below the specified level; Upper outlines 

where the color values of pixels are above the 

specified level. 

3 Enter a threshold (Level) for evaluating color 

values (its tonal level), from 0 to 255. You can 

experiment to see what values bring out the best 

detail in the image. 

4 Use the Info palette in Grayscale mode to 

identify a color value that you want traced; then 

enter the value in the Level text box. For more 

information, see “Customizing the Info palette” 

on page 13.

5 Click OK.

Photoshop filter sample gallery

The following pages show examples of effects 

using filters included in Photoshop LE.
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Original Colored Pencil Dry BrushCutout

Film Grain Neon GlowFresco Paint Daubs

Rough PastelsPoster EdgesPalette Knife

Smudge Stick

Plastic Wrap

Gaussian Blur, radius 8Gaussian Blur, radius 4Original Blur More

Sponge WatercolorUnderpainting

ARTISTIC

BLUR

Smart BlurRadial Blur, zoomMotion Blur Radial Blur, spin
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Dark Strokes Ink Outlines

Sprayed Strokes, diagonal

Spatter

Sumi-e, high contrastSprayed Strokes, vertical

Accented Edges, brighter

Sumi-e, smooth

Glass, tiny lens textureDisplaceOriginal

Ocean Ripple

Diffuse Glow

TwirlShear Spherize

Pinch

Ripple 

Polar Coordinates

BRUSH
STROKES

DISTORT

Original Accented Edges

Crosshatch        

Angled Strokes

Glass, blocks texture
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Original Add Noise, 25 Add Noise, 55

Original CrystallizeColor Halftone Facet

PointillizeMosaicFragment

Original

Mezzotint

Unsharp MaskSharpen MoreOriginal Sharpen Edges

Clouds Lens FlareDifference Clouds

NOISE

PIXELATE

RENDER

SHARPEN

ZigZag, pond ripplesZigZag, out from centerWave, square type

DISTORT

Wave, sine type
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Tiles , background color

Extrude, blocks

Trace Contour Wind

STYLIZE

Chrome

Conté Crayon Graphic Pen Note Paper

Plaster

Photocopy

Reticulation Water PaperStamp

Original

Tiles, inverse image

SolarizeFind Edges Glowing Edges

Diffuse Extrude, pyramidsEmboss

STYLIZE

SKETCH

Chalk & CharcoalOriginal Bas Relief
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Original Craquelure Mosaic TilesGrain

Patchwork Texturizer, burlap textureStained Glass Texturizer, custom texture

TEXTURE
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Chapter 10: Saving and Exporting 
Images

dobe Photoshop Limited Edition 

supports a variety of file formats to suit a 

wide range of output needs. You can save 

or export your image to any of these formats. 

File format and export choices appear either in the 

Save As or Save a Copy dialog box or in the Export 

menu. If a file format does not appear, install the 

format’s plug-in module following the instruc-

tions in “Using plug-in modules” on page 18. For 

information on a specific format, see “About file 

formats” on page 210.

Saving files
Adobe Photoshop provides several ways for you to 

save files:

• The Save command saves the file in its current 

file format.

• The Save As command lets you save an alternate 

version of the file in a different format or location.

• The Save a Copy command lets you save an 

identical or flattened copy of the file. This 

command leaves the original file intact.

Note: Some formats are available only for certain 

color modes. In addition, many formats are available 

only if an image has no additional layers. 

To save a file in its current format:

Choose File > Save. 

To save a file in a different file format:

1 Choose File > Save As.

2 For Format (Macintosh) or Save As (Windows), 

choose a format. Unavailable formats are dimmed 

(Macintosh) or not visible (Windows).

3 Type a filename, and choose a location for 

the file.

4 Click Save.

With some image formats, a dialog box appears. 

For information on the options available for

specific file formats, see “About file formats” on 

page 210.

To save a duplicate of a file:

1 Choose File > Save a Copy.

2 For Format (Macintosh) or Save As (Windows), 

choose a format.

3 To flatten all visible layers, select Flatten Image. 

See “Flattening all layers” on page 175 for more 

information.

4 Click Save. 

Note: To copy an image without saving it to your 

hard disk, use the Duplicate command. See “Dupli-

cating images” on page 110.

A
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Using image previews on the Macintosh

On the Macintosh, you can choose to save your 

files with the following types of image previews:

• File icons are the preview icons you see on the 

desktop.

• Thumbnails are the image previews that appear 

in the Open dialog box.

• Full size previews are images intended for use in 

applications that open Adobe Photoshop images 

but require 72 ppi images. For non-EPS files, this 

is a PICT preview. 

The Full Size preview option is off by default. 

Turning off the other preview options can make 

saving faster and requires less file storage space on 

your disk.

To set options for image previews:

1  Choose File > Preferences > Saving Files.

2 For Image Previews, choose one of the following 

options:

• Never Save to save files without previews.

• Always Save to save files with the specified 

preview or previews.

• Ask When Saving to assign previews on a file-by-

file basis when you save. 

3 If you chose Always Save, select the preview or 

previews you want to use.

4 Click OK.

Using image previews in Windows

In Windows, you can choose to save images with a 

thumbnail preview that appears in the Open 

dialog box. In Windows NT 4.0 and Windows 95, 

you can also generate preview icons for files that 

have been saved.

To set options for thumbnail previews:

1 Choose File > Preferences > Saving Files.

2 For Image Previews, choose one of the following 

options:

• Never Save to save files without previews.

• Always Save to save files with the specified 

preview or previews.

• Ask When Saving to assign previews on a file-by-

file basis when you save. 

3 Click OK.

To generate a preview icon for a file (Windows NT 4.0 
and Windows 95 only):

1 Save the file.

2 Choose File > Save As.

3 Position the pointer on the filename in the file 

list, click the right mouse button, and choose 

Properties from the context menu that appears.
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4 Click the Photoshop Image tab.

5 For Icon Thumbnails, select the desired preview 

icon. To have the file appear without a preview 

icon, select Don’t Generate.

6 Click OK.

Using file extensions (Macintosh only)

On the Macintosh, you can have Adobe Photoshop 

append the file extension to the name of a file 

when you save it. This three-character file 

extension refers to the file’s format (for example, 

the extension for a JPEG file is.jpg). Saving files 

with extensions is useful when you want to use the 

files on a system running Windows. 

To append file extensions to filenames:

1 Choose File > Preferences > Saving Files.

2 For Append File Extension, choose one of the 

following options:

• Never to save files without file extensions.

• Always to append file extensions to filenames.

• Ask When Saving to append file extensions on a 

file-by-file basis when you save. 

3 Click OK.

To append the file extension to the current filename:

1 Choose File > Save As or File > Save a Copy.

2 Hold down Option, and choose a file format 

from the list.

3 Save the file.

Saving Adobe Photoshop files

Adobe Photoshop is the default file format for 

newly created images. This encoded format is 

the only format that supports all available Adobe 

Photoshop LE image modes (Bitmap, Grayscale, 

Indexed color, and RGB) and layers.

If you’re exporting Photoshop files to a page-

layout program that doesn’t support the Adobe 

Photoshop format, use the Save a Copy command 

to save a duplicate file in a format supported by the 

page-layout program. 

Saving Adobe Photoshop 2.0 files 
(Macintosh only)

Choose the Photoshop 2.0 format when you need 

to open a Photoshop file in version 2.0 of Adobe 

Photoshop, or when you are exporting to an appli-

cation that supports only Photoshop 2.0 files. 

Saving in Photoshop 2.0 format flattens your file 

and discards layer information.

Saving Adobe Photoshop files as 
Adobe Photoshop 2.5 files

If you’re planning to use a file created in Adobe 

Photoshop LE in an application that supports only 

Photoshop 2.5 files, you can still save the file in 

Photoshop format. By default, the Photoshop 

format saves a copy of the flattened data that can 

be used by programs that read Photoshop 2.5 files. 

Saving a Photoshop file with Photoshop 2.5 

compatibility turned on does increase the file size. 

If you plan to work only in Adobe Photoshop LE, 

you can turn off Photoshop 2.5 compatibility to 

minimize the file size of saved files.
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To turn off Photoshop 2.5 compatibility:

1 Choose File > Preferences > Saving Files.

2 Deselect 2.5 Format Compatibility, and 

click OK. 

Saving files in Photoshop EPS format

When you save a file in Encapsulated PostScript 

(EPS) format, you can choose from a variety of 

options, as described in the following sections. 

Preview You can save a TIFF preview of a 

Photoshop EPS file. On the Macintosh, you can 

also save a PICT preview. These preview images 

give you an idea of how the image will look when 

it is printed and help you accurately place the 

image on the page. On the Macintosh, choose a 

TIFF option to save a preview for use with an IBM® 

PC-compatible application.

Encoding When saving images in Photoshop EPS 

format and when printing to PostScript output 

devices, you can choose from several types of 

encoding options: ASCII encoding is the most 

generic, but creates the largest output files. If 

you’re working in Windows, use ASCII encoding. 

Binary encoding makes a smaller output file 

(speeding the transfer of the file to your output 

device) without modifying the original data.

Some page-layout applications may not support 

binary Photoshop EPS files. For these applications, 

you should select the ASCII encoding option. 

Some commercial print spooling and network 

printing software does not support binary 

encoding. If you experience printing errors, 

it may be that your print spooler requires 

ASCII encoding.

Halftone Screen You can choose to include the EPS 

file halftone screen information (including the 

frequency and angle of the screen) when you save 

the file. If you include the halftone screen infor-

mation and place the file into another application, 

such as Adobe Separator™, the PostScript language 

interpreter uses these screen settings when the 

color separations are generated. 

Saving files in JPEG format

When saving in JPEG format, you can specify an 

image quality and compression level for the file. To 

specify image quality, enter a value between 0 and 

10 or choose an option for Quality; to specify the 

amount of compression, drag the slider. A trade-

off exists between the image quality and the 

amount of compression; an image compressed 

using Maximum quality is less compressed (and 

thus takes up more disk space) than an image 

compressed using the Low quality option. 
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In addition, you can select a format option for the 

JPEG file. To optimize the color quality of the 

image, select Baseline Optimized. To save the file as 

a progressive JPEG, select Progressive. This option 

displays the image gradually as it is downloaded 

from a Web browser, using a series of scans to show 

increasingly detailed versions of the entire image 

until all of the data has finished downloading. 

However, progressive JPEG images require more 

RAM for viewing and are not supported by all Web 

browsers. When you select Progressive, you can 

also specify the number of progressive scans. 

Note: If you are using a JPEG file with a Java appli-

cation and find that the application cannot read 

your file, try saving the file without a thumbnail 

preview. See “Using image previews on the 

Macintosh” on page 204 and “Using image previews 

in Windows” on page 204 for more information.

Exporting images 
The GIF89a Export module lets you convert 

RGB images to indexed-color GIF files and specify 

the number of colors you want the file to have. 

In addition, the command lets you designate 

transparent areas in your GIF images for use 

in hypertext markup language (HTML) 

documents used on the World Wide Web. Adobe 

Photoshop LE can open and save CompuServe 

GIF files that are either 8-bit indexed color or 

grayscale.

Exporting RGB images to GIF

When you export an RGB image to GIF, you can 

use layers in Adobe Photoshop to define what 

parts of the image you want to appear transparent. 

The GIF89a export feature then lets you convert 

the image to indexed color, choose a transparency 

color for the Web browser, and save the image as a 

GIF file.

To export an RGB image to GIF:

1 If you want to include only part of the RGB 

image in your HTML document, select that part of 

the image and feather it if desired. Copy the 

selection onto a new, transparent layer. Be sure to 

hide any layers that you do not want to include in 

the GIF file. For more information, see Chapter 

8, “Using Layers.”

Original Selection copied to 
transparent layer

2 Choose File > Export > GIF89a Export.
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3 To display transparent areas of the image as a 

solid color, do one of the following:

• To make transparent areas the same color as the 

Web browser window background, leave the 

Transparency Index Color box at the default color. 

The default color is Netscape™ gray, which is 192 R, 

192 G, and 192 B.

• To change the color used for displaying trans-

parent areas, click the Transparency Index Color 

box, and choose a new color, see “Using the Adobe 

Photoshop Color Picker” on page 146. Click OK.

4 For Palette, choose one of the following options:

• Exact to create a palette using the colors in the 

image. This option is not dimmed (Macintosh) or 

visible (Windows) only if the image contains 256 

or fewer colors.

• Adaptive to create a palette using a represen-

tative sample of colors in the image. (This gives the 

best image quality if Exact is unavailable.) Then 

choose or enter the least number of colors that 

retains the necessary detail in your image.

The effect on file size of reducing the number of 

colors varies depending on dimensions and color 

content. For small-sized images, the effect on file 

size is insignificant.

• System to create a color table using the 

computer’s built-in color palette. Then select Use 

Best Match. The System palette option may 

produce unexpected results when the image is 

displayed on an 8-bit monitor using a different 

built-in palette.

• To use a custom palette, click Load, locate and 

select a custom palette, and click OK. Then select 

Use Best Match.

5 To see how the image will appear in the Web 

browser, click Preview. 

6 To navigate the preview, use the following 

methods:

• To move the image within the preview window, 

select the hand tool ( ) and drag over the image. 

To fit all of the image in the window, double-click 

the hand tool.

• To increase the magnification, select the zoom-

in tool ( ) and click the part of the preview that 

you want to magnify. For a 100% preview, double-

click the zoom-in tool.

• To reduce the magnification, hold down Option 

(Macintosh) or Alt (Windows) and click the part 

of the preview you want to reduce.

To use the viewing tools quickly when working 

in the GIF89a Export Preview, move the 

pointer to the preview area and use these shortcuts: 

• To activate the zoom-in tool, press Command 

(Macintosh) or Ctrl (Windows). 

• To activate the zoom-out tool, press Option 

(Macintosh) or Alt (Windows).

• To activate the hand tool, press the spacebar.

7 Click OK to close the preview window.

8 If dissatisfied with the results, hold down 

Option (Macintosh) or Alt (Windows) and click 

Reset to restore the colors in the image. Repeat 

steps 3 through 8 as needed.
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9 To determine how the image displays as it 

is downloaded in the Web browser, do one of 

the following:

• Select Interlaced to display the image gradually 

in increasing detail as it is downloaded. 

• Deselect Interlaced to use your image as a 

background or texture.

10 Click OK to export the file. Choose a location 

for the exported file, and click Save. 

Exporting indexed-color images to GIF

When you export an indexed-color image to GIF, 

you can assign background transparency to areas 

in the image. All areas containing the colors you 

specify are recognized as transparency by Web 

browsers. 

For the most control, however, you may want to 

convert your image to RGB, create transparency in 

Photoshop using layers, hide the background, and 

then export the RGB image to GIF. Converting the 

image to RGB also lets you feather your selection 

and reduce the number of colors in an adaptive 

palette image when you convert the image to GIF 

(see “Exporting RGB images to GIF” on page 207). 

See Chapter 8, “Using Layers” for more infor-

mation on working with layers.

To export an indexed-color image to GIF:

1 Choose File > Export > GIF89a Export.

2 Assign transparency to desired colors in 

the image:

• To add to the background transparency, click the 

eyedropper-plus tool ( ), and click the desired 

areas in the preview or the desired swatches. The 

selected colors appear highlighted in the swatches.

• To remove a colored area from the background 

transparency, Command-click (Macintosh) or 

Ctrl-click (Windows) the eyedropper-plus tool to 

toggle to the eyedropper-minus tool. Click the 

desired color swatch. 

• To remove all areas from the background trans-

parency, hold down Alt (Windows) or Option 

(Macintosh), and click Reset.

• To navigate the image preview, follow the guide-

lines described in step 6 of “Exporting RGB images 

to GIF” on page 207.

To activate the eyedropper-minus tool while the 

eyedropper-plus tool is selected, press 

Command (Macintosh) or press Ctrl (Windows). 

To activate the eyedropper-plus tool while the 

eyedropper-minus tool is selected, press Shift.

3 Do one of the following:

• To preview the background transparency as the 

gray background color used by many Web 

browsers, leave the Transparency Index Color box 

at the default color.
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• To preview the background transparency as a 

different color, click the Transparency Index Color 

box. Specify a color, as described in “Using the 

Adobe Photoshop Color Picker” on page 146, and 

click OK.

Note: The Transparency Index Color is used only to 

preview the background transparency, and does not 

affect the final appearance of the file.

4 Specify Interlaced and Export Caption options, 

as described in steps 7 and 8 of “Exporting RGB 

images to GIF” on page 207.

5 Click OK to export the file. Choose a location 

for the exported file, and click Save.

About file formats
The following sections discuss the various file 

formats you can use to get images into and out of 

Adobe Photoshop. See Chapter 2, “Getting Images 

into Photoshop” for information on opening files; 

see the beginning of this chapter for information 

on saving files. 

BMP 

BMP is the standard Windows bitmap image 

format on DOS and Windows-compatible 

computers. When saving an image in this format, 

you can specify either Microsoft® Windows or 

OS/2® format and a 1-bit to 24-bit depth for the 

image. For 4-bit and 8-bit images, you can also 

choose to use Run-Length-Encoding (RLE) 

compression; this compression scheme is lossless, 

that is, it does not discard detail from the image.

Photoshop EPS 

The Encapsulated PostScript (EPS) language file 

format is supported by most illustration and page-

layout programs, and in most cases is the preferred 

format for these applications. Note that 

Photoshop EPS also supports transparent whites 

in Bitmap mode. For more information on EPS 

options, see “Saving files in Photoshop EPS 

format” on page 206.

EPS TIFF or EPS PICT Preview

You can use these formats to open files saved 

in applications that create previews but are 

not supported by Adobe Photoshop (such as 

QuarkXPress®). An opened preview file can be 

edited and used like any other low-resolution file. 

Filmstrip

The Filmstrip format is used for animation or 

movie files created by Adobe Premiere®. Only 

images that were exported from Adobe Premiere 

in the Filmstrip file format can be saved in the 

Filmstrip file format in Adobe Photoshop. When 

editing a Filmstrip file in Adobe Photoshop, you 

must not resize or crop if you plan to export the 

image back into Adobe Premiere. For further 

guidelines, see the Adobe Premiere User Guide.
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CompuServe GIF 

The CompuServe Graphics Interchange Format 

(GIF) is the file format commonly used to display 

indexed-color graphics and images in hypertext 

markup language (HTML) documents over the 

World Wide Web and other online services. GIF is 

a compressed format that is designed to minimize 

file transfer time over phone lines.

Adobe Photoshop can save Bitmap mode, 

grayscale, or indexed-color images in the 

CompuServe GIF format. When saving an image 

as GIF, you can specify how the image appears as it 

is downloaded. Select Interlaced to display the 

image gradually in increasing detail as it is 

downloaded. 

The GIF89a Export command lets you specify the 

appearance of transparent areas in the image and 

save an RGB image in the GIF format. For more 

information, see “Exporting images” on page 207.

IFF 

The Amiga™ Interchange File Format (IFF) is used 

for working with Video Toaster and transferring 

files to and from the Commodore Amiga system. 

In addition, this format is supported by a number 

of paint programs on IBM-compatible computers, 

including DeluxePaint from Electronic Arts; IFF is 

the best export format to use with that program. 

JPEG 

The Joint Photographic Experts Group (JPEG) 

format is commonly used to display photographs 

and other continuous-tone images in hypertext 

markup language (HTML) documents over the 

World Wide Web and other online services. Unlike 

the GIF format, JPEG retains all the color infor-

mation in an RGB image. JPEG also uses a 

compression scheme that effectively reduces file 

size by identifying and discarding extra data not 

essential to the display of the image. Opening a 

JPEG image automatically decompresses it.

Because it discards data, the JPEG compression 

scheme is referred to as lossy. This means that once 

an image has been compressed and then decom-

pressed, it will not be identical to the original 

image. A higher level of compression results in 

lower image quality, while a lower level of 

compression results in better image quality. In 

most cases, compressing an image using the 

Maximum quality option produces a result that is 

indistinguishable from the original. For infor-

mation on choosing JPEG options, see “Saving 

files in JPEG format” on page 206.
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PCX 

PCX format, established by Z-Soft® for its PC

Paintbrush® software, is commonly used by IBM 

PC-compatible computers. Most PC software 

supports version 5 of the PCX format. Version 3 

files do not support a custom color palette. For this 

reason, when you open a version 3 PCX file, the 

palette is ignored, and a standard VGA color 

palette is used instead.

PDF

The PDF format is used by Adobe Acrobat®, 

Adobe’s electronic publishing software for 

Macintosh, Windows, UNIX®, and DOS. You can 

view PDF files using the Acrobat Reader® software 

included on your Adobe Photoshop CD-ROM.

Based on the PostScript Level 2 language, PDF can 

represent both vector and bitmap graphics. For the 

purposes of representing pages, PDF pages are 

identical to PostScript pages, but PDF files can also 

contain electronic document search and 

navigation features. PDF files, for example, can 

contain hypertext links and an electronic table 

of contents.

For more information on PDF and Adobe 

Acrobat, see the Adobe Systems website 

(http://www.adobe.com).

PICT File

The PICT format is widely used among Macintosh 

graphics and page-layout applications as an inter-

mediary file format for transferring files between 

applications. The PICT format is especially 

effective at compressing images that contain large 

areas of solid color.

When saving an RGB image in PICT format, you 

can choose either a 16-bit or 32-bit pixel 

resolution. For a grayscale image, you can choose 

from 2, 4, or 8 bits per pixel. If you’re using a 

Macintosh with QuickTime installed, you can also 

choose from four JPEG compression options for 

the file.

PICT Resource (Macintosh only)

A PICT resource is a PICT file contained in a 

Macintosh application’s resource fork; examples of 

PICT resources include the Adobe Photoshop 

splash screen and the contents of the Scrapbook. 

You can open a PICT resource by choosing File > 

Import > PICT Resource (see “Importing an anti-

aliased PICT file (Macintosh only)” on page 44). 

When saving a file as a PICT resource, you can 

specify the resource ID and resource name. You 

can also specify bit depth and compression 

options as you would for the PICT format.
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PIXAR 

The PIXAR format is designed specifically for 

exchanging files with PIXAR image computers. 

PIXAR workstations are designed for high-end 

graphics applications, such as those used for three-

dimensional images and animation. 

PNG

The PNG format was developed as an alternative 

to the GIF format and, like GIF, is used for 

displaying images on the World Wide Web and 

other online services. PNG preserves all color 

information in an image and uses a lossless 

compression scheme to reduce file size. 

When saving an image in PNG format, you can 

choose to display the image in gradually increasing 

detail as it is downloaded. To do this, select Adam7 

for Interlace. You can also select a filtering 

algorithm, which is used to prepare the image data 

for compression.

Raw 

The Raw format is a flexible file format for 

transferring files between applications and 

computer platforms. Raw format consists of a 

stream of bytes describing the color information 

in the file. Each pixel is described in binary format, 

in which 0 equals black and 255 equals white. You 

can specify the file extension (Windows), file type 

(Macintosh), file creator (Macintosh), and header 

information.

On the Macintosh, the file type is generally a four-

character ID that identifies the file; for example, 

TEXT identifies the file as an ASCII text file. The 

file creator is also generally a four-character ID. 

Most Macintosh applications have a unique file 

creator ID that is registered with the Apple 

Computer Developer Services group. 

The header parameter is the number of bytes of 

information that will appear at the beginning of 

the file, before the actual image information. This 

value defines the number of zeros that will be 

placed at the beginning of the file as placeholders. 

By default, there is no header (header size = 0). You 

can enter a header when you open the file in the 

Raw format (see “Opening Raw files” on page 43). 

You can also save the file without a header and 

then use a file-editing program, such as Norton 

Utilities  (Macintosh) or HEdit (Windows), to 

replace the zeros with header information. 

You can choose to save the image in an interleaved 

or noninterleaved format. If you choose the inter-

leaved format, the color values (red, green, and 

blue, for example) are stored sequentially. The 

choice you make depends on the requirements of 

the application you plan to use to open the file. 

Targa 

The TGA (Targa®) format is designed for use on 

systems that use the Truevision  video board and 

is commonly supported by MS-DOS color appli-

cations. If you are saving an RGB image in this 

format, you can choose the color depth you want.
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TIFF 

The Tagged-Image File Format (TIFF) is used to 

exchange files between applications and computer 

platforms. The TIFF format supports LZW 

compression, a lossless compression method that 

does not discard detail from the image.

When you save an Adobe Photoshop image in 

TIFF format, you can choose to save in a format 

that can be read either by Macintosh or by IBM 

PC-compatible computers. You can also choose to 

compress the file to a smaller size automatically by 

clicking the LZW Compression check box.

Placing Photoshop images in 
other applications
Photoshop supports several features that help you 

use images in other applications. If you’re using a 

Macintosh, the Edit Graphic Object (EGO) 

AppleEvent feature lets you embed Photoshop 

images in certain word-processor files.

Embedding Photoshop images in word-
processor applications (Macintosh only)

Adobe Photoshop supports the EGO AppleEvent, 

which allows the embedding of Adobe Photoshop 

images in word-processor files. 

Word-processor applications that work with EGO 

include Full Write Professional™, Nisus, MacWrite 

Pro®, WordPerfect®, and Claris® Works™.

To use the Edit Graphic Object (EGO) AppleEvent to 
update images in word-processor files:

1 Paste the Photoshop image into your word-

processor file. 

2 Double-click the image in your word-processor 

application to launch Adobe Photoshop (if it is not 

already running) and open the image for editing. 

3 When you have finished making changes, close 

the Photoshop file to update the image in your 

word-processor application.



11





217

Chapter 11: Printing

n most instances, the default print settings in 

Adobe Photoshop Limited Edition produce 

excellent results. However, depending on the 

type of image you want to print and your output 

device, you may want to adjust the print settings. 

This chapter provides an overview of the basic 

concepts of printing and describes how to print 

using the Adobe Photoshop program, including 

how to select screen attributes for halftones.

Printing: An overview
The most common way to output images is to 

produce a positive or negative image on paper or 

film, print prepress proofs, and then transfer the 

image to a printing plate to be run on a press. 

Note: Generally, for best printing results, use the 

latest printer software available for your printer and 

your operating system.

About halftones

To produce the appearance of continuous tone in 

an image, the image must be broken down into a 

series of dots. These dots are created during the 

printing process when a halftone screen is applied 

to the image. The dots in a halftone screen control 

how much ink is deposited at a specific location. 

Varying the size and density of the dots creates the 

optical illusion of variations of gray or continuous 

color in the image. For a process color image, 

four halftone screens are used: cyan, magenta, 

yellow, and black—one for each ink used in the 

printing process.

I

Halftone screen with black ink

450

00
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In traditional print production, a halftone is 

produced by placing a halftone screen between 

a piece of film and the image and then exposing 

the film. In Adobe Photoshop, you specify the 

attributes for the halftone screen immediately 

prior to producing the film or paper output. To 

achieve the best results, the output device you use, 

such as a PostScript imagesetter, should be set to 

the correct density limit, and the processor should 

be properly calibrated. If these factors are incon-

sistent, the results can be unpredictable. 

Setting up to print

To print any type of image in Adobe Photoshop, 

you first select the printing options you want and 

specify settings for the particular image type. 

Important: Photoshop always prints images at the 

center of the page—you cannot change the position 

of the artwork to print it at a different location on the 

page. If you want to print an image at a precise 

location on a page, you must export it to a page-

layout program and reposition it there.

By default, Adobe Photoshop prints all visible 

layers. To print an individual layer, make it 

the only visible layer before choosing the 

Print command. 

General printing options
For any type of image you print, you can choose 

to print page crop marks. You can also select a 

background color for the image. 

A. Crop marks

ccactus.ai

A
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These printing options appear in the Page Setup 

dialog box, which appears when you choose File > 

Page Setup. The exact appearance of this dialog 

box varies with different printers. In general, on 

the Macintosh, the top half of the Page Setup 

dialog box contains the standard printing options 

for paper type, printer effects, reduction and 

enlargement, and orientation. In Windows, some 

print features are available in the File > Page Setup 

dialog box; others, such as reduction and 

enlargement options, are available in the 

Properties dialog box (choose Start > Printers and 

select your printer; then choose File > Properties). 

See your printer documentation for more infor-

mation on these options. 

Not all options are available for all printers. 

For example, if you are printing to a non-

PostScript printer, the Calibration Bars option 

is not available.

Previewing the page layout

To preview the results of your printing options, 

click the page preview box at the lower left of the 

window. The box with the x in it represents the 

image. Note that Photoshop always prints images 

from the center of the page (you can’t adjust the 

image to print on another part of the page). 

See “Previewing the page layout and print size” on 

page 31 for more information on the page 

preview feature.

Speeding up landscape printing

Adobe Systems recommends that, rather than 

using Landscape orientation, you rotate the image 

90 degrees by choosing Image > Rotate Canvas, 

choose an option from the submenu, and then 

print using Portrait orientation. Depending on the 

printer and printer software, printing a page with 

the Portrait setting can be much faster than 

printing with the Landscape setting.

Setting additional page setup options

In the Page Setup dialog box, click the Options 

button or the Properties button (the button name 

varies with different operating systems) to set 

specific options for the printer you have selected. 

For more information on using the printing 

options, see your printer documentation.

Printing crop marks 

The Crop Marks option in the Page Setup dialog 

box prints crop marks that indicate where the page 

is to be trimmed. You can choose to print crop 

marks at the corners of the image, at the center of 

each edge of the image, or both.

Printing calibration bars 

The Calibration Bars option in the Page Setup 

dialog box prints an 11-step grayscale. The steps 

represent a transition in density from 0 to 100% in 

10% increments.
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Using interpolation

Some PostScript Level 2 printers can reduce the 

jagged appearance of a low-resolution image by 

automatically resampling up an image while it is 

printing. If your printer does not have this 

capability, this option has no effect.

Printing a border 

You can specify the width of a border you want to 

have appear around an image by using the Border 

button. The border is printed in black. 

To specify the width of a border: 

1 Click Border in the Page Setup dialog box.

2 For Width, enter a value for the width of the 

border; then choose a unit of measurement and 

click OK. You can specify decimal values for 

the width.

Selecting a background color

The Background button in the Page Setup dialog 

box lets you select a background color to be 

printed on the page outside the image area. This 

option is especially useful if you are printing slides 

to a film recorder, because a black or colored 

background is often desirable for slides. To use this 

option, click Background; then select a color from 

the Color Picker dialog box. The Background 

option is a printing option only and does not affect 

the image area itself.

Selecting halftone screen 
attributes 
Halftone screen attributes include the screen 

frequency and dot shape for the screen used in the 

printing process. Check with your print shop for 

the preferred frequency, angle, and dot settings 

before creating your halftone screens. (In general, 

the default angle settings should be used unless 

your printer specifies that they be changed.) 

If you are printing to a color printer, Adobe 

Systems recommends that you use the printer’s 

default halftone screen settings.

To use default screens for a color printer:

1 Click Screen in the Page Setup dialog box.

2 Select Use Printer’s Default Screens.

To define the screen attributes: 

1 Click Screen in the Page Setup dialog box. 

2 Deselect Use Printer’s Default Screens, and set 

the screen frequency and angle for the screen. 

The screen frequencies and angles for grayscale 

halftones are discussed in the sections following 

this procedure.

Note: To use the default halftone screen built into 

the printer, select Use Printer’s Default Screens. 

The specifications from the Halftone Screens dialog 

box are then ignored when the halftone screens 

are generated. 
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3 For Shape, choose the dot shape you want. 

Choosing Custom from the Shape menu displays 

the Custom Spot Function dialog box, which lets 

you define your own dot shapes by entering 

PostScript commands. The Custom Spot Function 

is useful for printing with nonstandard halftone 

algorithms. For information about using 

PostScript language commands, consult the 

imagesetter’s manufacturer.

For optimal printing, the image resolution should 

be twice the halftone screen frequency. If the 

resolution is more than 2.5 times the screen 

frequency, Adobe Photoshop displays an alert 

message. See “About resolution and image size” on 

page 25 for more information.

Selecting screen attributes for a 
grayscale halftone

For a grayscale image, enter a screen frequency 

from 1 to 999.999 for Frequency; then choose the 

unit of measurement you want.

For Angle, enter a screen angle from –180 to +180 

degrees.

Saving and loading halftone screen 
settings

You can save your halftone screen settings for

use with other Adobe Photoshop files by clicking 

the Save and Load buttons in the Halftone Screens 

dialog box. To save the new settings as the default, 

hold down Option (Macintosh) or Alt (Windows), 

and click the —> Default button. To return to the 

original default settings, hold down Option/Alt 

and click <—Default. 

Additional printing options
You can also set printing options by using the Print 

dialog box, which appears when you choose File > 

Print. These options let you print only a selected 

area of an image, transfer image data to the output 

device in ASCII format, print a color-corrected 

composite image on a color printer, and create an 

EPS or PostScript file. The appearance of this 

dialog box varies with different printers.
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Printing a selected area

You can print a rectangular selection of an image.

To print a selected part of an image: 

1 Use the rectangular marquee tool to select the 

part of an image you want to print.

2 Choose File > Print.

3 In the Print Range options, click Selection; then 

click OK.

Printing with print spoolers and 
across networks (PostScript printers)

If you have a PostScript printer, you can choose to 

transfer information to printers in either binary 

(the Macintosh default) or ASCII (the Windows 

default) format.

Some print spooler programs, computer 

networks, and third-party printer drivers don’t 

support files that are binary-encoded, and some 

PostScript output devices accept binary-encoded 

image data only through their AppleTalk® and 

Ethernet ports, and not their parallel or serial 

ports. In these situations, you can choose to 

transfer the file in ASCII format. 

Files that are encoded in ASCII format require 

about twice as much time to transfer as binary 

files, because they contain about twice as many 

characters. 

To select a binary or ASCII encoding option:

1 Choose File > Print.

2 Choose Adobe Photoshop from the pop-up 

menu. 

3 Choose an Encoding option and click OK.
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Appendix A: Improving Performance

program’s “performance” is the amount of 

time that it takes the program to complete 

certain operations, such as opening a file, 

sending a file to a printer, or redrawing the screen 

after you edit an image. 

To a great extent, your computer processor speed 

and the amount of RAM you have affect the 

performance of Adobe Photoshop Limited 

Edition. Other factors that can dramatically affect 

the application’s performance are how you set up 

your software, how you use virtual memory, and 

the size and complexity of your files.

This appendix explains how best to configure your 

system for optimal performance, and how Adobe 

Photoshop uses memory. The appendix also 

explains how to improve performance by 

minimizing the size of your files and making 

efficient use of Photoshop’s features. 

Using RAM, scratch disks, and 
system virtual memory
The best way to improve performance when using 

Adobe Photoshop is to increase the amount of 

random access memory (RAM) installed on your 

system. Testing at Adobe Systems has shown that 

increasing the amount of installed RAM tremen-

dously improves the overall performance of Adobe 

Photoshop. 

Determining the amount of RAM required

The amount of RAM that Photoshop requires 

depends on numerous factors, including the pixel 

dimensions of your image (see “Determining 

image size and resolution” on page 25), its color 

mode (see Chapter 3, “Choosing a Color Display 

Mode”), the number of layers in the file (see 

Chapter 8, “Using Layers”), as well as on the 

operations you’re performing. Copying part of an 

image or performing other operations in 

Photoshop may require 2 to 3 times the image size 

in RAM. 

In most cases, it’s a good idea to give Photoshop at 

least 3 to 5 times your file size in RAM, plus about 

5 to 10 MB. 

The RAM available to Photoshop is determined in 

the following ways:

• On the Macintosh, Photoshop is set to a default 

application size determined by the type of 

Macintosh you have. If you have more RAM 

available, you can increase the amount of RAM 

allocated to Photoshop in the Finder. See “Increase 

the application memory size” on page 229 for 

instructions.

A
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• In Windows, Photoshop’s default setting 

allocates 50% of available RAM (RAM not being 

used by the operating system or by disk-caching 

software) for its own use. You can change this 

amount in the Memory & Image Cache Prefer-

ences dialog box (choose File > Preferences > 

Memory & Image Cache).

Note: In Windows NT, a RAM setting of 70% or 

lower may improve performance. To achieve optimal 

performance, experiment with different RAM 

settings.

Determining the amount of scratch disk 
space required

When your system does not have enough RAM to 

perform an operation, Adobe Photoshop uses 

virtual memory, also called the scratch disk. Virtual 

memory is disk space used for storing data during 

a work session when the amount of RAM is insuf-

ficient. The Photoshop virtual memory 

technology lets you open and manipulate large 

images by swapping image data to a hard drive 

if there is not enough RAM to contain the data. 

Keep in mind, however, that copying data to and 

from the scratch disk requires significantly more 

time than processing files in RAM. Allocating 

enough RAM to Photoshop to avoid using the 

scratch disk will keep Photoshop operating at 

peak performance.

Whether or not Photoshop is using the scratch 

disk, the amount of free space on the scratch disk 

must be greater than or equal to the amount of 

RAM you have allocated to Photoshop. To ensure 

good performance, Photoshop writes the entire 

RAM contents to the scratch disk during idle 

times. If the scratch disk runs out of free space, 

Photoshop quits taking additional RAM—

regardless of what you have allocated to the 

program. This means that if you’ve allocated 60 

MB to Photoshop but you have only 10 MB of free 

space on your scratch disk, Photoshop will use 

only 10 MB of RAM.

Assigning scratch disks

By default, Photoshop uses the hard drive that the 

operating system is installed on as its primary 

scratch disk. You can change the primary scratch 

disk or designate a secondary scratch disk, to be 

used when the primary disk is full. Your primary 

scratch disk should be your fastest hard disk, and 

should have plenty of defragmented space 

available. 

The following guidelines can help you assign 

scratch disks:

• For best performance, scratch disks should be on 

a different disk than any large files you are editing.

• Scratch disks should be on a different disk than 

the one used for the Macintosh or Windows 

virtual memory.
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• Scratch disks should be local. That is, they 

should not be accessed over a network.

• Scratch disks should be conventional (non-

removable) media.

• Raid disks/disk arrays are good choices for 

dedicated scratch disk volumes.

• Scratch disks should be defragmented regularly.

To change the scratch disk assignment:

1 Choose File > Preferences > Plug-Ins & Scratch 

Disks.

2 Select the desired disk from the menu. Then 

restart Adobe Photoshop for the change to take 

effect.

Important: Adobe recommends that you use a disk 

tool utility, such as Norton Utilities or Defrag, to 

optimize and defragment your hard drive on a 

regular basis. See your Macintosh or Windows 

documentation for information. 

Using the operating system’s virtual 
memory

In addition to Photoshop’s virtual memory, both 

Apple System software (version 7.5 or later 

required for the Macintosh) and Windows use 

their own virtual memory schemes. These virtual 

memory schemes swap active application 

programs to a hard disk when there is not enough 

RAM to hold them all simultaneously. Increasing 

the system virtual memory will not speed up 

operations within Photoshop; it may, in fact, take 

needed scratch disk space from Photoshop and 

seriously degrade performance. Use the following 

guidelines for setting up system virtual memory:

• On the Macintosh, turn off System 7 or 8 virtual 

memory. See “Disabling virtual memory on the 

Macintosh” on page 230 for instructions.

• On Windows, if you have plenty of RAM for 

Photoshop (see “Determining the amount of 

RAM required” on page 225), you should 

manually set the Windows swap file to twice the 

amount of installed RAM. See “Increase the virtual 

memory allocation” on page 231 for more infor-

mation.
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Displaying file size and memory 
status
The display in the lower left of the window lets you 

view different information related to disk space 

and memory. It’s important to note that the 

amount of data in an image and the amount of 

RAM that Photoshop is using to process the image 

may be very different values. 

To display file size and memory status:

1 Move the pointer to the  in the lower left of 

the window, and hold down the mouse button.

2 Choose from the following options:

• Document Sizes to display information on the 

amount of data in the image. (See the following 

section for more information.)

• Scratch Sizes to display information on the 

amount of RAM used to process the image. See 

“Scratch sizes” on page 229 for more information.

• Efficiency to display the percentage of 

Photoshop operations being performed using 

RAM (as compared to using scratch disk space). 

An Efficiency display below 100% indicates that 

Photoshop is using the scratch disk and so is 

operating more slowly than if only RAM were 

being used. See “Determining the amount of 

scratch disk space required” on page 226 for infor-

mation on the scratch disk.

• Timing to display the amount of time it took to 

complete the last operation. 

Document sizes 

When you display Document Sizes, the number on 

the left represents the printing size of the image—

that is, the amount of data that will be sent to a 

printer if you print the file. The printing size is the 

same as the saved, flattened file in Adobe 

Photoshop format; however, it is usually 

somewhat smaller than the uncompressed file size 

on disk. This discrepancy is caused by other 

factors—such as your preview options and the 

type of disk you have—which can add to the size 

of the file on disk. On the other hand, if you save 

in a compressed format, such as JPEG, the printing 

size displayed here may be significantly larger than 

the file size on disk.

A. Amount of data sent to printer
B. Amount of data including layers

BA
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The number on the right indicates the file’s 

approximate size in its layered format. This 

number is usually greater than the file size on disk 

because Photoshop is able to compress certain 

data when it saves the file to disk. The larger the 

image, the greater the difference between this 

number and the saved file size. For more infor-

mation on how layers affect file size, see “Keeping 

track of file sizes” on page 174.

Important: If the 2.5 Format Compatibility option 

is turned off in the Saving Files Preferences dialog 

box (it’s on by default), the saved file size will be 

significantly smaller with layered files because the 

2.5 compatibility option saves a flattened version of 

the file with the layered file. Some applications, such 

as Adobe Illustrator, can open only a flattened 

version saved in the Photoshop format.

Scratch sizes

When you display scratch sizes, the number on the 

left represents the amount of memory that is 

currently being used by the program to display all 

open images, including layers and any information 

on the Clipboard.

A. Memory required for all open images and Clipboard
B. Total RAM available to Photoshop

The number on the right represents the total 

amount of RAM available for processing images. 

This number is equal to the amount of memory 

available to Photoshop minus the amount that 

Photoshop needs to run. See “Determining the 

amount of RAM required” on page 225 for more 

information.

With Scratch Sizes, when the number on the left is 

greater than the number on the right, Photoshop 

is using the scratch disk in addition to RAM. 

At this point, you’ll probably notice a dramatic 

decline in Photoshop’s performance because 

Photoshop must read and write files to the scratch 

disk. See “Determining the amount of scratch disk 

space required” on page 226 for more information.

Additional tips for improving 
performance on the Macintosh
You can optimize Adobe Photoshop’s performance 

on the Macintosh by changing a variety of system 

settings.

Increase the application memory size

If your computer has more RAM than Photoshop’s 

default RAM allocation, you can significantly 

improve Photoshop’s performance by increasing 

the application memory size. See “Determining 

the amount of RAM required” on page 225 for 

more information.

BA
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To change the application memory size:

1 Start all applications—except Adobe 

Photoshop—that you must use at the same time as 

Adobe Photoshop. Keep in mind, however, that 

running other applications with Photoshop uses 

RAM that could be allocated to Photoshop.

2 Return to the Finder. Choose About This 

Computer from the Apple menu. 

3 Note the Largest Unused Block value. (You will 

use this result in step 5.) This value shows the 

amount of memory currently available. 

4 In the Finder, select the Adobe Photoshop LE 

program icon (not the folder or the alias icon), and 

choose File > Get Info. 

You cannot increase the application memory size 

while Photoshop is running.

5 In the Adobe Photoshop LE Info window, set 

the Preferred Size option to no more than 90% 

of the Largest Unused Block value you noted 

in step 3. 

Important: Using RAM Doubler™ will improve 

performance when running Photoshop with other 

applications. However, Photoshop’s memory 

allocation must be based only on installed RAM.

6 Close the Adobe Photoshop Info window. 

Disabling virtual memory on the 
Macintosh

In addition to Photoshop’s virtual memory, both 

Windows and Apple System software (version 

7.1.2 and later) use their own virtual memory 

technologies. These swap active application 

programs to a hard disk when there is not enough 

RAM to hold them all simultaneously. Using the 

system virtual memory in the Mac® OS won’t 

speed up operations in Photoshop. In fact, it will 

take needed scratch disk space from Photoshop 

and seriously degrade performance. Use the 

following guidelines for setting up system virtual 

memory: 

Unless you don’t have enough memory to run 

Photoshop otherwise, Adobe strongly recom-

mends that you turn off virtual memory for much 

better performance with Photoshop. (For instruc-

tions on using the Memory control panel, see your 

Mac OS documentation.)

Turn on the Modern Memory Manager in 
the Memory control panel

Adobe Photoshop is designed to use the Modern 

Memory Manager in System 7.5.1 and later. This 

capability enables applications to use more than 8 

MB of RAM, thus allowing a larger portion of a file 

to be stored in RAM instead of on a comparatively 

slower hard disk. 

Only if RAM is so limited that Photoshop cannot 

run, it may be useful to turn on virtual memory to 

prevent RAM from being used up by the appli-

cation code. Set the virtual memory to 1 MB more 

than physical memory.
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If RAM is not this limited, Adobe strongly recom-

mends that you turn off virtual memory in System 

7 or later as described in “Using the operating 

system’s virtual memory” on page 227.

Decrease the disk cache setting

The disk cache setting in the Memory control 

panel sets aside memory for common operating 

system tasks. Adobe Systems recommends that you 

set the disk cache to a maximum of 128K. If you 

have limited RAM allocated to Photoshop, setting 

the disk cache higher may significantly degrade 

Photoshop’s performance.

To set the disk cache size:

1 Choose Control Panels > Memory from the 

Apple menu.

2 If necessary, click the arrow keys to change the 

disk cache size to no higher than 128K.

3 Close the Memory control panel.

Turn off system extensions and control 
panels

Like any application running at the same time as 

Photoshop, system extensions and control panels 

use RAM that could be allocated to Photoshop. If 

you are running Photoshop with limited RAM, use 

Extensions Manager to turn off as many exten-

sions and control panels as possible, or run with 

the Mac OS Only or Mac OS Base extension 

presets. See your Macintosh documentation for 

instructions.

Additional tips for improving 
performance with Windows
The first time you launch Adobe Photoshop, 

the program automatically checks the amount of 

RAM and warns you if you need to change the 

virtual memory allocation. By default, Adobe 

Photoshop allocates 50% of all available RAM 

(that is, RAM not being used by the operating 

system or by disk-caching software) for its 

own use.

Increase the virtual memory allocation

Although you can’t improve the performance 

of Photoshop operations by increasing the 

Windows virtual memory allocation, adequate 

virtual memory lets Windows swap Photoshop 

out of RAM when launching other applications, 

performing other Windows operations, or 

printing.

Windows manages its own virtual memory, by 

default. However, you can manually adjust 

amount of memory you assign to the Windows 

virtual memory disk, called the permanent swap 

file (or Paging File in Windows NT), as follows:

• In Windows 95, select the option to Let Me 

Specify My Own Virtual Memory Settings; then set 

the swap file to at least the size of virtual memory, 

and preferably, to double the RAM. 

• In Windows NT, set the initial size of the 

Windows Paging File to the amount of your 

installed RAM plus 12 MB. For the Maximum size, 

enter twice the amount of installed RAM. 
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If more memory is needed to run other applica-

tions at the same time as Photoshop, you can lower 

the percentage of RAM allocated to Adobe 

Photoshop in the Memory & Image Cache Prefer-

ences dialog box. Adjusting the RAM percentage 

will probably degrade the program’s performance, 

but it may make it easier to run other applications 

with Adobe Photoshop.

For more information on increasing the virtual 

memory setting in Windows, see your Windows 

documentation.

Tips for working efficiently
In addition to the amount of RAM and your 

system configuration, the single most important 

factor affecting performance is the size of your 

files. File size is determined chiefly by the pixel 

dimensions of an image and its color mode (see 

“Determining image size and resolution” on 

page 25 and “Color modes and models” on 

page 53). In addition, the number of layers in an 

image can significantly increase file size. 

Minimize file size

The most important factor in determining file size 

is the pixel dimensions of the image. If you are 

preparing your image for printed output, make 

sure that the print resolution and dimensions are 

the size you need for your final file. In general, the 

recommended image resolution is 1.5 to 2 times 

the screen frequency you will use to print the 

image. See “Screen frequency and image 

resolution” on page 29 for more information. 

Also, merge layers as you no longer need them. 

Layers may add significantly to the size of the file.

Clear data from RAM

The images and selections you cut or copy to the 

Clipboard are stored in RAM. Keeping large 

amounts of data in RAM can significantly degrade 

Adobe Photoshop’s performance. 

To clear cut and copied data from RAM:

Choose Edit > Purge and then choose an option 

from the submenu:

• Undo to remove from RAM a copy of the image 

before the last-performed operation.

• Clipboard to remove from RAM any data copied 

or cut from an image. 

Note: To avoid filling the Clipboard with data, use 

the program’s drag-and-drop capability to drag 

elements (images, selections, and layers) from 

one file to another or from the Layers palette to 

another file.

Turn off palette previews

The preview thumbnails on the Layers palette can 

be turned off for a slight performance 

improvement. To turn off these previews, choose 

Palette Options from the Layers palette menu and 

select None from the Thumbnail Size options.
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Use shortcuts

Learn to use the command shortcuts that appear 

to the right of the commands in the menus. These 

are especially useful for operations that you 

perform frequently, such as displaying a specific 

command’s dialog box or adjusting color levels. 

For complete information on shortcuts, see the 

Photoshop LE online help. 

Working in two windows

You can save time by using the View > New 

View command to open a second window for 

a document. For example, you can work on a 

magnified version of an image in one window 

while viewing the entire image in a second 

window.

Work on low-resolution copies of files

Another way to save time and space is to create 

a low-resolution version of your file. Be sure to 

give this copy a unique name when you create it 

so that you don’t overwrite your original high-

resolution image.

A low-resolution image is useful for making initial 

editing and color corrections. If you’re adjusting 

color, save the settings by using the Save buttons in 

the color-adjustment dialog boxes. Once you 

know which features and dialog box settings 

produce the results you want, open the original file 

and repeat the steps; then use the Load button to 

apply saved settings to the original file.

Adjust the image cache setting

Photoshop uses a technology called image caching 

to help speed the redraw of high-resolution 

images. With image caching, Photoshop uses 

lower-resolution versions of an image to update 

the image on-screen when performing basic 

operations, such as layering and applying color 

adjustments. You can adjust the image cache 

setting and determine whether or not Photoshop 

uses the image cache to display histograms.

To change the cache settings:

1 Choose File > Preferences > Image Cache.

2 For Cache Levels, enter a value between 1 and 8. 

A higher value results in more caching and quicker 

screen redraw, but also uses more hard disk space 

and RAM, and can increase the time it takes to 

open a file.

If you are working with small files (for example, 

frames of QuickTime movies or screen images), 

you may want to use a Cache Levels setting of 2 or 

3. If you are working with large files (for example, 

files larger than 4096 pixels high or wide), you may 

want to use a setting higher than 4.

3 To increase the speed of histogram displays, 

select Use Cache for Histograms. Selecting this 

option produces a faster, though slightly less 

accurate, histogram display when you choose 

Image > Adjust > Levels.

4 Click OK.
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Appendix B: Troubleshooting

his appendix contains common solutions to 

problems you may encounter when using 

the Adobe Photoshop Limited Edition 

program. 

Before you call Adobe Technical 
Support
There are several steps you can take before calling 

technical support to receive assistance. Performing 

these steps can solve many problems and often 

eliminates the need for telephone assistance.

Reinstall Adobe Phtoshop Limited Edition If you are 

experiencing installation problems, delete all of 

your Photoshop applications files, including the 

preferences file (located in the System 

Folder/Preferences folder on the Macintosh and in 

the Photoshop/Prefs folder on Windows), and 

then try the following:

• Copy the entire Adobe Photoshop 5.0 LE folder 

(Macintosh) or Photosle folder (Windows) from 

the CD-ROM to your hard disk, and then install 

from the hard disk after following the instructions 

in the next paragraphs. 

• On the Macintosh, hold down the Shift key and 

restart to turn off all extensions; then reinstall 

Adobe Photoshop LE.

To reinstall Adobe Photoshop Limited Edition in 
Windows:

1 Uninstall the program by choosing Start > 

Programs > Photoshop 5.0 Limited Edition > 

Uninstall Photoshop Limited Edition.

2 From the Windows Explorer, delete the 

Photoshop 5.0 LE folder and any remaining 

folders under it (the uninstaller doesn't always 

delete all the folders and files), as follows:

• In Windows 95, remove all items from the 

startup group. (Choose Windows\Start 

Menu\Programs\Startup folder.) 

• In Windows NT, remove all items from the 

startup group. (From Windows Explorer, select 

the folder Winnt > Profiles > your login name > 

Start Menu> Programs > Startup, where “your 

login name” is your user name.

You must remove the startup items from the 

username you are logged in as well as from the 

username called All Users. 

3 Reinstall Adobe Photoshop LE.

4 Restart your computer; if you’re running 

Windows NT, restart in VGA mode.

See your Windows documentation for instruc-

tions on deactivating startup software and 

changing restart options.

T
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Check for new software or setting conflicts Very 

often problems with Adobe Photoshop can be 

traced to recent installation of new software or 

utilities that are running at the same time as 

Photoshop. If you have recently installed new 

software or changed other system configuration 

settings, such as your monitor setting, try de-

installing the software or restoring your original 

settings. (If you de-install software, you must also 

reinstall Photoshop following the instructions in 

the previous section. This will ensure that any 

Photoshop files that might have been damaged by 

your new software installation are restored.) If the 

problem disappears, you can try reinstalling the 

problem software or system utility or contact the 

manufacturer for a new version and for compati-

bility information.

Check for an extension conflict On the Macintosh, 

hold down the Shift key and restart the computer 

to restart with extensions off. In Windows, remove 

all items from the startup group and remark out 

the load/run lines in the win.ini file. (See your 

Macintosh or Windows documentation for more 

information on deactivating startup software.) 

If the problem disappears after restarting 

Photoshop, try restarting your computer with 

selected startup items reactivated until you have 

identified the problem software. You can then try 

reinstalling the software, or remove the software 

and contact the software manufacturer for a new 

version and for compatibility information.

Deactivate the preferences file To check whether 

your problem is caused by a corrupted preferences 

file, quit Adobe Photoshop, deactivate the prefer-

ences file, and restart Photoshop. (Deactivating 

the preferences file before starting causes 

Photoshop to generate a new preferences file with 

default settings.)

To deactivate the preferences file on the 

Macintosh, drag the Adobe Photoshop 5 LE Prefs 

file (located in the Preferences folder in your 

System Folder) to the Trash. To deactivate the 

preferences file in Windows, make sure that file 

extensions are displayed, and then rename the 

Adobe Photoshop 5 LE Prefs.psp file (located in 

your Photoshop 5.0 LE/Prefs directory). If the 

problem disappears, delete the preferences. If the 

problem persists, restore the preferences file to its 

original location (Macintosh) or names 

(Windows) to preserve your preferences settings.

Check SCSI device connections Make sure that the 

devices you are using are securely and fully 

connected to your computer, and that device cords 

are not damaged. The cause of the problem could 

be a bad connection.

Important: Be sure to turn off your computer and 

SCSI devices before checking cord connections. 

Failure to do so can damage your hardware.
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Optimize and defragment your hard disk Use a disk 

tool utility, such as Norton Utilities or Scandisk, to 

check whether your hard disk contains bad sectors 

that may be causing the crashes. You can then use 

the Norton Speed Disk or Defrag utility to 

optimize and defragment the hard drive. (Defrag-

menting cleans up any leftover file fragments and 

orders data contiguously so that it can be accessed 

quickly.) For instructions, see the utility’s 

documentation. 

Additional technical support 
resources
For more information about Adobe products and 

services, you can use forums through Internet 

services. Forums vary by country. You can access 

extensive customer support information on the 

Adobe Home Page on the World Wide Web, or on 

the technical support Web page. 

To open the Adobe Home Page, enter the URL 

http://www.adobe.com in your Web browser. To 

launch the Adobe Home Page directly from 

Photoshop LE, choose File > Adobe Online or 

click the icon at the top of the tool bar. 

Setup and performance 
problems

Commands don’t appear in menus; Filter 
(or Import or Export) menu and submenus 
are gray or missing.

Choose File > Preferences > Plug-Ins & Scratch 

Disks, and make sure that you have selected the 

plug-ins folder containing the modules that you 

want to use. Also make sure that all the plug-ins 

you want to use are within a single umbrella folder. 

Although you can nest plug-ins in folders within 

folders, you can select only one umbrella plug-in 

folder at a time. See Chapter 1, “Looking at the 

Work Area” for information on choosing the plug-

ins folder.

Tool icons don’t change when another 
tool is selected.

This problem may occur with some Windows 

video card drivers that conflict with the Photoshop 

application. Contact the card manufacturer for an 

updated driver.



APPENDIX B238
Troubleshooting

Operations seem unusually slow, or out-
of-memory messages appear frequently.

Your system settings—such as the amount of RAM 

and use of the system’s virtual memory—may be 

slowing down Adobe Photoshop operations. For 

information on setting up RAM and virtual 

memory in Photoshop and for other tips on 

improving performance, see Appendix 

A, “Improving Performance.” 

Scratch disk full messages appear.

This error usually occurs when you are low on 

hard drive space, which Photoshop needs to 

process your images. Choose File > Preferences > 

Plug-Ins & Scratch Disks to determine where your 

scratch disks are located. Then use Windows 

Explorer or the Mac OS Finder to determine the 

amount of space available on those hard drives. Set 

the primary scratch disk space to a drive which 

contains contiguous free space that equals at least 

3 to 5 times the size of your document in 

Photoshop.

For more information on the scratch disk, see 

“Determining the amount of scratch disk space 

required” on page 226.

Space on hard disk appears lost.

If a system error occurs when a Photoshop file is 

open, the system creates a temporary (.tmp) file to 

hold the information about the open images. 

Normally, the temporary file is deleted when you 

quit the program. However, sometimes when the 

system crashes the file is not deleted. On the 

Macintosh these temporary files are automatically 

placed in the Trash. 

To restore the hard disk space on your Macintosh, 

empty the Trash to delete the temporary files. For 

more information, see your Macintosh documen-

tation.

To restore the hard disk space in Windows, search 

for *.tmp (all files with a .tmp extension) on all 

hard drives from the root directory, including 

subfolders. Then delete the .tmp files and run the 

Scandisk utility. (Note that you will not be able to 

delete the active Windows .tmp file.) 

For more information, see your Windows 

documentation.

Problems with image 
appearance

Painting tools don’t work.

Painting tools work only on the target layer and 

inside areas that are parts of the current selection 

or when no part of the layer is selected. 

Check to make sure that you are not painting 

outside a selected area. Check to make sure that 

you have not previously hidden the edges of the 

selection by pressing Command/Ctrl+H. If you 

are painting outside a selected area, choose Select > 

None to deselect everything or Select > Inverse to 

switch the selected and unselected areas. 

You might also be attempting to paint or fill a layer 

that has the Preserve Transparency option 

selected. In this case, painting is limited to the 

areas of the layer that contain pixels. Deselect this 

option in the Layers palette to edit anywhere on 

the layer.
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The pointer disappears (Macintosh only).

Try either disabling or enabling the Direct Cursors 

extension in the Extensions folder. To turn off the 

extension, first create a new folder; then drag the 

Direct Cursors extension out of the Extensions 

folder (located in the Plug-Ins folder) and into a 

new folder. Then restart Adobe Photoshop.

Brush Size icon doesn’t work at all brush 
sizes (Macintosh only).

Reinstall the Director Cursors plug-in by dragging 

it from the Adobe Photoshop Application CD to 

the Extensions folder within the Plug-Ins folder.

Only 16 pixels are available for the brush 
size (Macintosh only).

Disabling the Direct Cursors extension restricts 

the number of pixels available for the brush size. 

To fix this problem, turn on the Direct Cursors 

extension by placing it in the Extensions folder 

within the Plug-Ins folder. 
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Index

A

Actual Pixels command 17

Adaptive Palette option 61

Add Layer Mask command 170

Add Noise filter 183

additive colors 54

adjustment layers

for color corrections 67

Adobe Acrobat 212

Adobe Home Page 20

Adobe Illustrator

artwork compared to 

Photoshop artwork 23–24

Adobe Online 20

Adobe Premiere 210

Adobe technical support 2

Adobe Type Manager (ATM) 120

airbrush tool 128

aligning type 123

Alignment options 123

Amiga Interchange File Format 

(IFF) 211

Amount option 84

Angle option 134

animation 68–69

Anti-aliased option

for selections 103

for type 122

Anti-aliased PICT format 41

Apple Color Picker (color wheel) 

148

application memory size 229–230

Arbitrary Map option, in Curves 

dialog box 80

arrowhead options 129

Auto Erase option 131

Auto Levels command 57, 77

B

background color

Background Color option 46

choosing 127, 145

editing with Color palette 143

filling selections with 141

filling with 46

printing 220

selecting with eyedropper tool 

142

backgrounds

adding to an image 163

and layers 153

converting into a layer 163

definition 153

deleting 163

duplicating 163

moving 159

base color 136

Beep When Done option 109

Behind mode 137

Bicubic interpolation option 37

Bilinear interpolation option 37

bit depth 56, 57

bit resolution 25, 61

bitmap images 23, 55, 60

Bitmap mode 54, 58–60

bitmapped type 120

black and white points

setting 80–81

Black Body color-table option 63

black point value 76–77

bleeds 220

blend color 136

blending modes

explained 136–139

layers and 163

Blur filters 183

blur tool 119

BMP file format 210

borders 220

around a selection 101

brightness

adjusting 86

Brightness/Contrast command 

86

equalizing 87

explained 53

Brush Options command 133

brushes

Brushes palette 131

choosing 131, 132

creating 132

customizing 132–135

deleting 132

saving, loading, and replacing 

134

setting and loading options 133

bump maps 193

burn tool 119
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C

Calibration Bars option 219

canceling operations 109

Canvas Size command 48–49

Cascade command 15

channels

bit depth 57

explained 55

mask channel for layer mask 173

chroma 53

Clear command 114

Clear mode 137

Clipboard 109–110, 114, 232

Export Clipboard option 114

preferences 114

saving contents when quitting 

114

clipping groups for layers 168

Clone options 117

color balance 81–83

Color Balance command 82

color bar 144

color casts

correcting 40, 77, 81–83

identifying 81

in scanner 40

removing from images 78

color corrections

adjusting contrast 80

adjusting highlights, shadows, 

and midtones 80–81

applying to other images 70

automatic 77

brightness and contrast 

adjustments 86

color balance adjustments 81–83

generalized 85–86

highlight and shadow 

adjustments 73–78

midtone adjustments 78–79

previewing 68–70

removing color casts 78

sharpening images 83–85

special-purpose tools for 87–89

tonal range check 70

using tools and commands for 

67

color depth. See pixel depth 25

color lookup table 56

Color mode option 138

color models

explained 53

HSB model 53

RGB model 54

color modes

Bitmap mode 54

converting images between 57

explained 53

Grayscale mode 54

Indexed color mode 55

RGB images 54

Color palette 56, 143–144

Color Pickers

Adobe Photoshop 146–147

Apple 148

Color Picker option 146, 148

plug-in 149

using to set printing background 

220

Windows 148

color readout values 144

color slider 147

color table animation 68–69

Color Table command 60, 62

Color Table dialog box 62

color tables

editing colors in 62

saving and loading 63

setting options for 63

color values

measuring 55

previewing 69–70, 144

specifying 144, 147

color wheel 82, 148

Colorize option 82, 83

colors

changing midtones 119

inverting 87

column width, setting 112

commands

Commands palette 109

missing 237

See also  names of individual 

commands

compressing files

using JPEG format 211

using LZW 214

using TIFF format 214

CompuServe GIF file format 211

Constrain Proportions options 44

Constrained Aspect Ratio option 

94

Contents options 45

context menus 14

contrast 86

control panels 231

converting

backgrounds into layers 163

between color modes 57–62

convolution 185
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copying

and pasting 114

between applications 113–114

layers between images 160–162

selections 112

copying. See also duplicating

correcting mistakes 109–110

reverting to saved image 110

undoing last action 109

creating

brushes 132

gradient fills 140

images 45

layers 155–156

Crop command 46

Crop Marks option 219

Crop tool 46, 47

cropping images 46–48

Curves dialog box 80–81

Custom color-table option 63

Custom filter 185–186

Custom Palette option 61

Custom Spot Function dialog box 

221

Cut command 114

D

Darken mode 138

data transfer, initiating 38

defaults

interpolation method 37

restoring palette positions 12

restoring preferences 20

restoring tool settings 13

Define Brush command 132

Defrag utility 227, 237

De-Interlace filter 184

Delete Layer command 165

deleting

backgrounds 163

brushes 132

colors from swatch sets 145

layers 163, 165

selections 111, 114

type characters 123

deselecting

selections 93

deselecting. See also selecting

dialog boxes. See names of 

individual dialog boxes

Diameter option 133

Difference mode 138

Diffusion Dither option 57, 59, 62

Direct Cursors extension 239

directional light effect 190

disk cache setting 231

disk drive. See hard disk

Displace filter 187

displacement map 187

Display & Cursor preferences 57

Dissolve mode 137

Distort filters 183

dithering

diffusion 57, 59, 62

pattern 56, 59, 62

specifying options 61

Do Not Apply option for layer 

mask 172

Document Sizes option 31, 228–

229

documentation 1–2

dodge tool 119

dots per inch (dpi) 27

downsampling 32–34

drag-and-drop method 113, 232

drawing

lines 129

Duplicate command 110

duplicating

and saving files 203

backgrounds 163

images 110

layers 160, 163

duplicating. See also copying

Dust & Scratches filter 186

Dynamic Color Sliders option 144

dynamic range 40

E

edge effects 182

editing

background and foreground 

colors 143

color tables 62

layers 163

editing. See also copying, 

correcting mistakes, deleting, 

pasting selections, restoring 

images, transformations, and 

names of individual editing 

tools

Efficiency option 228

8-bit image 57

elliptical marquee tool 94

Encapsulated PostScript (EPS) 

format. See EPS format

EPS format 206, 210

EPS PICT Preview file format 210

EPS TIFF Preview file format 210

Equalize command 87

Erase to Saved option 131

eraser tool 130

erasing 130–131

erasing. See also deleting
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Exact Palette option 60

Exclusion mode 138

Expand command 101

explained 218

Export Caption option 210

Export Clipboard option 114

exporting

Clipboard 114

indexed-color images to GIF 

209–210

RGB images to GIF 207–209

exporting. See also saving

exposure settings 135

extensions conflicts 236

eyedropper options

in Levels dialog box 78

Eyedropper Options palette 69, 73, 

143

eyedropper tool 69, 73, 142, 145

eyedropper-minus tool 209

F

fade-out rate 135

fastening point 96

feathering selections 102–103

file formats

for Adobe Photoshop files 205–

207, 210–214

saving files in various 203

specifying when opening 42

file formats. See also names of 

individual formats

file size

constraining 44

displaying 31, 228

image size and 25

improving performance with 

232

layered documents and 174, 229

minimizing 232

resampling and 32–34

resolution and 29–31

scanning images and 39–40

filename extensions 205

files

opening 41–44

saving 203–207

Fill command 141, 142

Fill dialog box 142

Fill with Neutral Color option 168

filling

layers 141–142

selections 141–142

with background color 141

with foreground color 141

with gradients 140

Filmstrip file format 210

filter dialog box 180

filters

applying to images 179–180

categories 183–184

explained 179

improving performance with 

182

plug-in 179

previewing 179–180

sample gallery 194

shortcuts for 180

special effects tips 182

filters. See also names of individual 

filters

Find Edges filter 194

Finger Painting option 118

Fixed Size option 94

Fixed Target Size option 47

Flatten Image command 176

flattening images 175–176

flipping

images 115

layers and selections 116

focus tools 119

foreground color

choosing 127, 144

editing with Color palette 143

filling selections with 141

selecting with eyedropper tool 

142

freehand selection 95

Frequency option 58

Full Size preview option 204

G

gamma

adjusting 79

Gaussian Blur filter 183

General preferences. See 

preferences, names of specific 

preferences

GIF format

exporting indexed-color images 

to 209–210

exporting RGB images to 207–

209

GIF89a Export module 207

gradient tool 139–140

gradients

applying 140

Graphics Interchange Format. See 

GIF format

Grayscale color-table option 63

grayscale images

color readout values 144

colorizing 83
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converting Bitmap-mode 

images to 60

converting to Bitmap-mode 

images 58

converting to high-contrast 

black-and-white images 88

definition 54

halftone screen attributes for 

221

specifying shades numerically 

144

Grayscale mode 54

Group with Previous Layer option 

169

Grow command 100

H

halftone screens 218

for Bitmap-mode images 58–59

Halftone Screen option 58

Halftone Screens dialog box 220, 

221

saving and loading settings 59, 

221

saving with EPS files 206

selecting attributes for 220–221

hand tool 15

hard disk

optimizing 227, 237

restoring space on 238

Hard light mode 138

Hardness option 133

hidden tools 8

Hide command 10

Hide Edges command 104

Hide Rulers command 111

hiding and showing

layers 157

palettes 10

rulers 111

selection borders 104

High Pass filter 184

high-contrast black-and-white 

images 88

highlights, adjusting 73–78

Histogram dialog box 71

hot spots 9

HSB color model 53

HTML 207, 211

Hue mode 138

Hue slider 83

Hue/Saturation command 82–83

hues

adjusting 82–83

defined 53

hypertext markup language. See 

HTML

I

IFF format 211

image previews 204–205

image resolution

changing 34–35

determining 35–36

displaying information on 31

explained 25–29

file size and 29–30, 232

image size and 25–29

pasting between images and 114

scanning and 39–40

image size

file size and 25

Image Size command 34–37, 40, 

48, 112

Image Size dialog box 32

resolution and 25–29

specifying 34–36

images

adding type to 121

appearance problems 238–239

bit depth 57

changing pixel dimensions 34

converting between color modes 

57–62

copying layers between 160–162

copying selections between 113

creating new 45

cropping 46–48

displaying file size and 

resolution 31

duplicating 110

embedding in word-processing 

applications 214

exporting 207–210

flattening 175–176

importing 41–42

magnifying and reducing 16–18

moving 15, 18

opening 41–42

previewing 31–32

printing 217–222

resampling 32–34

restoring 110

rotating or flipping 115

saving 203–207

scanning 37–41

viewing 14–18

images. See also specific types of 

images

Import command 39, 41, 42

importing

Photoshop images into other 

applications 214

with TWAIN interface 38

importing. See also opening files
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Indexed Color dialog box 61

Indexed color mode. See indexed-

color images

indexed color table 60–63

indexed-color images

converting RGB images to 60–62

dithering options 61

exporting to GIF format 207–

209

manipulating color tables for 62

Info palette

customizing 13

information displayed by 13

measuring color values in 55

previewing color changes in 69–

70

information. See Info palette

Input Levels slider 76–77

installing

instructions for 1

plug-in modules 18

problems with 235

Interlaced option 210

interpolation methods 36–37, 115, 

220

Interpolation option 37

interrupting operations 109

Inverse command 102

Invert command 87

inverting

colors 87

images 87

selection areas 102

J

JPEG format

explained 211

saving files in 206

K

key type 71

Kodak PhotoCD format files 43

Kodak Precision Color 

Management System 

(KPCMS) 43

L

Landscape orientation 219

lasso tools 93, 95, 96, 103

layer mask

adding 169

applying 173

definition 169

discarding 173

editing 170

mask channel 170

removing 173

Layer Via Cut command 156

layers

adding a mask 169

and backgrounds 153

applying filters to 179–180

changing order of 158–159

converting backgrounds to 163

copying between images 160–

162

creating 155–156

definition 153

deleting 165

duplicating 160

editing 163

explained 154

file size and 174, 229

filling 141–142

filling with neutral color 168

flattening 175–176

flipping or rotating 116

grouping 168

hiding and showing 157

Layers palette 154–155

merging 154, 174–175

moving 159–160

opacity 166

options 165

removing a mask 169

renaming 165

saving 176

selecting 155

selections as 156

stroking 142

transparency 164

viewing 156–158

leading 122

Lens Flare filter 184

letterspacing 122, 124

Levels dialog box 70, 73

Levels sliders 76

adjusting 78–79

setting highlights and shadows 

with 76–77

Lighting Effects filter 189–194

Lightness slider 83

line screen. See screen frequency

line tool 129

Line Tool Options palette 13

linear fills 140

lines per inch (lpi) 29

lines, drawing 129

Load Brushes command 135

loading

brushes 135

color adjustment settings 70

color tables 63

halftone screen settings 221

swatch sets 146
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low-resolution files 233

Luminosity mode 139

LZW compression 214

M

Macintosh Drag Manager 113

Macintosh System color-table 

option 60, 63

Macintosh, improving Photoshop 

performance on 229–231

magnetic lasso tool 93, 96

magnifying images 16–18

Make Layer command 163

Marquee Options palette 94, 103

marquee tools 93, 94–95, 103

mask channel

for layers mask 173

Masked Areas option 105

masking, unsharp 84, 85

masks

editing in Quick Mask mode 

104–105

masks. See also Quick Mask mode

Maximum filter 184

measuring

changing ruler units 112

changing units of measurement 

112

color values 55

Memory & Image Cache 

preferences 226

Memory control panel 230

memory. See RAM or virtual 

memory

menu items

missing from display 237

Merge Down command 175

Merge Visible command 175

merging

layers 154, 174–175

midtones 80–81, 119

adjusting 78–79

Minimum filter 184

minus eyedropper 209

mistakes

correcting 109–110

Mode command 58, 60

models. See color models

Modern Memory Manager 230

modes. See blending modes or 

color modes

monitor resolution 26, 27

monitors

adjusting display 55–57

move tool 111

moving

images 15

layers 159–160

palette groups 11

selection borders 98–99

selections 111

toolbox 8

MS Windows 98, scanning images 

38

MS Windows, improving 

Photoshop performance on 

231

multiple copies, creating 112

Multiply mode 137

N

Navigator palette 17

Nearest Neighbor interpolation 

option 37

network printing 222

New Brush command 132

New command 45

New dialog box 45

New Layer button 155

New Layer command 155

New View command 15

Noise filters 183

None command 93

Normal mode 137

Norton Speed Disk 237

Norton Utilities 227, 237

NTSC Colors filter 184

numeric values

previewing for colors 69–70, 144

specifying colors with 144, 147

O

omni light effect 191

online distribution

file formats for 211, 212, 213

online services 20

opacity

layers 166

masks 105

Opacity slider 166

Quick Mask 105

setting 135

type 122

Open As command 41

Open command 41

opening files

Kodak CD format 43

procedures for 41–42

Raw format 43–44

opening files. See also importing

Options palette 12–13

options. See names of individual 

options
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Other Cursors options 9

Other filters 184

out-of-memory message 238

Output Levels slider 79

Overlay mode 137

P

page layout preview 31, 219

Page Setup dialog box 32, 219

Paging File 231

paint bucket tool 139

paintbrush tool 128

painting

multiple copies 118

Painting Cursors options 9

painting options 135–139

painting tools 127–129, 238

Palette Options command 13

palettes 10–14

changing display of 10–12

for converting to indexed-color 

image 60–61

setting position of 12

showing or hiding 10

palettes. See also names of 

individual palettes

Paste command 114

pasting

from Clipboard 114

Pattern buffer 110

Pattern Dither option 59, 62

pattern dithering 56, 59, 62

PCX format 212

PDF format 212

pencil tool 128–129, 131

performance

efficiency tips 232–233

improving for filters 182

improving for Macintosh 229–

231

improving for Windows 231–

232

managing memory to improve 

225–227

problems with 237–238

PhotoCD format files 43

Photoshop EPS format. See EPS 

format

Photoshop format 206

PICT dialog box 44

PICT file format

Clipboard contents 114

PICT format 44, 212

PICT Resource files 41, 44, 212

PIXAR format 213

pixel depth 25, 56, 61

pixel dimensions 25, 26, 34

pixelation 27

pixels

adding to a layer 163

changing image dimensions and 

34

explained 23

interpolating when resampling 

36–37

resolution and 25–27

pixels per inch (ppi) 25

placing images in other 

applications 214

plug-in modules

color pickers 146

filters 179

installing 18

Kodak Photo CD 43

using 18

Plug-Ins & Scratch Disks 

preferences 19

PNG format 213

pointers. See tool pointers

Polygon Lasso Options palette 103

polygon lasso tool 93, 95–96

Portrait orientation 219

Posterize command 89

preferences

beeping 109

Clipboard 114

color picker 144, 146, 148

display options 57

interpolation method 37

palettes 12

plug-in modules 19

Preferences file 20, 236

restoring to defaults 20

rulers 112

saving files 204

setting 20

thumbnail previews 204

transparency 158

units 112

Preserve Transparency option 114, 

164, 238

pressure settings 135

preview icons 204

previewing

color adjustments 68–70

color values 69–70

filters 179–180
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images 204–205

layers 156–158

page layout 31–32, 219

print size 32

turning off 232

Previous Palette option 61

primary colors 54

Print dialog box 221

Print Range options 222

print size

changing 33, 34–35

previewing 31–32

print spoolers 222

printer resolution 27, 29

printing

background color 220

document sizes and 228

general options for 218–220

halftone screen attributes for 

220–221

overview 217–218

selected part of an image 222

problems. See troubleshooting

pseudocolor images 62

Purge command 110, 232

push scanning 38

Q

Quick Mask mode 104–105

R

radial fills 140

Radius option 85

RAM (random access memory)

application memory size and 

229–230

clearing data from 232

out-of-memory message 238

requirements 225

virtual memory and 225–227, 

231

raster images 23

rasterizing 113, 114

Raw format 43, 213

rectangular marquee tool 94

reducing magnification 16–18

reinstalling Adobe Photoshop 235

Remove Layer Mask command 173

renaming

layers 165

Repeat Edge Pixels option 181, 188

Replace Brushes command 135

Resample Image option 32, 34, 35

resampling 32–34

resampling. See also resizing

Reset All Tools command 13

Reset Brushes command 135

Reset Palette Locations to Default 

option 12

Reset Tool command 13

resizing

and resolution 47–49

images 34–35

layer thumbnails 157

resolution, of type 120

resolution. See image resolution, 

monitor resolution, printer 

resolution

restoring images 110

result color 136

Revert command 110

RGB color model 54, 144, 147

RGB images 55

color readout values 144

converting to indexed-color 

image 60

exporting to GIF format 207–

209

specifying colors numerically 

144, 147

Rotate Canvas command 115, 219

Rotate command 116

rotating

for landscape printing 219

images 115, 116

layers and selections 116

Roundness option 134

rubber stamp tool 117

rulers 111–112

Run-Length-Encoding (RLE) 

compression 210

S

Sample Size option 69, 73

sampling

image with rubber stamp tool 

117–118

saturation

adjusting 82–83, 120

defined 53

Saturation mode 138

Saturation slider 83

Save a Copy command 176, 203

Save As command 203

Save Brushes command 135

Save command 41, 203

Save Palette Locations option 12

saving

brushes 134

color adjustment settings 70

color tables 63

files 203–207

halftone screen settings 206, 221

layered documents 176
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preview icons 204

restoring a saved image 110

Saving Files preferences 204

swatch sets 146

saving. See also exporting, file 

formats, file size

Scale command 116

scan resolution 39

Scandisk utility 237

scanning images 45

correcting color casts 40

explained 37

file size setting 39–40

optimizing the dynamic range 

40

quality check 70

scan resolution 39–40

TWAIN interface 38

using Acquire modules 45

scratch disks 226, 238

scratch disks. See also virtual 

memory

Scratch Sizes option 228, 229

screen frequency

Bitmap-mode images and 58

image resolution and 29

setting in photoshop 220–221

Screen mode 137

screen ruling. See screen frequency

scrolling 15

SCSI devices 236

secondary colors 54

Selected Areas option 105

selecting

borders around a selection 101

interpolation method 36

layers 155

parts of a selection 100

tools 5, 8

type characters 122

unselected areas 102

selecting. See also deselecting

selection borders

expanding and contracting 101

hiding and showing 104

moving 98–99

selecting area around 101

selections

adding to 99

adjusting 98–102

applying effects to 115–116

as layers 156

copying between applications 

113–114

copying within Photoshop 112

creating edge effects with 182

deleting 114

deselecting 93

dragging between documents 

113

expanding and contracting 101

extending 100

feathering 102–103

filling 141–142

flipping or rotating 116

freehand 95

hiding or showing borders 104

inverting 102

moving 111

pasting 114

selecting parts of 100

smoothing 100

softening edges of 102–103

stroking 142

subtracting from 99

tools and commands for making 

93–98

setup problems 237–238

shadows, adjusting 79

Sharpen Edges filter 184

Sharpen filters 184

Sharpen More filter 184

sharpen tool 119

sharpening images 83–85

shortcuts

filters 180

selecting tools 9

usefulness 233

zoom tools 17

Show command 10

Show Edges command 104

Show Options command 12

Show Rulers command 111

showing. See hiding and showing

Similar command 100

single column marquee tool 94

single row marquee tool 94

16-bit image 57

size. See image size, print size

smudge tool 118

Soft light mode 138

software conflicts 236

Spacing option

brush 134

type 122

spacing type 122

special effects

applying to selections 115–116

with filters 182

with Posterize command 89
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Spectrum color-table option 63

specular white 73

speed. See performance

sponge tool 119, 120

spotlight effect 191

stacking order

of layers 158

straight-edged selection border 95

Stroke command 142

stroking

selections 142

style options

type 122

Stylize filters 184

stylus pressure options 136

swap file 231

swatch sets

adding and deleting colors 145

saving and using 146

Swatches palette 144–146

system extensions 231

System Palette option 57, 60

T

Tagged-Image File Format (TIFF). 

See TIFF format

Targa format 213

target values

determining 74

entering for color correction 78

setting highlights and shadows 

with 73–76

technical support 235–237

temporary files 238

textures, in Lighting Effects filter 

193

TGA format 213

32-bit addressing capability 230

Threshold command 88

Threshold dialog box 88

Threshold mode 76

Threshold slider 186

Threshold values 85

Thumbnail Size options 232

thumbnails

for layer masks 170

image previews 204

layer 157

turning off 232

TIFF format 214

Tile command 15

Timing option 228

Tolerance values 97, 139

tonal range 70

brightness and contrast 

adjustments 86

fine-tuning 78–79

generalized adjustments 85–86

highlight and shadow 

adjustments 73–78

midtone adjustments 78–79

special-purpose adjustments 

87–89

toning tools 119–120

tool pointers

changing appearance of 9–10

disappearance of 239

hot spots of 9

toolbox

illustrated 5

using 8–10

tools

color correction 67–70

default settings 13

focus 119

marquee 94–95, 103

painting 127–129, 238

selecting 5, 8

toning 119–120

tools. See also individual tool names

Trace Contour filter 194

Transform commands 115

transformations 115–116

transformations.See also flipping, 

rotating, and individual 

transform commands

transparency

preserving on a layer 164

setting preferences for 158

Transparency Index Color 

option 210

Transparent option 46

troubleshooting 235–239

TWAIN interface 38

type 120–124

aligning 123

anti-aliased 122

editing 122

leading 122

letterspacing 122

mode 122

moving 123–124

opacity 122

resolution 120

style options 122

type characters 122–124

type mask 123

type mask tool 120–124

type selection border 122

type tool 120–124

Type Tool dialog box 122–123
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U

Undo command 109–110

Uniform Palette option 60

Units & Rulers preferences 112

Unsharp Mask dialog box 84

Unsharp Mask filter 85, 184

Unsharp masking (USM) 84, 85

Use Printer’s Default Screens 

option 220

V

Variations command 85–86

Variations dialog box 85

vector graphics 23–24

vectors 23

Video LUT Animation option 68–

69, 76, 88

view box 17

viewing

images 14–18

layers 156–158

viewing. See also previewing

virtual memory 226

increasing memory allocation 

for 231

operating system 227

W

Wacom tablet 136

Web Palette option 60

Web publishing. See Adobe Home 

Page, online distribution

Wet Edges option 117, 128, 130

white and black points

setting 80–81

White option 46

white point value 77–78

windows

arranging multiple 15

controlling display of 14

setting position of 12

working in multiple 233

World Wide Web site (Adobe) 20, 

237

Wrap Around option 181, 188

Z

zero origin 111

zoom commands 16

zoom tool 16
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